SSO Error with google

Keywords: OpenEdX - Google Cloud Platform - Technical issue - Credentials
Description:
Hi,
Followed the instructions https://docs.bitnami.com/aws/apps/edx/administration/enable-third-party-auth/
but eventual got the error “Your credentials aren’t allowed”
Please help

Hi @learning,

If the credentials are not allowed is because there is something that was not configured properly. Could you please review the different files and ensure you used the correct credentials.

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

How to Run the Bitnami Support Tool

Please note that you need to paste the code ID that is shown at the end.

Thanks jota for your recommendation. I will install the support tool as suggested. However, it works perfectly with moodle but not with edx. It could be the edx is not configured correctly.
can you please give some hints which files/things I should inspect.
Thanks

The code is: 61e7ceb1-9225-db45-91da-c7623f6001e6

Hi,

Checking at the lms.env.json file, I see no reference to the SOCIAL_AUTH_OAUTH_SECRETS section that is described in the documentation. I am not sure if I’m missing anything. Could you detail the exact steps that you followed?

Best regards,

Javier J. Salmerón


Was my answer helpful? Click on :heart:

Hi, I followed this
https://edx.readthedocs.io/projects/edx-installing-configuring-and-running/en/latest/configuration/tpa/tpa_integrate_open/index.html
Check again many times. Sure it has been properly done!

Hi,

Didn’t the instruction here work either? https://docs.bitnami.com/aws/apps/edx/administration/enable-third-party-auth/

Best regards,

Javier J. Salmerón


Was my answer helpful? Click on :heart:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.