SSL certificate stopped working randomly - how can I debug, and solve this issue?

Keywords: Jenkins - Linux - Technical issue - Secure Connections (SSL/HTTPS)
Description:
My Let’s Encrypt installed certificate has been working perfectly for over a year. Installed using: https://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/ However, today it randomly stopped working.

I’ve tried renewing it, and also re-installing using the install instructions, but nothing works. I have not made any changes to my site. https version of the site shows: “This site can’t be reached error”.

How can I debug this situation to determine what the error is?

Has this happened before when the certificate randomly stops working?

I’m also seeing “unable to get local issuer certificate” when I run openssl s_client -connect mysite:443

Hi @c610524,

Thanks for using Bitnami. We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please download and execute it on the machine where the stack is running by following the steps described in the guide below?

How to Run the Bitnami Support Tool

Please note that you need to paste the code outputted by the tool in your reply.

Regards,
Gonzalo

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.