SSL certificate setup httpd could not be started

Keywords: MEAN - AWS - Technical issue - Secure Connections (SSL/HTTPS)
Description:
After change server.crt into new cert.crt httpd could not be started.
how to solve this?

its urgent please respond me

Hi @sways,

Can you back up the file:

cp cert.crt cert.bak

And then rename it back to server.crt.

mv cert.crt server.crt

And restart apache?

If that doesn’t work, can you download and execute it on the machine where the stack is running by following the steps described in the guide below?

How to Run the Bitnami Support Tool

Please note that you need to paste the code outputted by the tool in your reply.


Please, click on :heart: if you think my answer was helpful

support tool code as follows
6d868d24-2f9f-0a92-fd10-a4c9b8d9f69c

According to the logs the following file can’t be found:

/opt/bitnami/apache2/conf/cert2.crt

Can you edit the /opt/bitnami/apache2/conf/bitnami/bitnami.conf file and change the following line:

SSLCertificateFile "/opt/bitnami/apache2/conf/cert2.crt

To

SSLCertificateFile "/opt/bitnami/apache2/conf/server.crt

And restart apache:

sudo /opt/bitnami/ctlscript.sh restart apache

Please, click on :heart: if you think my answer was helpful

Hi @michiel
Please share details about how to setup ssl certificate i have purchase SSL certificate it contains two files are

filename.crt
gd_bundle-g2-g1.crt
which one i need to upload to /opt/bitnami/apache2/conf folder
what config need do

Please respond me its urgent

I understand that it’s urgent for you, but please note that I’m trying my best to help you, in the context of an online community offering a free service to Bitnami users.

You need 2 files, a file with the .crt extension, which is the certificate, and a file with the .key extension which is the key file. It’s not completely clear to me why you have 2 .crt files. Can you tell me if you also have key file? If not please contact the company that issued the certificate. The following guide contains all necessary information and a video tutorial showing how to set up HTTPS using an existing certificate.

https://docs.bitnami.com/general/apps/wordpress/administration/enable-https-ssl-apache/


Please, click on :heart: if you think my answer was helpful

respond me
http://domain redirects to my app page
https://domain redirects to default page

how to redirects http and https both are to my app page

Hi @sways,

I just reviewed that you have the following lines in your app’s config file

ProxyPass / http://127.0.0.1:80/
ProxyPassReverse / http://127.0.0.1:80/

You app should be running on the port 3000 or any other one. The port 80 is used by Apache. Can you change this file to use the proper port?

https://docs.bitnami.com/aws/infrastructure/mean/administration/create-custom-application-nodejs/

Thanks

Hi jota
I tried with port 3000 but same thing happened
let me help to solve this?

Hi @sways, first of all, were you able to solve your HTTPS certificate issues?

If not, keep in mind you purchased a certificate (crt), but the certificate key file (.key) is usually provided by the user. Then you need to configure Apache (/opt/bitnami/apache2/conf/bitnami/bitnami.conf) to point “SSLCertificateFile” to the .crt file, and “SSLCertificateKeyFile” to the .key file. You may also need to point “SSLCertificateChainFile” to the file “gd_bundle-g2-g1.crt”.

I tried with port 3000 but same thing happened
let me help to solve this?

Your next issue seems to be related to Apache misconfiguration. Keep in mind that our guide describes how to configure a custom Node.js application, and I was able to test it successfully.

Could it be possible you were changing the Apache configuration without restarting Apache? You can do so with the command below:

sudo /opt/bitnami/ctlscript.sh restart apache

NOTE: You should use port 3000 in the ProxyPass, not 80.

hi @marcos
certificate issue solved
http://domain.com showing my app page BUT
https://domain.com showing default bitnami page

Please give me suggestion to solve this

Keywords: MEAN - AWS - Technical issue - Other
bnsupport ID: cd6743f9-b789-fe26-d57e-d7fc61b8045b
Description:
when i access http://domain.com is working correctly showing my app index page
but i try in
https://domain.com
showing default bitnami page
how to config let me know

Please anybody give solution for this i try with different option but did’t get clear

Hi @sways, we checked your file at /opt/bitnami/apps/APPNAME/conf/httpd-app.conf, and we still see this:

ProxyPass / http://127.0.0.1:80/
ProxyPassReverse / http://127.0.0.1:80/ 

That is wrong, it should be as following:

ProxyPass / http://127.0.0.1:3000/
ProxyPassReverse / http://127.0.0.1:3000/

Also you need to add the following line to /opt/bitnami/apache2/conf/bitnami/bitnami-apps-prefix.conf:

Include "/opt/bitnami/apps/APPNAME/conf/httpd-prefix.conf"

Then, after changing it, restart Apache:

sudo /opt/bitnami/ctlscript.sh restart apache

If you keep finding issues we recommend you try following the following guide again: How to configure a custom Node.js application

hI @marcos
thanks now its running

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.