Something is causing 524 on my wordpress site

Hello! Ok before I do that, I would like to ask you if disabling pagespeed will have negative consequences on my site

PageSpeed works as a cache in the server so it helps to improve the time it takes to provide the info to a request but the problem is that it doesn’t work properly when there is not enough RAM memory available in the machine. In that case, it introduces errors and the performance is worse. You can either increase the instance type of your instance or disable PageSpeed to avoid those issues.

What is the best option? Should I upgrade the RAM or disable PageSpeed? Thanks

Hi @esteban.calderon,

I’d increase the memory of the machine as it will improve the performance for sure.

Can you please explain me how to do it? I’m using google cloud.

You can follow this guide of our documentation

https://docs.bitnami.com/google/faq/administration/change-server-type/

Happy to help!


Was my answer helpful? Click on :heart:

Hello my site was fine for a while. However now I’m getting this error now

On wordpress I’m getting this error

Update: I run the command again and it’s showing this errors now

However when I try to go to the admin. I’m getting the error establishing a database connection

Hi @esteban.calderon,

I think the database is not running. I saw a “wp_options table is marked as crashed” in the screenshot you shared in a previous message so you will need to recover that table before starting the database and accessing the application.

To solve that error, you can either check this other post

or this guide in our documentation

https://docs.bitnami.com/google/apps/wordpress/administration/recover-database/

Hello I ran the command sudo tail -n 100 /opt/bitnami/mysql/data/mysqld.log and get this information. Apparently I’m out of space, however I don’t understand how. Can you please tell me some advise?

I found a related problem Something Taking Up Space And Growing
And follow the steps, however the issue still persists. image

Mysql configuration:
image

Hi @esteban.calderon,

As you mentioned, you ran out of space. The binary logging in MySQL is the “culprit” of that data usage. Those files record all the requests to the database. We found in the past several issues like this one when a WordPress’ plugin used the database to store the information. In those cases, that plugin performed a big amount of requests to the database and that generated those large binlog files. In the thread you posted, you can find the information about how to disable the binary logging in MySQL so you can free that space, did you do so? You can also increase the disk size of your instance to start the services again and disable the binlogs later.

I hope this information helps

Hi @esteban.calderon,

As you mentioned, you ran out of space. The binary logging in MySQL is the “culprit” of that data usage. Those files record all the requests to the database. We found in the past several issues like this one when a WordPress’ plugin used the database to store the information. In those cases, that plugin performed a big amount of requests to the database and that generated those large binlog files. In the thread you posted, you can find the information about how to disable the binary logging in MySQL so you can free that space, did you do so? You can also increase the disk size of your instance to start the services again and disable the binlogs later.

I hope this information helps

Hello! Jota

Yes I tried with the steps in this thread Something Taking Up Space And Growing
However the problem still persist. I resize the disk to 100GB and check this
image
Now, It’s 80GB
So, I tried on the Mysql configuration set the expire logs to 7 days. But that command seems deprecated. I tried with

binlog_expire_logs_seconds and It didn’t work

My msql config
image

Hi @esteban.calderon,

The binlog_expire_logs_seconds parameter should work as expected according to the documentation

https://dev.mysql.com/doc/refman/8.0/en/replication-options-binary-log.html#sysvar_binlog_expire_logs_seconds

You can try to expire the old logs manually now

https://dev.mysql.com/doc/refman/8.0/en/purge-binary-logs.html

If you continue running into disk space issues, I suggest you disable the binary logging. You can find useful information about the different options to disable it in these other community posts


Hello binlog_expire_logs_seconds parameter work but I set to expire every day. However, the data keeps growing minute after minute. Can you please tell if it is safe to disable the binlogs?

The bin log files stores all the actions that are performed inside the database. It’s useful to recover the database information in case there is any error in the database but it uses a big amount of space in the machine. It’s up to you to disable it or not. You can disable it and backup your server regularly to recover the information in case of a failure.

The documentation about disabling the bin log can be also found here

https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/disable-binary-logging-mysql/

To backup your server, you have this other guide

https://docs.bitnami.com/aws/faq/administration/backup-restore-server/

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.