Solved: Unable to install "nano"

Keywords: Phabricator - Virtual Machines - Technical issue - Upgrade
Description:
I am using the latest phabricator virtual machine.
I noticed it doesn’t come with a nano editor.

  1. I tried sudo apt-get update , and i got an error:
    https://snag.gy/7EsGul.jpg
    Err:3 http://security.debian.org stretch/updates Release
    403 Forbidden [IP xxx.xx.x.xx 80]
    E: The repo ‘http://security.debian.org stretch/updates Release’ does no longer have a Release file.
    N: Updating from such repo…

  2. I tried installing nano, and i got other error. Possibly derived from the 1st.
    https://snag.gy/SJv6dy.jpg

I do not have this issue, when the os was a ubuntu vs the debian.

I have change info in the following file using:
sudo vim /etc/apt/sources.list
Edit:
http://security.debian.org/debian-security stretch/updates
to
deb http://security.debian.org/debian-security stretch/updates main contrib non-free

it works for that. But, i still get some error updating the list. Ideas anyone?

Err:6 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
403 Forbidden [IP: 149.20.4.14 80]

Reading package lists… Done
E: The repository ‘http://deb.debian.org/debian stretch Release’ does no longer have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: The repository ‘http://security.debian.org/debian-security stretch/updates Release’ does not have a Release file.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

==================================================================

Sorry, had to merged into this post since i can’t post a closed topic.
Got it fixed by making sure networking in the VM was able to ping google or debian. Managed to get it to work by connecting to a normal networking (not work).
Also probably modified:
/etc/resolv.conf

nameserver 8.8.8.8

Utilizing the following /etc/apt/sources.list

deb http://deb.debian.org/debian stretch main
deb http://security.debian.org/ stretch/updated main contrib non-free

==================================================================

Hi,

I cannot reproduce the issue you describe using the latest Phabricator VM. Here you can found the output of the installation command, as well as the content of the /etc/apt/sources.list file.

Regards,
Silvio Fernández

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.