SMTP Setup Wont Work

Hi,

I’m using a SMTP relay server to send email. All server application must use this relay server to send emails. I configured a lot of other applications using this SMTP relay and they all work. The only configuration on the relay is to

I only have an IP address and a port for configuration (No username/No password). The only other setting required to make this work on my network is to allow sender server (ip or name) on the relay, which is already done.

But when I check the “Send a test e-mail after saving” option, I immediately receive a “Failed to send test e-mail.” message. In the apache logs, I have the following:

ReviewBoard + PowerPack 3.0.14
VMDK
I only modified configs available on admin web pages of ReviewBoard. No plugins (Other that the power pack)
Apache log:
[Tue Jun 04 18:35:25.550562 2019] [ssl:warn] [pid 995] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jun 04 18:35:25.610252 2019] [ssl:warn] [pid 996] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jun 04 18:35:25.729813 2019] [mpm_prefork:notice] [pid 996] AH00163: Apache/2.4.38 (Unix) OpenSSL/1.0.2r mod_wsgi/3.5 Python/2.7.16 configured – resuming normal operations
[Tue Jun 04 18:35:25.729866 2019] [core:notice] [pid 996] AH00094: Command line: ‘/opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf’
[Tue Jun 04 18:35:47.753166 2019] [mpm_prefork:notice] [pid 996] AH00169: caught SIGTERM, shutting down
[Tue Jun 04 18:35:49.786157 2019] [ssl:warn] [pid 1194] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jun 04 18:35:49.838481 2019] [ssl:warn] [pid 1195] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jun 04 18:35:49.861910 2019] [mpm_prefork:notice] [pid 1195] AH00163: Apache/2.4.38 (Unix) OpenSSL/1.0.2r mod_wsgi/3.5 Python/2.7.16 configured – resuming normal operations
[Tue Jun 04 18:35:49.861942 2019] [core:notice] [pid 1195] AH00094: Command line: ‘/opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf’
[Tue Jun 04 18:45:18.340896 2019] [mpm_prefork:error] [pid 1195] AH00161: server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting
[Tue Jun 04 22:45:39.507899 2019] [:error] [pid 1202] ERROR:root:Failed to send test e-mail.
[Tue Jun 04 22:45:39.516063 2019] [:error] [pid 1202] Traceback (most recent call last):
[Tue Jun 04 22:45:39.516084 2019] [:error] [pid 1202] File “/opt/bitnami/apps/reviewboardpowerpack/htdocs/reviewboard/admin/forms.py”, line 736, in save
[Tue Jun 04 22:45:39.516091 2019] [:error] [pid 1202] fail_silently=False)
[Tue Jun 04 22:45:39.516097 2019] [:error] [pid 1202] File “/opt/bitnami/apps/reviewboardpowerpack/htdocs/venv/lib/python2.7/site-packages/django/core/mail/init.py”, line 50, in send_mail
[Tue Jun 04 22:45:39.516104 2019] [:error] [pid 1202] connection=connection).send()
[Tue Jun 04 22:45:39.516110 2019] [:error] [pid 1202] File “/opt/bitnami/apps/reviewboardpowerpack/htdocs/venv/lib/python2.7/site-packages/django/core/mail/message.py”, line 276, in send
[Tue Jun 04 22:45:39.516117 2019] [:error] [pid 1202] return self.get_connection(fail_silently).send_messages([self])
[Tue Jun 04 22:45:39.516124 2019] [:error] [pid 1202] File “/opt/bitnami/apps/reviewboardpowerpack/htdocs/venv/lib/python2.7/site-packages/django/core/mail/backends/smtp.py”, line 87, in send_messages
[Tue Jun 04 22:45:39.516130 2019] [:error] [pid 1202] new_conn_created = self.open()
[Tue Jun 04 22:45:39.516136 2019] [:error] [pid 1202] File “/opt/bitnami/apps/reviewboardpowerpack/htdocs/venv/lib/python2.7/site-packages/django/core/mail/backends/smtp.py”, line 48, in open
[Tue Jun 04 22:45:39.516143 2019] [:error] [pid 1202] local_hostname=DNS_NAME.get_fqdn())
[Tue Jun 04 22:45:39.516149 2019] [:error] [pid 1202] File “/opt/bitnami/python/lib/python2.7/smtplib.py”, line 256, in init
[Tue Jun 04 22:45:39.516155 2019] [:error] [pid 1202] (code, msg) = self.connect(host, port)
[Tue Jun 04 22:45:39.516161 2019] [:error] [pid 1202] File “/opt/bitnami/python/lib/python2.7/smtplib.py”, line 318, in connect
[Tue Jun 04 22:45:39.516167 2019] [:error] [pid 1202] (code, msg) = self.getreply()
[Tue Jun 04 22:45:39.516173 2019] [:error] [pid 1202] File “/opt/bitnami/python/lib/python2.7/smtplib.py”, line 369, in getreply
[Tue Jun 04 22:45:39.516179 2019] [:error] [pid 1202] raise SMTPServerDisconnected(“Connection unexpectedly closed”)
[Tue Jun 04 22:45:39.516185 2019] [:error] [pid 1202] SMTPServerDisconnected: Connection unexpectedly closed

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please download and execute it on the machine where the stack is running by following the steps described in the guide below?

How to Run the Bitnami Support Tool

Please note that you need to paste the code outputted by the tool in your reply.

1 Like

I’ve run the tool but this server does not have Internet access. And because I’m a new user, I cannot upload the zip file here.

What part of the generated zip file do you need for proper investigation ? I’ll copy/paste the file content as a reply here.

Thank you

Oups, the end of the first paragraph of my original question is missing… But this last sentence can be deleted :wink:

Hi @plangevin,

We have this guide in our documentation to explain how to configure SMTP in this application, did you configure the SMTP settings following it?

https://docs.bitnami.com/general/apps/reviewboard-plus-powerpack/configuration/configure-smtp/

From these lines, it seems that the connection was closed. That can be caused by multiple reasons. We suggest you contact the developers of the application or a forum related with the SMTP server you are using to get more information about the issue.

Do not hesitate to write us back if you have any other questions about the Bitnami solution

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.