SMTP Config fails

Hi,

In the past I was able to successfully use SMTP to send email via gmail using resourcespace recommended setup --> http://wiki.resourcespace.org/index.php/Email_Using_an_External_SMTP_Server. Now when I use those same credentials to setup in bitnami, it fails to send. Why might this be occurring?

Hi @shalbert,

Please check our guide about how to configure SMTP settings for ResourceSpace at https://wiki.bitnami.com/Applications/Bitnami_ResourceSpace#How_to_configure_the_email_settings_of_ResourceSpace.3f

Apart from that, please note that some cloud vendors as Google Cloud Platform doesn’t allow SMTP traffic through default ports: 25, 465, 587. Check [Google Cloud documentation][1] to learn how to use a VPN to bypass these restrictions.

Hope it helps,
Gonzalo
[1]: https://cloud.google.com/compute/docs/tutorials/sending-mail/

Hi,

I am using AWS cloud platform and the guide suggested and the issue still persists. Any advice on what else I can do to troubleshoot?

Hi,

if you are trying to configure a Gmail account you must assure that the option to less secure apps is enabled in your account. You can find how to enable it, here: https://docs.bitnami.com/aws/apps/wordpress/#how-to-configure-outbound-email-settings

Best regards,
Silvio Fernández

Hi silvio,

Thanks for your response. I have already confirmed that this setting is on and has always been on in Sign-in & Security. When I test, the problem still persists. Below is my config.default.php [username & password redacted].I am baffled by this issue. Thanks!

Use an external SMTP server for outgoing emails (e.g. Gmail).

Requires $use_phpmailer.

$use_smtp=true;

SMTP settings:

$smtp_secure=‘tls’; # ‘’, ‘tls’ or ‘ssl’. For Gmail, ‘tls’ or ‘ssl’ is required.
$smtp_host=‘smtp.gmail.com’; # Hostname, e.g. ‘smtp.gmail.com’.
$smtp_port=587; # Port number, e.g. 465 for Gmail using SSL.
$smtp_auth=true; # Send credentials to SMTP server (false to use anonymous access)
$smtp_username=‘aca*00@gmail.com’; # Username (full email address).
$smtp_password='A
5’; # Password.

Hi,

You must copy this content from your config.default.php file into config.php without default. After that, you must restart the servers preforming /opt/bitnami/ctlscript.sh.

You could find more information here.

Best regards,
Silvio Fernández