Slow TTFB even though I have a heavy VM

Type: Suggestion

Description:
Hi, I recently migrated a site from a MySQL setup, to a MariaDB setup.

The new MariaDB setup is a VM on google cloud with 16gb ram, 4x E2 cpus.

I used the Wordpress plugin “All in one migrator” to move the site. Do I have to do anything else in order to optimize the old MySQL queries for MariaDB? or does that happen automatically?

I have a consistent TTFB of 2s. I have caching, brotoli, minify and everything else you can think of.

This same site with my old server had no TTFB issues, I moved it because I thought nginx would be faster than apache and I thought mariadb would be faster than MySQL.

Any suggestions on what I can do?

Hi @daniele2,

That depends on the application but I think WordPress will handle that automatically.

Maybe the PHP processes are reaching the limits. Can you take a look at the Apache and PHP-FPM log files to see if there is any error there?

https://docs.bitnami.com/google/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/google/apps/wordpress/troubleshooting/debug-errors-php-fpm/
https://docs.bitnami.com/google/apps/wordpress/configuration/configure-phpfpm-processes/
https://docs.bitnami.com/google/apps/wordpress/troubleshooting/debug-errors-mariadb/

If you continue running into issues, please create a new ticket in the forum selecting the “Technical issue” option and include the Bitnami Support Tool code. Apart from that, it’d be helpful if you also include the output of this test (https://www.webpagetest.org/) in that new ticket

Happy to help!


Was my answer helpful? Click on :heart:

1 Like