Site is not loading inside an IFRAME

Keywords: WordPress + NGINX + SSL - AWS - Technical issue - Application configuration

bndiagnostic ID: 00ec1e97-a504-db2e-8f1b-d6db5f6db8b7

bndiagnostic output:

? Nginx: Found possible issues
https://docs.bitnami.com/installer/infrastructure/nginx/troubleshooting/

bndiagnostic failure reason: The tool could not find any issue

Description:
Hello,

Ours is a NEWS PORTAL SITE, We have integrations with several big players like JIO NEWS. They usually display the news articles from our site using IFRAME.

Pages Link will be like this: JioNews

But inside, They usually put up an IFRAME but if we try to view the link,
It comes like this “newsnext.live refused to connect.” [SCREENSHOT: Screenshot by Lightshot]

Could you please suggest how do we fix this?
Thanks in advance!

Hi @vgnavada ,

Thank you for using our solution. That’s a specific question about the application so we suggest you ask in the official forums of the application to get more information about that. The app’s documentation should also describe how to achieve what you want to, so please take a look at it too.

https://wordpress.org/support/

However, we will also keep this ticket open in this forum in case any Bitnami user configured the application they way you want to.

Thanks

Hi @jota ,
No that is not a application specific question.
And this is also not a specific question related to WordPress as well.

I have several other sites hosted on other server platforms, They load properly inside an iFrame.

Only the sites hosted on Bitnami Ngnix doesn’t load inside an iFrame.

So i feel like there is something here that is causing this blockage.

Could you please recheck on HOW TO ENABLE LOADING IFRAME for bitnami hosted WordPress sites??

I think you will need to configure the X-Frame-Options header in NGINX

https://stackoverflow.com/a/35790513

As you are using WordPress, you will need to add this configuration to the wordpress files inside the /opt/bitnami/nginx/conf/server_blocks folder.

Please note that this is not a Bitnami-related question, but a webserver’s configuration one. You will find more resources online to allow using iframe in your server.

1 Like

Hi @jota ,
I followed this step: iframe - X-Frame-Options in nginx to allow all domains - Stack Overflow
It worked :man_dancing:
Thank you :handshake:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.