Site down because of instance has little available RAM memory?

Keywords: WordPress Multisite - Google Cloud Platform - Technical issue - Services (Apache, MariaDB, MySQL…)

bnsupport ID: 5066aafe-9a37-2f1a-4f85-0e33b3c63cc8

bndiagnostic output:

? Resources: Found possible issues
? Apache: Found possible issues

bndiagnostic failure reason: The suggested guides are not related with my issue

Recently my client website was down, it’s curious that Bitnami Launchpad for Google Cloud Platform was showing “Running” as normal, GCP console was showing a green check mark, why it will not reflect the site was down?

While using support tool, the first issue is RAM, is there anyway to get alert for little RAM before the site down?

Besides, “You will need to stop VM to edit machine type”, this is very inconvenient, is there anyway to workaround?


Hi @mubiesam,

The launchpad and the GCP console shows that the instance is running but they do not check if the services inside the VM are running or not.

There are monitoring services that can help you monitor the performance of the instance.

Please note that that depends on the platform but the process usually requires to stop/restart the machine. The resources need to be reassigned and that’s why a restart is required.

Happy to help!

Was my answer helpful? Click on :heart:

Hi @jota

Thanks for quick answer.

Can you guide me more how can I use monitoring services to monitor the performance, especially RAM?


Hi @mubiesam,

You can find many online resources like this one

Happy to help!

Was my answer helpful? Click on :heart:

1 Like

Thank you very much.

Hi @jota

One more question…

After running support tool, one of the bndiagnostic output is suggesting to disable pagespeed,

I have read the guide…

But wondering is this the reason to cause the site down? If I disable it, will it slow down the pagespeed?


Hi @mubiesam,

If PageSpeed is not working properly due to the resources of the machine or because there is a conflict with the app’s files, it’s better to disable it to avoid problems. PageSpeed helps you optimize the application by caching the resources but it doesn’t work all times. You can try and disable PageSpeed to see if the performance of the website is affected.


I followed the instruction to disable PageSpeed, Flush The PageSpeed Cache and Restart Apache, but the similar error again…

Found recent Pagespeed related error messages in the Apache error log:

[Wed Oct 13 23:51:12.426886 2021] [pagespeed:error] [pid 2032:tid 
139696093001472] [mod_pagespeed **ip_address**-0 @2032] PageSpeed Serf fetch 
failure rate extremely high; only 0 of 887 recent fetches fully successful; is 
fetching working?

The support bundle code 9b324bd7-63f1-5990-ad62-834cbe28d6b3 


Noticed the error is dated Wed Oct 13, so I run the tool again, but still same result.


Hi @mubiesam,

If you are still getting Pagespeed-related errors is because you didn’t disable it properly. Please review the steps you performed in the instance and compare them with the ones that we show in the documentation. You will need to make sure that the pagespeed libraries are disabled and that you restarted Apache after making that change.


Hi @jota

I double checked, pretty sure that this is edited in the /opt/bitnami/apache2/conf/httpd.conf file.

Include “conf/deflate.conf”
#Include conf/pagespeed.conf
#Include conf/pagespeed_libraries.conf

Flushed The PageSpeed Cache and Restarted Apache today, but still got this error messages.

Is this because it is ONLY an error messages in the Apache error log [Wed Oct 13 23:51:12.426886 2021], since I can not find anything like this…

  • Check the source code of rendered application page. Images, CSS and JavaScript should appear in compressed form. For example, an image might be named sample.png.pagespeed.ic.ZWx38TQ7J5.png.


Hi @mubiesam,

Please send a new support tool output so we can check your changes.


Hi @davidg

Here is the new code 180c3a8d-7d17-fb89-c2f1-93752c2ffdf6

But the error messages are no long related to PageSpeed,

Found recent error or warning messages in the Apache error log.

[Mon Oct 18 22:22:36.803757 2021] [autoindex:error] [pid 541:tid

140421849990912] [client **ip_address**:63216] AH01276: Cannot serve directory

/opt/bitnami/apps/wordpress/htdocs/wp-admin/css/: No matching DirectoryIndex

(index.html,index.php) found, and server-generated directory index forbidden by

Options directive, referer:

[Tue Oct 19 07:55:51.939029 2021] [proxy_fcgi:error] [pid 12662:tid

140421808027392] [client **ip_address**:46594] AH01071: Got error 'PHP message:

PHP Fatal error: Uncaught Error: Class 'Walker' not found in


Stack trace:

#0 {main}

thrown in

/opt/bitnami/apps/wordpress/htdocs/wp-includes/class-walker-nav-menu.php on line


[Tue Oct 19 08:20:31.359162 2021] [core:error] [pid 3189:tid 140422059808512]

[client **ip_address**:32776] AH00126: Invalid URI in request POST

/cgi-bin/.%2e/.%2e/.%2e/.%2e/bin/sh HTTP/1.1 

Thanks for your help.

Hi @mubiesam,

Those errors are related to the application itself or plugins/themes you are using in the application. The class-walker-nav-menu.php file should include the Walker class as you can see here and the css error is something related to the application. There is not any index.html or index.php file there and there shouldn’t be any, I do not know why the app is trying to find it there. Please post these errors in the WordPress’ forums