Site accessible but not the wp-admin page even with all the plugins deactivated

Keywords: WordPress + NGINX + SSL - AWS - Technical issue - Other

bndiagnostic ID: 063bb340-ccfe-fd6a-3a4d-840316f239e4

bndiagnostic output:

? Nginx: Found possible issues
? Wordpress: Found possible issues
https://docs.bitnami.com/installer/infrastructure/nginx/troubleshooting/
https://docs.bitnami.com/general/apps/wordpress/administration/understand-file-permissions/

bndiagnostic failure reason: The documentation did not make any significant change

Description:
Hello,

we are running the AWS “WordPress with NGINX and SSL Certified by Bitnami and Automattic” instance and a problem occurred a few days ago (we detect it on the 13 of May). The website is accessible but we can’t access the wp-admin page., we got an “HTTP ERROR 500”. We have just renewed a license of a plugin “Theme my login” on May 3rd and we have detected the issue on the 13th. We thought that it could be the issue, so we have deactivated that plugin then, all the plugins as it was still not working. Same with all the plugins deactivated

$ sudo wp plugin deactivate --all
Success: Plugins already deactivated.

I found that there were some wrong permissions and I fixed them by following the bitnami guide

$ ls -ld /opt/bitnami/wordpress/*/
drwxrwxr-x  2 bitnami daemon  4096 Feb 19 02:13 /opt/bitnami/wordpress/licenses/
drwxr-xr-x  5 daemon  daemon  4096 Feb 26 01:20 /opt/bitnami/wordpress/rop/
drwxrwxr-x  2 bitnami daemon  4096 Feb 19 02:13 /opt/bitnami/wordpress/tmp/
drwxrwxr-x 10 bitnami daemon 12288 May 13 10:37 /opt/bitnami/wordpress/wp-admin/
drwxrwxr-x 28 bitnami daemon  4096 May 16 22:34 /opt/bitnami/wordpress/wp-content/
drwxrwxr-x 26 bitnami daemon 12288 Feb 19 02:13 /opt/bitnami/wordpress/wp-includes/

For the permissions of the files

$ ls -l /opt/bitnami/wordpress | grep -v "drwx"
total 388
-rw-r--r--  1 daemon  daemon  18488 May  6 00:38 2index.php
-rw-r--r--  1 daemon  daemon   2092 Mar 16 22:26 3index.php
-r--r--r--  1 daemon  daemon   8659 Feb 16 17:22 academy.roopu.cloud.php
-rw-r--r--  1 daemon  daemon   1145 May 15 23:50 admin.php
-r--r--r--  1 daemon  daemon     69 May  9 03:01 bettyann_mehaj.html
-r--r--r--  1 daemon  daemon     69 May  9 03:01 debbra_franza.html
-r--r--r--  1 daemon  daemon     69 May  9 03:01 google49af8e614de39662.html
-r--r--r--  1 daemon  daemon     69 May  9 03:01 google8af70b24362554c0.html
-r--r--r--  1 daemon  daemon     69 May  9 03:01 googleadbda8bbe0eef4a8.html
-r--r--r--  1 daemon  daemon     69 May  9 03:01 googledde3a6d7073a996c.html
-r--r--r--  1 daemon  daemon  31179 May 17 14:37 index.php
-rw-rw-r--  1 bitnami daemon  19915 Jan 29 11:35 license.txt
-r--r--r--  1 daemon  daemon     69 May  9 03:01 luanne_borock.html
-rw-rw-r--  1 daemon  daemon      0 Feb 22 12:19 nginx.conf
-rw-r--r--  1 daemon  daemon   2012 Mar 16 22:26 old-index.php
-rw-rw-r--  1 bitnami daemon     69 May  9 03:01 readme.html
-rw-r--r--  1 daemon  daemon   8822 Apr 28 13:11 robots.txt
-rw-r--r--  1 daemon  daemon   2094 May 14 03:50 wikindex.php
-rw-rw-r--  1 bitnami daemon   7165 Dec 15 21:32 wp-activate.php
-rw-rw-r--  1 bitnami daemon   7246 Mar 16 22:26 wp-admin.php
-rw-r--r--  1 bitnami bitnami  7246 May 16 23:19 wp-admin.php.backup
-rw-rw-r--  1 bitnami daemon    351 Dec 15 21:32 wp-blog-header.php
-rw-rw-r--  1 bitnami daemon   2338 Jan 29 11:35 wp-comments-post.php
-rw-r-----  1 bitnami bitnami  4308 Jan 18 21:00 wp-config.old
lrwxrwxrwx  1 root    root       32 Jan  4 20:34 wp-config.php -> /bitnami/wordpress/wp-config.php
-rw-rw-r--  1 bitnami daemon   3001 Jan 29 11:35 wp-config-sample.php
-rw-r--r--  1 daemon  daemon  20970 Mar 16 03:37 wp-conflg.php
lrwxrwxrwx  1 root    root       29 Jan  4 20:34 wp-content -> /bitnami/wordpress/wp-content
-rw-rw-r--  1 bitnami daemon   3939 Dec 15 21:32 wp-cron.php
-rw-rw-r--  1 bitnami daemon   2496 Dec 15 21:32 wp-links-opml.php
-rw-rw-r--  1 bitnami daemon   3900 Dec 15 21:32 wp-load.php
-rw-rw-r--  1 bitnami daemon  47916 Jan 29 11:35 wp-login.php
-rw-rw-r--  1 bitnami daemon   8582 Jan 29 11:35 wp-mail.php
-rw-rw-r--  1 bitnami daemon  23025 Jan 29 11:35 wp-settings.php
-rw-rw-r--  1 bitnami daemon  31959 Jan 29 11:35 wp-signup.php
-rw-rw-r--  1 bitnami daemon   4747 Dec 15 21:32 wp-trackback.php
-rw-rw-r--  1 bitnami daemon   3236 Dec 15 21:32 xmlrpc.php

but there are still some results that I find strange regarding the wp-config.php file and the wp-includes folder that seem to be symlinks and I don’t know if it’s normal

lrwxrwxrwx  1 root    root       32 Jan  4 20:34 wp-config.php -> /bitnami/wordpress/wp-config.php
lrwxrwxrwx  1 root    root       29 Jan  4 20:34 wp-content -> /bitnami/wordpress/wp-content

they were not edited recently, which means the wp-admin page and the site were probably working fine even without the current error. Even Nginx was not edited, nothing was edited before the problem. I have run the diagnostic tool and indicated the code of the result.

Hi @fralain,

Can you reset the permissions in the following way:

sudo chown -R bitnami:daemon /opt/bitnami/wordpress/wp-content
sudo find /opt/bitnami/wordpress/wp-content -type d -exec chmod 775 {} \;
sudo find /opt/bitnami/wordpress/wp-content -type f -exec chmod 664 {} \;
sudo chmod 640 /opt/bitnami/wordpress/wp-config.php

Regards,
Michiel

Hi @michiel ,

thank you for your reply, I already did it but same result. If I try to look at the permissions applied on the two, it seems to be okay

$ ls -ld /bitnami/wordpress/wp-config.php
-rw-r----- 1 bitnami daemon 4582 May 17 14:19 /bitnami/wordpress/wp-config.php

and

$ ls -ld /bitnami/wordpress/wp-content/
drwxrwxr-x 28 bitnami daemon 4096 May 18 07:11 /bitnami/wordpress/wp-content/

but I don’t understand why the two appear as symlinks when listing the content of the Wordpress directory. I don’t know if it should appear like that by default because it seems that it was working like that before as nobody manually edited the two recently to make them appear as symlinks. I deleted the other lines in the output

$ ls -l /opt/bitnami/worpdress
lrwxrwxrwx  1 root    root       32 Jan  4 20:34 wp-config.php -> /bitnami/wordpress/wp-config.php
lrwxrwxrwx  1 root    root       29 Jan  4 20:34 wp-content -> /bitnami/wordpress/wp-content

Also, when deactivating some plugins, I get an error

PHP Warning:  file_get_contents(index.php): failed to open stream: No such file or directory in /opt/bitnami/wordpress/wp-includes/plugin.php on line 441
Warning: file_get_contents(index.php): failed to open stream: No such file or directory in /opt/bitnami/wordpress/wp-includes/plugin.php on line 441

I think that there is a missing index.php file that is not found by the plugins and I don’t know where it should be located and what its content should look like as I didn’t see it in the /opt/bitnami/wordpress/wp-includes folder.

Thank you

Hello, no idea?
service still not running properly and I got the same PHP warning messages and new ones even when disabling the plugins

$ sudo wp plugin deactivate --all
PHP Warning:  file_get_contents(index.php): failed to open stream: No such file or directory in /opt/bitnami/wordpress/wp-includes/plugin.php on line 441
Warning: file_get_contents(index.php): failed to open stream: No such file or directory in /opt/bitnami/wordpress/wp-includes/plugin.php on line 441
PHP Warning:  file_get_contents(index.php): failed to open stream: No such file or directory in /opt/bitnami/wordpress/wp-includes/plugin.php on line 441
Warning: file_get_contents(index.php): failed to open stream: No such file or directory in /opt/bitnami/wordpress/wp-includes/plugin.php on line 441
PHP Warning:  file_get_contents(index.php): failed to open stream: No such file or directory in /opt/bitnami/wordpress/wp-includes/plugin.php on line 441
Warning: file_get_contents(index.php): failed to open stream: No such file or directory in /opt/bitnami/wordpress/wp-includes/plugin.php on line 441
...
...
##same error that I just skipped
...
...
Plugin 'astra-addon' deactivated.
Plugin 'bbpress' deactivated.
Plugin 'cookie-notice' deactivated.
Plugin 'debug-bar' deactivated.
Plugin 'design-upgrade-pro-learndash' deactivated.
Plugin 'elementor' deactivated.
Plugin 'addon-elements-for-elementor-page-builder' deactivated.
Plugin 'header-footer-elementor' deactivated.
Plugin 'elementor-pro' deactivated.
Plugin 'essential-addons-for-elementor-lite' deactivated.
Plugin 'hide-admin-bar-from-non-admins' deactivated.
Plugin 'leadin' deactivated.
Plugin 'if-menu' deactivated.
Plugin 'jetsticky-for-elementor' deactivated.
Plugin 'LearnDash-Importer-Exporter' deactivated.
Plugin 'sfwd-lms' deactivated.
Plugin 'learndash-bbpress' deactivated.
Plugin 'learndash-course-grid' deactivated.
Plugin 'learndash-elementor' deactivated.
Plugin 'learndash-stripe' deactivated.
Plugin 'learndash-woocommerce' deactivated.
Plugin 'mailchimp-for-woocommerce' deactivated.
Plugin 'megamenu' deactivated.
Plugin 'minify-html-markup' deactivated.
Plugin 'makewebbetter-hubspot-for-woocommerce' deactivated.
Plugin 'woo-stripe-payment' deactivated.
Plugin 'post-smtp' deactivated.
Plugin 'responsive-menu' deactivated.
Plugin 'woo-sales-by-country-reports' deactivated.
Plugin 'google-site-kit' deactivated.
Plugin 'ssl-insecure-content-fixer' deactivated.
Plugin 'theme-my-login' deactivated.
Plugin 'tml-avatars' deactivated.
Plugin 'tml-moderation' deactivated.
Plugin 'tml-notifications' deactivated.
Plugin 'tml-profiles' deactivated.
Plugin 'tml-social' deactivated.
Plugin 'woocommerce' deactivated.
Plugin 'woo-gutenberg-products-block' deactivated.
Plugin 'woocommerce-pdf-invoices-packing-slips' deactivated.
Plugin 'woolentor-addons' deactivated.
Plugin 'wordfence' deactivated.
Plugin 'wp-optimize' deactivated.
Plugin 'wpforms-lite' deactivated.
Plugin 'wp-html-mail' deactivated.
Plugin 'wp-phpmyadmin-extension' deactivated.
Warning: Some code is trying to do a URL redirect. Backtrace:
#0  WP_CLI\Utils\wp_redirect_handler() called at [/opt/bitnami/wordpress/wp-includes/class-wp-hook.php:309]
#1  WP_Hook->apply_filters(, Array ([0] => ,[1] => 302)) called at [/opt/bitnami/wordpress/wp-includes/plugin.php:189]
#2  apply_filters(wp_redirect, , 302) called at [/opt/bitnami/wordpress/wp-includes/pluggable.php:1316]
#3  wp_redirect(, 302, WordPress) called at [/opt/bitnami/wordpress/wp-includes/pluggable.php:1463]
#4  wp_safe_redirect() called at [/bitnami/wordpress/wp-content/plugins/wp-rocket/inc/Engine/Deactivation/Deactivation.php:63]
#5  WP_Rocket\Engine\Deactivation\Deactivation::deactivate_plugin() called at [/opt/bitnami/wordpress/wp-includes/class-wp-hook.php:307]
#6  WP_Hook->apply_filters(, Array ([0] => )) called at [/opt/bitnami/wordpress/wp-includes/class-wp-hook.php:331]
#7  WP_Hook->do_action(Array ([0] => )) called at [/opt/bitnami/wordpress/wp-includes/plugin.php:487]
#8  do_action(deactivate_wp-rocket/wp-rocket.php, ) called at [/opt/bitnami/wordpress/wp-admin/includes/plugin.php:812]
#9  deactivate_plugins(wp-rocket/wp-rocket.php, , ) called at [phar:///opt/bitnami/wp-cli/bin/wp-cli.phar/vendor/wp-cli/extension-command/src/Plugin_Command.php:413]
#10 Plugin_Command->deactivate(Array ([0] => astra-addon,[1] => bbpress,[2] => cloudflare,[3] => cookie-notice,[4] => debug-bar,[5] => design-upgrade-pro-learndash,[6] => elementor,[7] => addon-elements-for-elementor-page-builder,[8] => header-footer-elementor,[9] => elementor-pro,[10] => essential-addons-for-elementor-lite,[11] => hide-admin-bar-from-non-admins,[12] => leadin,[13] => if-menu,[14] => jetsticky-for-elementor,[15] => LearnDash-Importer-Exporter,[16] => sfwd-lms,[17] => learndash-bbpress,[18] => learndash-course-grid,[19] => learndash-elementor,[20] => learndash-stripe,[21] => learndash-woocommerce,[22] => mailchimp-for-woocommerce,[23] => megamenu,[24] => minify-html-markup,[25] => makewebbetter-hubspot-for-woocommerce,[26] => woo-stripe-payment,[27] => post-smtp,[28] => responsive-menu,[29] => woo-sales-by-country-reports,[30] => google-site-kit,[31] => ssl-insecure-content-fixer,[32] => theme-my-login,[33] => tml-avatars,[34] => tml-moderation,[35] => tml-notifications,[36] => tml-profiles,[37] => tml-social,[38] => woocommerce,[39] => woo-gutenberg-products-block,[40] => woocommerce-pdf-invoices-packing-slips,[41] => woolentor-addons,[42] => wordfence,[43] => wp-optimize,[44] => wpforms-lite,[45] => wp-html-mail,[46] => wp-phpmyadmin-extension,[47] => wp-rocket,[48] => wordpress-seo,[49] => wpseo-woocommerce), Array ([all] => 1))
#11 call_user_func(Array ([0] => Plugin_Command Object ([*item_type] => plugin,[*upgrade_refresh] => wp_update_plugins,[*upgrade_transient] => update_plugins,[*obj_fields] => Array ([0] => name,[1] => status,[2] => update,[3] => version),[*fetcher] => WP_CLI\Fetchers\Plugin Object ([*msg] => The '%s' plugin could not be found.),[*chained_command] => ,[WP_CLI\CommandWithUpgrademap] => Array ([short] => Array ([inactive] => I,[active] => A,[active-network] => N,[must-use] => M,[parent] => P,[dropin] => D),[long] => Array ([inactive] => Inactive,[active] => Active,[active-network] => Network Active,[must-use] => Must Use,[parent] => Parent,[dropin] => Drop-In))),[1] => deactivate), Array (), Array ([all] => 1)) called at [phar:///opt/bitnami/wp-cli/bin/wp-cli.phar/vendor/wp-cli/wp-cli/php/WP_CLI/Dispatcher/CommandFactory.php:100]
#12 WP_CLI\Dispatcher\CommandFactory::WP_CLI\Dispatcher\{closure}(Array (), Array ([all] => 1))
#13 call_user_func(Closure Object (), Array (), Array ([all] => 1)) called at [phar:///opt/bitnami/wp-cli/bin/wp-cli.phar/vendor/wp-cli/wp-cli/php/WP_CLI/Dispatcher/Subcommand.php:491]
#14 WP_CLI\Dispatcher\Subcommand->invoke(Array (), Array ([all] => 1), Array ()) called at [phar:///opt/bitnami/wp-cli/bin/wp-cli.phar/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php:399]
#15 WP_CLI\Runner->run_command(Array ([0] => plugin,[1] => deactivate), Array ([all] => 1)) called at [phar:///opt/bitnami/wp-cli/bin/wp-cli.phar/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php:422]
#16 WP_CLI\Runner->run_command_and_exit() called at [phar:///opt/bitnami/wp-cli/bin/wp-cli.phar/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php:1194]
#17 WP_CLI\Runner->start() called at [phar:///opt/bitnami/wp-cli/bin/wp-cli.phar/vendor/wp-cli/wp-cli/php/WP_CLI/Bootstrap/LaunchRunner.php:23]
#18 WP_CLI\Bootstrap\LaunchRunner->process(WP_CLI\Bootstrap\BootstrapState Object ([WP_CLI\Bootstrap\BootstrapStatestate] => Array ())) called at [phar:///opt/bitnami/wp-cli/bin/wp-cli.phar/vendor/wp-cli/wp-cli/php/bootstrap.php:77]
#19 WP_CLI\bootstrap() called at [phar:///opt/bitnami/wp-cli/bin/wp-cli.phar/vendor/wp-cli/wp-cli/php/wp-cli.php:27]
#20 include(phar:///opt/bitnami/wp-cli/bin/wp-cli.phar/vendor/wp-cli/wp-cli/php/wp-cli.php) called at [phar:///opt/bitnami/wp-cli/bin/wp-cli.phar/php/boot-phar.php:11]
#21 include(phar:///opt/bitnami/wp-cli/bin/wp-cli.phar/php/boot-phar.php) called at [/opt/bitnami/wp-cli/bin/wp-cli.phar:4]

or when listing the plugins,

$ sudo wp plugin list
PHP Warning:  file_get_contents(index.php): failed to open stream: No such file or directory in /opt/bitnami/wordpress/wp-includes/plugin.php on line 441
Warning: file_get_contents(index.php): failed to open stream: No such file or directory in /opt/bitnami/wordpress/wp-includes/plugin.php on line 441
PHP Warning:  file_get_contents(index.php): failed to open stream: No such file or directory in /opt/bitnami/wordpress/wp-includes/plugin.php on line 441
Warning: file_get_contents(index.php): failed to open stream: No such file or directory in /opt/bitnami/wordpress/wp-includes/plugin.php on line 441

+-------------------------------------------+----------+-----------+---------+
| name                                      | status   | update    | version |
+-------------------------------------------+----------+-----------+---------+
| astra-addon                               | inactive | none      | 3.5.6   |
| bbpress                                   | inactive | none      | 2.6.9   |
| cloudflare                                | inactive | available | 4.8.3   |
| cookie-notice                             | inactive | none      | 2.2.3   |
| debug-bar                                 | inactive | none      | 1.1.3   |
| design-upgrade-pro-learndash              | inactive | none      | 2.17.2  |
| elementor                                 | inactive | none      | 3.6.5   |
| addon-elements-for-elementor-page-builder | inactive | none      | 1.11.15 |
| header-footer-elementor                   | inactive | none      | 1.6.10  |
| elementor-pro                             | inactive | none      | 3.6.5   |
| essential-addons-for-elementor-lite       | inactive | available | 5.1.1   |
| hide-admin-bar-from-non-admins            | inactive | none      | 1.0.1   |
| leadin                                    | inactive | available | 8.11.72 |
| if-menu                                   | inactive | none      | 0.16.2  |
| jetsticky-for-elementor                   | inactive | none      | 1.0.3   |
| LearnDash-Importer-Exporter               | inactive | none      | 1.3.5   |
| sfwd-lms                                  | inactive | none      | 4.1.1   |
| learndash-bbpress                         | inactive | none      | 2.2.2   |
| learndash-course-grid                     | inactive | none      | 2.0.5   |
| learndash-elementor                       | inactive | none      | 1.0.3   |
| learndash-stripe                          | inactive | none      | 1.9.3   |
| learndash-woocommerce                     | inactive | none      | 1.9.4.1 |
| mailchimp-for-woocommerce                 | inactive | none      | 2.6.2   |
| megamenu                                  | inactive | none      | 2.9.6   |
| minify-html-markup                        | inactive | none      | 2.02    |
| makewebbetter-hubspot-for-woocommerce     | inactive | none      | 1.3.0   |
| woo-stripe-payment                        | inactive | none      | 3.3.19  |
| post-smtp                                 | inactive | none      | 2.0.26  |
| responsive-menu                           | inactive | none      | 4.1.10  |
| woo-sales-by-country-reports              | inactive | none      | 1.6.5   |
| google-site-kit                           | inactive | available | 1.73.0  |
| ssl-insecure-content-fixer                | inactive | none      | 2.7.2   |
| theme-my-login                            | inactive | none      | 7.1.4   |
| tml-avatars                               | inactive | none      | 1.0.3   |
| tml-moderation                            | inactive | none      | 1.1.1   |
| tml-notifications                         | inactive | none      | 1.1.6   |
| tml-profiles                              | inactive | none      | 1.0.7   |
| tml-social                                | inactive | none      | 1.1     |
| woocommerce                               | inactive | available | 6.4.1   |
| woo-gutenberg-products-block              | inactive | available | 7.5.0   |
| woocommerce-pdf-invoices-packing-slips    | inactive | available | 2.14.4  |
| woolentor-addons                          | inactive | available | 2.2.6   |
| wordfence                                 | inactive | available | 7.5.9   |
| wp-optimize                               | inactive | none      | 3.2.3   |
| wpforms-lite                              | inactive | none      | 1.7.4.1 |
| wp-html-mail                              | inactive | none      | 3.2.2   |
| wp-phpmyadmin-extension                   | inactive | none      | 5.2.0.1 |
| wp-rocket                                 | active   | none      | 3.9.0.5 |
| wordpress-seo                             | active   | available | 18.8    |
| wpseo-woocommerce                         | active   | none      | 14.8    |
| elementor-safe-mode                       | must-use | none      | 1.0.0   |
| learndash-multisite                       | must-use | none      | 1.0.0   |
| wp-staging-optimizer                      | must-use | none      | 1.5.1   |
| advanced-cache.php                        | dropin   | none      |         |
+-------------------------------------------+----------+-----------+---------+

Thank you

Hi @fralain,

Can tell me the output of this command:

ls -la /opt/bitnami/wordpress/wp-includes/plugin.php

Regards,
Michiel

Hi @michiel ,

there is the output

-rw-rw-r-- 1 bitnami daemon 34746 May 18 03:57 /opt/bitnami/wordpress/wp-includes/plugin.php

Thank you

Hi,
can’t get any idea or any step to follow?

Hi @fralain,

Can you restart the services?

sudo /opt/bitnami/ctlscript.sh restart

And then run the bndiagnostic tool again?

sudo /opt/bitnami/bndiagnostic-tool

Regards,
Michiel

HI @michiel ,

I restarted the service and run the bndiagnostic tool. there is the code: 0cdb9d45-b456-3f4e-977e-fd1161e1c16c. Just to let you know that the plugins are still all disabled.

Hope that this will help as our services are still down, and our users are already complaining because they can’t use the services.

Hello,
still nothing? We still have the same warning/error regarding PHP and more frequently it seems. We didn’t edit a file or a permission file before the problem. We are using the bitnami version 5.8.2-22-r09-linux-debian. No upgrade was done so would like to understand why our wp-admin page went down suddenly.

need help as our users can’t log in properly to access their services

Hi @fralain,

The bndiagnostic tool also didn’t find the /opt/bitnami/wordpress/wp-includes/plugin.php file, so there seems to be something with it. You could launch a new instance and copy its file from the new instance to the old one?

scp /opt/bitnami/wordpress/wp-includes/plugin.php old_instance_ip:/opt/bitnami/wordpress/wp-includes/plugin.php

And see if that makes a difference?

Regards,
Michiel

Hi @michiel ,

thank you for your reply, I will and let you know

also @michiel , regarding the file permission error, is it normal that the wp-content folder and the wp-config.php appear as symlinks? Because while reading the documentation and looking some other threads, it doesn’t seem to be the case, so i’m a little confused. But the fact is, we never created it ourselves like that, I may think that it came like that by default.

Hi @michiel ,

When we check the /opt/bitnami/wordpress/wp-includes/plugin.php in the old instance it’s there, there is the output for the ls command

 ls -l /opt/bitnami/wordpress/wp-includes/plugin.php
-rw-rw-r-- 1 bitnami daemon 34746 May 18 03:57 /opt/bitnami/wordpress/wp-includes/plugin.php

the main error was more about an index.php file
PHP Warning: file_get_contents(index.php): failed to open stream: No such file or directory in /opt/bitnami/wordpress/wp-includes/plugin.php on line 441 that seems to be not found in the old server. We are not sure where it should find that file. If it should be in the wp-includes folder but in the new server, there is also no index.php in that folder.

But, just in case, we ran another instance to check the file issues. So, should we still copy the /opt/bitnami/wordpress/wp-includes/plugin.php file from the new server to the old one?

Also, on the new server, we can see that the wp-content folder and the wp-plugin file also appear as symlink just like in the old server

$ ls -l /opt/bitnami/wordpress
total 216
-rw-rw-r--  1 bitnami daemon   405 Dec 15 21:32 index.php
drwxrwxr-x  2 bitnami daemon  4096 Dec 15 21:45 licenses
-rw-rw-r--  1 bitnami daemon 19915 Dec 15 21:32 license.txt
-rw-rw-r--  1 bitnami daemon  7346 May 25 17:31 readme.html
drwxrwxr-x  2 bitnami daemon  4096 Dec 15 23:43 tmp
-rw-rw-r--  1 bitnami daemon  7165 Dec 15 21:32 wp-activate.php
drwxrwxr-x  9 bitnami daemon  4096 Dec 15 21:44 wp-admin
-rw-rw-r--  1 bitnami daemon   351 Dec 15 21:32 wp-blog-header.php
-rw-rw-r--  1 bitnami daemon  2328 Dec 15 21:32 wp-comments-post.php
lrwxrwxrwx  1 root    root      32 May 25 16:58 wp-config.php -> /bitnami/wordpress/wp-config.php
-rw-rw-r--  1 bitnami daemon  3004 Dec 15 21:32 wp-config-sample.php
lrwxrwxrwx  1 root    root      29 May 25 16:58 wp-content -> /bitnami/wordpress/wp-content
-rw-rw-r--  1 bitnami daemon  3939 Dec 15 21:32 wp-cron.php
drwxrwxr-x 25 bitnami daemon 12288 Dec 15 21:44 wp-includes
-rw-rw-r--  1 bitnami daemon  2496 Dec 15 21:32 wp-links-opml.php
-rw-rw-r--  1 bitnami daemon  3900 Dec 15 21:32 wp-load.php
-rw-rw-r--  1 bitnami daemon 45463 Dec 15 21:32 wp-login.php
-rw-rw-r--  1 bitnami daemon  8509 Dec 15 21:32 wp-mail.php
-rw-rw-r--  1 bitnami daemon 22297 Dec 15 21:32 wp-settings.php
-rw-rw-r--  1 bitnami daemon 31693 Dec 15 21:32 wp-signup.php
-rw-rw-r--  1 bitnami daemon  4747 Dec 15 21:32 wp-trackback.php
-rw-rw-r--  1 bitnami daemon  3236 Dec 15 21:32 xmlrpc.php

I don’t know if that information could help.

I did copy the /opt/bitnami/wordpress/wp-includes/plugin.php file from the new server to the old one and I restarted the services. I don’t see the PHP warning error anymore but the “wp-admin” page still not accessible. The website is not displaying well. All the plugins are still deactivated.

I ran again the bndiagnostic-tool just in case and there is the generated code: d632ead5-e668-d7fe-1e95-f12dc1886ce1 But it said that the file /opt/bitnami/nginx/logs/error.log are bigger than 10MB and have not been included.

@michiel ,

the login page appears with wp-login but we can’t log in (no reaction even with wrong credentials) while the wp-adminpage not working (500 error) and the website is not displaying properly.

Hi @fralain,

Could you check the latest entries from the error.log for errors? Also there are many php-fpm child processes active. I guess it shouldn’t be a problem due to the machine specs, but you could try changing the max_children setting:

https://docs.bitnami.com/aws/apps/wordpress-multisite/configuration/configure-phpfpm-options/

Regards,
Michiel

Hi Michiel,

For the error.log files, I can see some errors relates to a theme but it points inside the /bitnami/wordpress/... folder in /opt/bitnami/wordpress/...

2022/05/27 14:28:33 [error] 17857#17857: *26427 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 218.53.233.146, server: _, request: "GET /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 14:28:34 [error] 17857#17857: *26427 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 218.53.233.146, server: _, request: "POST /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 14:32:50 [error] 17857#17857: *26463 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream, client: 193.106.191.48, server: _, request: "GET /vendor/phpunit/phpunit/src/Util/PHP/eval-stdin.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C:80"
2022/05/27 14:34:12 [error] 17857#17857: *26477 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 219.249.26.201, server: _, request: "GET /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 14:34:12 [error] 17857#17857: *26477 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 219.249.26.201, server: _, request: "POST /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 14:37:56 [error] 17857#17857: *26500 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 177.92.247.70, server: _, request: "GET /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 14:38:01 [error] 17857#17857: *26500 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 177.92.247.70, server: _, request: "POST /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 14:45:55 [error] 17857#17857: *26575 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 59.5.23.206, server: _, request: "GET /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 14:45:56 [error] 17857#17857: *26575 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 59.5.23.206, server: _, request: "POST /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 14:47:34 [error] 17857#17857: *26594 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 46.136.146.128, server: _, request: "GET /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 14:47:34 [error] 17857#17857: *26594 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 46.136.146.128, server: _, request: "POST /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 14:48:36 [crit] 17857#17857: *26601 SSL_do_handshake() failed (SSL: error:14201044:SSL routines:tls_choose_sigalg:internal error) while SSL handshaking, client: 162.216.19.41, server: 0.0.0.0:443
2022/05/27 14:51:14 [error] 17857#17857: *26614 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 39.117.229.108, server: _, request: "GET /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 14:51:15 [error] 17857#17857: *26614 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 39.117.229.108, server: _, request: "POST /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 14:53:41 [error] 17857#17857: *26639 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream, client: 80.94.93.250, server: _, request: "GET /admin/config.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 14:55:49 [error] 17857#17857: *26661 FastCGI sent in stderr: "PHP message: PHP Warning:  Unknown: failed to open stream: No such file or directory in Unknown on line 0Unable to open primary script: /opt/bitnami/wordpress/index.php (No such file or directory)" while reading response header from upstream, client: 172.70.246.33, server: _, request: "GET /602048/402799144/bs8cce37Wwhute6ff8cco2.htm HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "host-domain.com"
2022/05/27 15:05:23 [error] 17857#17857: *26715 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 1.244.182.22, server: _, request: "GET /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 15:05:24 [error] 17857#17857: *26715 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 1.244.182.22, server: _, request: "POST /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 15:19:58 [error] 17857#17857: *26809 access forbidden by rule, client: 95.214.235.205, server: _, request: "GET /.env HTTP/1.1", host: "X.Y.Z.C"
2022/05/27 15:24:25 [error] 17857#17857: *28334 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 46.71.28.241, server: _, request: "GET /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 15:24:25 [error] 17857#17857: *28334 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 46.71.28.241, server: _, request: "POST /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 15:26:26 [error] 17857#17857: *29636 access forbidden by rule, client: 135.125.246.110, server: _, request: "GET /.env HTTP/1.1", host: "X.Y.Z.C"
2022/05/27 15:27:21 [error] 17857#17857: *29887 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 61.85.74.23, server: _, request: "GET /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 15:27:21 [error] 17857#17857: *29887 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 61.85.74.23, server: _, request: "POST /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 15:31:07 [error] 17857#17857: *33617 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 43.152.199.49, server: _, request: "GET /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 15:31:12 [error] 17857#17857: *33617 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: gM5598 in /bitnami/wordpress/wp-content/themes/L6UL67AE/D7BXK114.php on line 1" while reading response header from upstream, client: 43.152.199.49, server: _, request: "POST /wp-content/themes/L6UL67AE/D7BXK114.php HTTP/1.1", upstream: "fastcgi://unix:/opt/bitnami/php/var/run/www.sock:", host: "X.Y.Z.C"
2022/05/27 15:33:52 [crit] 17857#17857: *34026 SSL_do_handshake() failed (SSL: error:141CF06C:SSL routines:tls_parse_ctos_key_share:bad key share) while SSL handshaking, client: 178.73.215.171, server: 0.0.0.0:443

Regarding the max_children value via the link you provided, it was not present in the file /opt/bitnami/php/etc/php.ini so I added it. Still the same issue, wp-admin page not accessible, wp-login appears but can’t log in. Our collaborator also see the ERR_TOO_MANY_REDIRECTS

I ran the bndiagnostic diagnostic tool and this is the code 32dd6221-5d94-a989-6fa6-4f56ac953501.

Thank you

Hi @fralain,

Can you try to deactivate the L6UL67AE theme?

wp theme deactivate L6UL67AE

Regards,
Michiel

Hi @michiel , the theme is already deactivated since a long time.

 sudo wp theme list
+-----------------+----------+-----------+---------+
| name            | status   | update    | version |
+-----------------+----------+-----------+---------+
| L6UL67AE        | inactive | none      | 1.0.2   |
| astra           | parent   | available | 3.6.6   |
| classic         | inactive | none      | 1.6     |
| hello-elementor | inactive | none      | 2.5.0   |
| roopu           | active   | none      | 1.0.0   |
| twentytwentyone | inactive | available | 1.4     |
| twentytwentytwo | inactive | available | 1.0     |
+-----------------+----------+-----------+---------+

And when looking at the warning messages, it’s related to sub-folder in /bitnami and not /opt/bitnami. Most of the warning messages came from the same location. Any idea about what else to do?