SES Configured in configuration XML file, but execution getting timed out

Keywords: Redmine - AWS - Technical issue - Email configuration (SMTP)
bnsupport ID: 7acaeb95-c43e-9f5f-e05c-76a361ecbf6d
Description:
When sending test mail it shows: An error occurred while sending mail (execution expired)

Settings used :

Tried the SES Testmail, it’s working fine. Username & Password is also correct.

Hello @arjunkaimattathil,

Amazon EC2 blocks SMTP port 25 by default on all Amazon EC2 instances, and you must manually request removal of this restriction to use this port, did you perform this action? Going by the AWS SMTP Issues guide, receiving timeout errors is the normal behaviour if you do not have this port open.

Regards,
Francisco de Paz

Hi @fdepaz,
Thanks for the answer.
I tried after opening the PORT 25, 567, 465. Still getting time out.

Hello @arjunkaimattathil,

Let me set up this testing environment and reproduce this issue, I’ll get back to you as soon as I have any news.

Thanks,
Francisco de Paz

1 Like

Tried changing the username & password. Still the same error. Also please note that I am using Lightsail Redmine Instance

Hello @arjunkaimattathil,

Sorry about the late response, there was a permissions problem with my AWS and I couldn’t test this properly. I think the issue is related to the domain parameter. In it, you have to use your instance’s domain and not your SMTP domain. Please try modifying your configuration to the following one:

email_delivery:
  delivery_method: :smtp
  smtp_settings:
    enable_starttls_auto: true
    address: "AWS_SMTP_DOMAIN"
    port: 587
    domain: "REDMINE_DOMAIN"
    authentication: :login
    user_name: "YOUR_SMTP_USER"
    password: "YOUR_SMTP_PASSWORD"

After that, follow the steps detailed in our Configure SMTP For Outbound Emails guide as before and restart your services. I hope this solves your issue! If not, please share with us again your SMTP configuration as the recent migration of our servers has produced some issues with previously posted images.

Regards,
Francisco de Paz

Tried that too, it was still not working
At last, I created a dedicated google workspace account to configure the Gmail & now its working fine

Thanks @fdepaz for the information.

Glad to see you were able to solve your issue! We are marking the previous answer as “Solution” and this topic as “Closed”.

If you have any other questions, please do not hesitate to let us know. Feel free to create a new topic referencing this one if necessary.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart: