Server keeps going down while using wp-admin

Keywords: LAMP/MAMP/WAMP - AWS - Technical issue - Connectivity (SSH/FTP)
Description:
Hi,

My server shows Error 524 while using the wp-admin. I have just one website with almost 10 people visiting. Not sure why the server would keep going down. This doesn’t make sense. I have a 1 GB RAM, 1 vCPU, 40 GB SSD which is more than sufficient for such a small website.

Kindly help.

Hi @huzanforbes,

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

How to Run the Bitnami Support Tool in a cloud image or virtual machine

Please note that you need to paste the code ID that is shown at the end.

Regards,
Michiel

Hi @michiel

===== Begin of bndiagnostic tool output =====

? Apache: Found possible issues
✓ Connectivity: No issues found
? Resources: Found possible issues
✓ Mysql: No issues found
✓ Php: No issues found

[Apache]

Found recent error or warning messages in the Apache error log.

[Sun Jul 04 13:00:42.117052 2021] [authz_core:error] [pid 2979:tid 
139744990152448] [client **ip_address**:49313] AH01630: client denied by server 
configuration: /opt/bitnami/phpmyadmin/index.php, referer: 
http://15.207.63.175:80/phpmyadmin/index.php

Please check the following guide to troubleshoot server issues:
Press [Enter] to continue:
 
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-erro
rs-apache/

A high number of incoming requests originate from one or more unique IP 
addresses. This could indicate a bot attack. The following guide shows how to 
check for and block suspicious IP addresses.
 
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-
bots-apache/

[Resources]

Your instance has little available RAM memory.

total used free shared buff/cache available Mem: 983 765 94 1 123 85 Swap: 634
239 395

You could try to increase your instance's memory. Please check your cloud 
provider's documentation for more information.

===== End of bndiagnostic tool output =====

Hi @huzanforbes,

There seems to be an HTML encoding character in your URL. Can you click on this link?

https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/

Could you also paste the output ID of the bnsupport tool?

Regards,
Michiel

Hi @michiel

Refer here for the output:

Hi @huzanforbes,

Could you tell me the ID? Please note that you need to press Enter to continue after the bndiagnostic output to get the bnsupport output:

Regards,
Michiel

Hi @michiel

The support tool code 22142f80-9ffe-cd9e-9311-9b71678cb141

Hi @huzanforbes,

It does seem like an issue with RAM. Could you run the following command:

free -m

Regards,
Michiel

Hi @michiel

Not sure why RAM is an issue when there is only one website on a 1 GB RAM, 1 vCPU, 40 GB SSD with barely any visitors.

Are these visitors too many for the configuration?

Hi @huzanforbes,

Do you have a lot of active plugins? Plugins can have a big impact on performance. Can you tell me the output of this command:

wp plugin list

Regards,
Michiel

Hi @michiel

I have 32 plugins active however, I’ve NEVER had such an issue on a Bluehost/hostgator shared hoisting which had 5 sites on the same server.

Hi @huzanforbes,

It could be due to a difference in the configuration that could make an instance perform worse but the underlying cause could be a plugin. I recommend deactivating all the plugins and then activate them one by one to check if performance improves.

Regards,
Michiel

Hi @michiel

Is there a way to check which plugins are causing the issues? Is there a way to clear full/reset memory or clear files (tmp) which are not required?

Hi @huzanforbes,

I’m not aware of another way to check that except turning them off and then on again. If you’re running on a production server I recommend cloning the instance:

https://docs.bitnami.com/aws/faq/administration/clone-server/

And then disable the plugins on the cloned instance.

This guide shows how to optimise WordPress, it might help:

https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/optimize-bitnami-wordpress/

Regards,
Michiel