Server issues after copying the website to other instance

Keywords: WordPress Multisite - Google Cloud Platform - Technical issue - Application configuration

bnsupport ID: 58718cc7-e51c-95e1-d2f3-11679f2ad5ed

bndiagnostic output:

? Mariadb: Found possible issues
? Php: Found possible issues
? Resources: Found possible issues
? Apache: Found possible issues
? Wordpress: Found possible issues
https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-mariadb/
https://docs.bitnami.com/general/apps/akeneo/administration/increase-memory-limit/
https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-memory-linux/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/

bndiagnostic failure reason: I do not know how to perform the changes explained in the documentation

Description:
Hi, we needed to upgrade the php version of our instance, so we create a new wordpress multisite instance on php 7.4.X.

there are some issues, and we dont know how to fix. we would like to get some help in this.
uploading a plugin gives this: The uploaded file could not be moved to wp-content/uploads/sites/2.
a check on the instance says this: Your instance has little available RAM memory.
also this message came up: 28-Sep-2021 09:31:55] ERROR: fork() failed: Cannot allocate memory (12)

This error  indicates there is a problem with the memory limit in PHP. Please 
check the following guide to increase the number of PHP-FPM child processes:

can we get some help to fix this?

Hello @peter2,

Could you try increasing the memory limit by following this documentation?
https://docs.bitnami.com/aws/apps/wordpress/configuration/configure-phpfpm-options/

I hope it helps

hi, tnx for your reply…

i would like to know what values i should use and,

our php-fpm file looks like this:

[www]
include=/opt/bitnami/php/etc/environment.conf
include=/opt/bitnami/php/etc/common.conf
pm=dynamic
listen=/opt/bitnami/php/var/run/www.sock
listen.allowed_clients=127.0.0.1

; Memory settings adapted to the machine
; The file below will be overwritten after restarts
include=/opt/bitnami/php/etc/memory.conf

so i realy dont know what to add/change here…
please help…

the mentioned memory.conf in this file refers to this file:

; Bitnami memory configuration for PHP-FPM
;
; Note: This will be modified on server size changes

pm.max_children=400
pm.start_servers=260
pm.min_spare_servers=260
pm.max_spare_servers=300
pm.max_requests=5000

Hello @peter2,

It depends on your site’s requirements. This guide may help (even though it is focused on nginx):
https://www.kinamo.be/en/support/faq/determining-the-correct-number-of-child-processes-for-php-fpm-on-nginx

Let me share with you this previous answer.

Regards

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.