Server has been crashing after bitnami-wordpress-5.8.2-25 update

Keywords: WordPress - AWS - Technical issue - Services (Apache, MariaDB, MySQL…)

bndiagnostic ID: 57ae32ad-bde0-2e71-fb6d-66e43c23e8e8

bndiagnostic output:

? Apache: Found possible issues
? Connectivity: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/general/faq/administration/use-firewall/
https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-memory-linux/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
The server crashed 1 day after the update, and needed to be manually reset. Then again 3 days later it crashed. This has never happened before so I am not sure what may be the cause. I saw some issues on the support file logs.

Re: https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-memory-linux/

I don’t believe this is the issue, because I checked memory:
image

Hi @wronski,

As the tool mentioned, you have warnings in the Apache’s log and that might be related to the problem you are running into

[Tue Jan 11 19:40:22.377724 2022] [proxy_fcgi:error] [pid 3388:tid 140003359180544] [client 220.253.111.118:55068] AH01071: Got error 'PHP message: PHP Warning:  Illegal string offset 'slug' in /bitnami/wordpress/wp-      content/plugins/woocommerce/packages/woocommerce-admin/src/API/Reports/PerformanceIndicators/Controller.php on line 149PHP message: PHP Warning:  Illegal string offset 'slug' in /bitnami/wordpress/wp-content/plugins/      woocommerce/packages/woocommerce-admin/src/API/Reports/PerformanceIndicators/Controller.php on line 149PHP message: PHP Warning:  Illegal string offset 'slug' in /bitnami/wordpress/wp-content/plugins/woocommerce/packages/ woocommerce-admin/src/API/Reports/PerformanceIndicators/Controller.php on line 149PHP message: PHP Warning:  Illegal string offset 'slug' in /bitnami/wordpress/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/API/Reports/PerformanceIndicators/Controller.php on line 149PHP message: PHP Warning:  Illegal string offset 'slug' in /bitnami/wordpress/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/API/Reports/          PerformanceIndicators/Controller.php on line 149PHP message: PHP Warning:  Illegal string offset 'slug' in /bitnami/wordpress/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/API/Reports/PerformanceIndicators/Controller.php on line 149PHP message: PHP Warning:  Illegal string offset 'slug' in /bitnami/wordpress/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/API/Reports/PerformanceIndicators/Controller.php on     line 149PHP message: PHP Warning:  Illegal string offset 'slug' in /bitnami/wordpress/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/API/Reports/PerformanceIndicators/Controller.php on line 149', referer:   https://www.questcoffee.com.au/wp-admin/

Also, I found this error in the PHP-FPM’s log

[11-Jan-2022 10:01:03] WARNING: [pool www] seems busy (you may need to increase pm.start_servers, or pm.min/max_spare_servers), spawning 8 children, there are 3 idle, and 29 total children
[11-Jan-2022 10:01:04] WARNING: [pool www] server reached pm.max_children setting (30), consider raising it

It seems your server reached the limits. Try to increase those values

https://docs.bitnami.com/aws/apps/wordpress/configuration/configure-phpfpm-processes/

And finally, check if there is any bot/attacker accessing your site with malicious intentions

https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/deny-connections-bots-apache/

Thanks, @jota. I have started troubleshooting.

With regards to: https://docs.bitnami.com/aws/apps/wordpress/configuration/configure-phpfpm-processes/

I am using pm=dynamic however, the file /opt/bitnami/php/etc/common-dynamic.conf doesn’t seem to exist. See image below:

common.conf has the following contents:

user=daemon
group=daemon
listen.owner=daemon
listen.group=daemon

Could you please help me with this?

Hi @wronski,

Sorry for the wrong information. You can configure the PHP-FPM processes in the /opt/bitnami/php/etc/memory.conf file.