Server cannot be found with bitnami multi-site wordpress

Keywords: WordPress Multisite - OS X - Technical issue - Connectivity (SSH/FTP)
Description:
I’m new to Bitnami. When I run my Bitnami Wordpress, everything is fine. However when I run Bitnami multi-site wordpress, everything looks fine until I run the application and the server cannot be found.

When I run
-> systemctl status bitnami.service

bitnami.service - LSB: bitnami init script
Loaded: loaded (/etc/init.d/bitnami; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Tue 2021-05-25 21:24:39 UTC; 55min a
Process: 299 ExecStart=/etc/init.d/bitnami start (code=exited, status=3)
Tasks: 8 (limit: 764)
Memory: 74.4M
CGroup: /system.slice/bitnami.service
└─1735 /usr/bin/gonit

May 25 21:24:02 debian bitnami[299]: /opt/bitnami/apache2/scripts/ctl.sh : httpd
May 25 21:24:02 debian bitnami[299]: ## 2021-05-25 21:24:02+00:00 ## INFO ## Run
May 25 21:24:39 debian bitnami[299]: ## 2021-05-25 21:24:39+00:00 ## INFO ## Run
May 25 21:24:39 debian bitnami[299]: ## 2021-05-25 21:24:39+00:00 ## INFO ## Run
May 25 21:24:39 debian bitnami[299]: ## 2021-05-25 21:24:39+00:00 ## INFO ## Run
May 25 21:24:39 debian bitnami[299]: Starting gonit daemon
May 25 21:24:39 debian bitnami[299]: ## 2021-05-25 21:24:39+00:00 ## INFO ## Run
May 25 21:24:39 debian systemd[1]: bitnami.service: Control process exited, code
May 25 21:24:39 debian systemd[1]: bitnami.service: Failed with result 'exit-cod
May 25 21:24:39 debian systemd[1]: Failed to start LSB: bitnami init script.

Please help, I’m not sure where to go from here.

Hello @wes.lawler2,

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

Please note that you need to paste the code ID that is shown at the end.

Here’s the code ID:
49191fc3-1b8d-9683-4beb-eb21af43ba22

Here is the result of the diagnostic tool output:

===== Begin of bndiagnostic tool output =====

? Connectivity: Found possible issues
✓ Apache: No issues found
✓ Php: No issues found
? Resources: Found possible issues
? Mysql: Found possible issues

[Connectivity]

Server ports 22, 80 and/or 443 are not publicly accessible. Please check the
following guide to open server ports for remote access:

https://docs.bitnami.com/general/faq/administration/use-firewall/

[Resources]

Your instance has little available RAM memory.

              total        used        free      shared  buff/cache   available
Press [Enter] to continue:
Mem:            665         516          59           4          89          52
Swap:           634         149         485

You could try to increase your instance’s memory. Please check your cloud
provider’s documentation for more information.

[Mysql]

Found recent error messages in the MySQL error log:

2021-05-25T11:48:02.731936Z 0 [ERROR] [MY-010119] [Server] Aborting

Please check the following guide to troubleshoot MySQL issues:

https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-m
ysql/

===== End of bndiagnostic tool output =====

I’m lost on all three issues.

Hello @wes.lawler2,

Your machine is using a lot of swap

Note that WordPress recommends at least 700M of memory.

You could try to increase your machine memory:
https://docs.bitnami.com/installer/faq/osx-vm-faq/administration/change-required-memory-osx-vm/

Let me share with you our troubleshooting documentation:
https://docs.bitnami.com/installer/how-to/troubleshoot-wordpress-issues/

We also have a guide to optimize Wordpress:
https://docs.bitnami.com/installer/apps/wordpress/troubleshooting/optimize-bitnami-wordpress/

I hope it helps

I clicked the first link, the one to the process of increasing the machine memory. I can’t initiate the process because I do not know my directory’s name, the one that should go under APPNAME, as mentioned in the steps provided. How do I find this name?

Hello @wes.lawler2,

APP_NAME in your case should be wordpress.

Regards

So, I’ve tried upping the memory limit and cannot make it past the first command to even find the file. I’ve tried five different possible iterations(all pictured below) and still can’t find the file.

Hello @wes.lawler2,

Sorry, there was a typo in my previous answer. APP_NAME should be wordpressmultisite. Anyway, could you please execute this command to check your files under ~/.bitnami/stackman/machines/

ls -larthR ~/.bitnami/stackman/machines/

Regards

Regards

Ok, here is what I am getting. Also by the way, I really appreciate the support you are offering. Not everyone does this.

Hi @wes.lawler2,

Thanks for your kind words.

Maybe the documentation is not clear enough. Those commands need to be run outside the VM, in a terminal on your MAC OS X machine.

Could you try them again on your MAC machine?

Regards

The default interactive shell is now zsh.
To update your account to use zsh, please run `chsh -s /bin/zsh`.
For more details, please visit https://support.apple.com/kb/HT208050.
Wess-MBP:~ weslawler$ ls -larthR ~/.bitnami/stackman/machines/
total 0
drwxr-xr-x   4 weslawler  staff   128B Jan  6 21:53 ..
drwxr-xr-x   9 weslawler  staff   288B Jan  6 21:53 wordpress
drwxr-xr-x   4 weslawler  staff   128B Feb 24 20:00 .
drwxr-xr-x  10 weslawler  staff   320B May 23 21:35 wordpressmultisite

/Users/weslawler/.bitnami/stackman/machines//wordpress:
total 16
drwxr-xr-x  2 weslawler  staff    64B Jan  6 21:53 data
drwx------  4 weslawler  staff   128B Jan  6 21:53 ssh
drwxr-xr-x  6 weslawler  staff   192B Jan  6 21:53 vm
drwxr-xr-x  9 weslawler  staff   288B Jan  6 21:53 .
drwxr-xr-x  3 weslawler  staff    96B Jan  6 21:54 log
-rw-r--r--  1 weslawler  staff    39B Jan  6 21:55 db
drwxr-xr-x  4 weslawler  staff   128B Feb 24 20:00 ..
-rw-r--r--  1 weslawler  staff   1.5K May 28 18:13 metadata.json
drwxr-xr-x  3 weslawler  staff    96B May 28 18:22 tmp

/Users/weslawler/.bitnami/stackman/machines//wordpress/data:
total 0
drwxr-xr-x  2 weslawler  staff    64B Jan  6 21:53 .
drwxr-xr-x  9 weslawler  staff   288B Jan  6 21:53 ..

/Users/weslawler/.bitnami/stackman/machines//wordpress/ssh:
total 16
-rw-------  1 weslawler  staff   1.6K Jan  6 21:53 id_rsa
drwx------  4 weslawler  staff   128B Jan  6 21:53 .
-rw-------  1 weslawler  staff   381B Jan  6 21:53 id_rsa.pub
drwxr-xr-x  9 weslawler  staff   288B Jan  6 21:53 ..

/Users/weslawler/.bitnami/stackman/machines//wordpress/vm:
total 13548888
-rw-r--r--  1 weslawler  staff    24M Jan  6 21:53 initrd.img
-rw-r--r--  1 weslawler  staff   5.0M Jan  6 21:53 vmlinuz
drwxr-xr-x  6 weslawler  staff   192B Jan  6 21:53 .
drwxr-xr-x  9 weslawler  staff   288B Jan  6 21:53 ..
-rw-r--r--  1 weslawler  staff   512K Jan  6 21:54 firstboot.qcow2
-rw-r--r--  1 weslawler  staff   6.5G May 28 18:22 machine.qcow2

/Users/weslawler/.bitnami/stackman/machines//wordpress/log:
total 128
drwxr-xr-x  9 weslawler  staff   288B Jan  6 21:53 ..
drwxr-xr-x  3 weslawler  staff    96B Jan  6 21:54 .
-rw-r--r--  1 root       staff    64K May 28 18:13 boot.log

/Users/weslawler/.bitnami/stackman/machines//wordpress/tmp:
total 0
drwxr-xr-x  9 weslawler  staff   288B Jan  6 21:53 ..
lrwxr-xr-x  1 root       staff    12B May 28 18:13 tty -> /dev/ttys000
drwxr-xr-x  3 weslawler  staff    96B May 28 18:22 .

/Users/weslawler/.bitnami/stackman/machines//wordpressmultisite:
total 16
drwxr-xr-x   4 weslawler  staff   128B Feb 24 20:00 ..
drwxr-xr-x   2 weslawler  staff    64B Feb 24 20:00 data
drwx------   4 weslawler  staff   128B Feb 24 20:00 ssh
drwxr-xr-x   6 weslawler  staff   192B Feb 24 20:00 vm
drwxr-xr-x   3 weslawler  staff    96B Feb 24 20:00 log
drwxr-xr-x  10 weslawler  staff   320B May 23 21:35 .
drwxr-xr-x   3 weslawler  staff    96B May 23 21:35 volumes
-rw-r--r--   1 weslawler  staff    86B May 28 18:45 db
-rw-r--r--   1 weslawler  staff   1.5K Jun  1 18:32 metadata.json
drwxr-xr-x   3 weslawler  staff    96B Jun  2 07:11 tmp

/Users/weslawler/.bitnami/stackman/machines//wordpressmultisite/data:
total 0
drwxr-xr-x   2 weslawler  staff    64B Feb 24 20:00 .
drwxr-xr-x  10 weslawler  staff   320B May 23 21:35 ..

/Users/weslawler/.bitnami/stackman/machines//wordpressmultisite/ssh:
total 16
-rw-------   1 weslawler  staff   1.6K Feb 24 20:00 id_rsa
drwx------   4 weslawler  staff   128B Feb 24 20:00 .
-rw-------   1 weslawler  staff   381B Feb 24 20:00 id_rsa.pub
drwxr-xr-x  10 weslawler  staff   320B May 23 21:35 ..

/Users/weslawler/.bitnami/stackman/machines//wordpressmultisite/vm:
total 8860768
-rw-r--r--   1 weslawler  staff    24M Feb 24 20:00 initrd.img
-rw-r--r--   1 weslawler  staff   5.0M Feb 24 20:00 vmlinuz
drwxr-xr-x   6 weslawler  staff   192B Feb 24 20:00 .
-rw-r--r--   1 weslawler  staff   512K Feb 24 20:00 firstboot.qcow2
drwxr-xr-x  10 weslawler  staff   320B May 23 21:35 ..
-rw-r--r--   1 weslawler  staff   4.2G Jun  2 07:10 machine.qcow2

/Users/weslawler/.bitnami/stackman/machines//wordpressmultisite/log:
total 128
drwxr-xr-x   3 weslawler  staff    96B Feb 24 20:00 .
drwxr-xr-x  10 weslawler  staff   320B May 23 21:35 ..
-rw-r--r--   1 root       staff    64K Jun  1 18:32 boot.log

/Users/weslawler/.bitnami/stackman/machines//wordpressmultisite/volumes:
total 0
drwxr-xr-x  10 weslawler  staff   320B May 23 21:35 ..
drwxr-xr-x   2 weslawler  staff    64B May 23 21:35 root
drwxr-xr-x   3 weslawler  staff    96B May 23 21:35 .

/Users/weslawler/.bitnami/stackman/machines//wordpressmultisite/volumes/root:
total 0
drwxr-xr-x  2 weslawler  staff    64B May 23 21:35 .
drwxr-xr-x  3 weslawler  staff    96B May 23 21:35 ..

/Users/weslawler/.bitnami/stackman/machines//wordpressmultisite/tmp:
total 0
drwxr-xr-x  10 weslawler  staff   320B May 23 21:35 ..
lrwxr-xr-x   1 root       staff    12B Jun  1 18:32 tty -> /dev/ttys001
drwxr-xr-x   3 weslawler  staff    96B Jun  2 07:11 .
Wess-MBP:~ weslawler$

Hi @wes.lawler2,

Thanks for the detailed information. You have to follow the steps in the guide @davidg mentioned with APP_NAME=wordpressmultisite to update the memory needed in WordPress Multisite. Remember you will need to install the jq tool in case you don’t have it already installed and to replace the MEMORY placeholder with the new value. You can replace it with 1024 to use 1 GB.

So, with the command to optimize my memory, it seems the command only runs on my computer’s general terminal but not my bitnami virtual machine. I ran the commands for optimizing the memory through my computer’s general cli terminal(see screenshot below) but it still does not seem to be enough memory. I’ve tried both the brew method and the sudo apt-get method for getting jq installed to optimize the memory through the bitnami vm but to no avail.

Screenshot of increased memory and failed jq installations:

Linux debian 4.19.0-13-amd64 #1 SMP Debian 4.19.160-2 (2020-11-28) x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
       ___ _ _                   _
      | _ |_) |_ _ _  __ _ _ __ (_)
      | _ \ |  _| ' \/ _` | '  \| |
      |___/_|\__|_|_|\__,_|_|_|_|_|
  
  *** Welcome to the Bitnami WordPress Multisite 5.6.2-0                           ***
  *** Documentation:  https://docs.bitnami.com/installer/apps/wordpress-multisite/ ***
  ***                 https://docs.bitnami.com/installer/                          ***
  *** Bitnami Forums: https://community.bitnami.com/                               ***

#######################################################
###    For frequently used commands, please run:    ###
###         sudo /opt/bitnami/bnhelper-tool         ###
#######################################################

Last login: Wed Jun  9 21:31:41 2021 from 192.168.64.1
root@debian:~# free -h
              total        used        free      shared  buff/cache   available
Mem:          985Mi       448Mi       157Mi        21Mi       380Mi       380Mi
Swap:         634Mi        14Mi       620Mi
root@debian:~# brew install jq
-bash: brew: command not found
root@debian:~# sudo apt-get install jq
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package jq
root@debian:~#

Linux debian 4.19.0-13-amd64 #1 SMP Debian 4.19.160-2 (2020-11-28) x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
       ___ _ _                   _
      | _ |_) |_ _ _  __ _ _ __ (_)
      | _ \ |  _| ' \/ _` | '  \| |
      |___/_|\__|_|_|\__,_|_|_|_|_|
  
  *** Welcome to the Bitnami WordPress Multisite 5.6.2-0                           ***
  *** Documentation:  https://docs.bitnami.com/installer/apps/wordpress-multisite/ ***
  ***                 https://docs.bitnami.com/installer/                          ***
  *** Bitnami Forums: https://community.bitnami.com/                               ***

#######################################################
###    For frequently used commands, please run:    ###
###         sudo /opt/bitnami/bnhelper-tool         ###
#######################################################

Last login: Wed Jun  9 21:31:41 2021 from 192.168.64.1
root@debian:~# free -h
              total        used        free      shared  buff/cache   available
Mem:          985Mi       448Mi       157Mi        21Mi       380Mi       380Mi
Swap:         634Mi        14Mi       620Mi
root@debian:~# brew install jq
-bash: brew: command not found
root@debian:~# sudo apt-get install jq
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package jq
root@debian:~#

Hello @wes.lawler2,

From the guide I shared with you, all the commands need to be run on your MAC OS terminal. These would be the steps:

  • Open your MAC OS terminal
  • Install jq with brew update && brew install jq command
  • Update the memory with the command below:
cat ~/.bitnami/stackman/machines/wordpressmultisite/metadata.json | jq '.requiredMemory = 1024' | tee ~/.bitnami/stackman/machines/wordpressmultisite/metadata.json

After that, access your OSX VM terminal (Open terminal button) to verify the change by executing free -h (note that this is the only command that you need to run inside the VM).

Checking your output, it seems that the new memory setting were updated:

root@debian:~# free -h
              total        used        free      shared  buff/cache   available
Mem:          985Mi       448Mi       157Mi        21Mi       380Mi       380Mi
Swap:         634Mi        14Mi       620Mi

Are you still facing the initial issues? In that case, please run the support tool again from inside the OSX VM terminal.

Regards

I do appear be running into the same issue. I’ve run the diagnostic tool twice and they appear slightly different from one another but saying the same thing. Both results also have been unable to automatically upload. When I did run these diagnostic, I was outside of my home’s internet and I instead was using a local university’s internet. Maybe that interfered with the automatic upload. Still, I can’t seem to locate the files on my Mac to do a manual upload. I’ll provide a screen shot in the following reply. If this does end up being a memory issue, could other programs on my mac be causing interference? Specifically, the program Final Cut Pro. Also, why would the bitnami program that I run for just one wordpress site work and not the bitnami program for multisite? I had yet to really even begin to develop sites on the multisite program before it stopped working. Should I delete the other bitnami program and just use multi-site? Anyways, thanks for your help.

1

    ? Connectivity: Found possible issues
    ✓ Apache: No issues found
    ✓ Php: No issues found
    ? Resources: Found possible issues
    ? Mysql: Found possible issues
 
[Connectivity]

Server ports 22, 80 and/or 443 are not publicly accessible. Please check the 
following guide to open server ports for remote access:

https://docs.bitnami.com/general/faq/administration/use-firewall/
[Resources]

Your instance has little available RAM memory.
              total        used        free      shared  buff/cache   available
Press [Enter] to continue:
Mem:            985         726          70          19         188          96
Swap:           634          46         588
You could try to increase your instance's memory. Please check your cloud 
provider's documentation for more information.
[Mysql]

Found recent error messages in the MySQL error log:

2021-06-10T23:58:56.630709Z 0 [ERROR] [MY-010119] [Server] Aborting

Please check the following guide to troubleshoot MySQL issues:
 
https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-m
ysql/

2

    ? Connectivity: Found possible issues
    ✓ Apache: No issues found
    ✓ Php: No issues found
    ✓ Resources: No issues found
    ? Mysql: Found possible issues
 
[Connectivity]

Server ports 22, 80 and/or 443 are not publicly accessible. Please check the 
following guide to open server ports for remote access:

https://docs.bitnami.com/general/faq/administration/use-firewall/

Your instance is using swap memory: total used free shared buff/cache available 
Mem: 985 451 309 18 224 371 Swap: 634 240 394This usually means that your 
instance is running low on memory. You could try to increase your instance's 
memory. Please check your cloud provider's documentation for more information.

[Mysql]

Found recent error messages in the MySQL error log:
2021-06-11T00:10:06.628546Z 0 [ERROR] [MY-010119] [Server] Aborting

Please check the following guide to troubleshoot MySQL issues:
 
https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-m
ysql/
 

Hello @wes.lawler2,

I cannot see a specific issue. Could you try the following?

  • Stop and close your wp-multisite VM.
  • Remove the folder:
rm -rf /Users/weslawler/.bitnami/stackman/machines/wordpressmultisite

Note: I understand you don’t have data to backup in your WPMS instance

Please let us know if it helps

Regards

Success! Everything appears to be running fine. I’ve located the credentials and have accessed the admin page. Thank you for the support.

Thanks,

Wes

Nice to hear that.

Regards