Running into Error trying to downgrade from LAMP7.x stack to LAMP 5.6.x

Keywords: LAMP/MAMP/WAMP - Installers - How to - Application configuration

Description:
I am trying to downgrade the from AWS lightsail LAMP(PHP 7.x) down to Lamp5.6.4 by doing the following:

1-connected via SSH to server,

2 - Stop all the services and remove the LAMP 7 Stack.

sudo /opt/bitnami/ctlscript.sh stop

3- sudo mv /opt/bitnami /opt/bitnami.bak
4- cd /tmp
5- curl -LJO "https://downloads.bitnami.com/files/stacks/lampstack/5.6.31-0/bitnami-lampstack-5.6.31-0-linux-x64-installer.run"

6-

chmod +x  ./bitnami-lampstack-5.6.31-0-linux-x64-installer.run
sudo ./bitnami-lampstack-5.6.31-0-linux-x64-installer.run --prefix /opt/bitnami

7- sudo ./bitnami-lampstack-5.6.31-0-linux-x64-installer.run --prefix /opt/bitnami

Then I got this (See Error at Very bottom)

Welcome to the Bitnami LAMP Stack Setup Wizard.

----------------------------------------------------------------------------
Select the components you want to install; clear the components you do not want 
to install. Click Next when you are ready to continue.

Varnish [Y/n] :n

Zend Framework [Y/n] :n

Symfony [Y/n] :n

CodeIgniter [Y/n] :n

CakePHP [Y/n] :Y

Smarty [Y/n] :n

Laravel [Y/n] :n

PhpMyAdmin : Y (Cannot be edited)

Is the selection above correct? [Y/n]: Y

----------------------------------------------------------------------------
Installation folder

Please, choose a folder to install Bitnami LAMP Stack

Select a folder [/opt/bitnami]: Y

--------

----------------------------------------------------------------------------
Create MySQL 'root' Account

Bitnami LAMP Stack database root user creation

Password :
Re-enter :
Warning: Please use only alphanumeric characters in your password
Press [Enter] to continue:
----------------------------------------------------------------------------
Create MySQL 'root' Account

Bitnami LAMP Stack database root user creation

Password :
Re-enter :
----------------------------------------------------------------------------
Setup is now ready to begin installing Bitnami LAMP Stack on your computer.

Do you want to continue? [Y/n]: Y

----------------------------------------------------------------------------
Please wait while Setup installs Bitnami LAMP Stack on your computer.

 Installing
 0% _
Please wait while Setup installs Bitnami LAMP Stack on your computer.

 Installing
 0% ______________ 50% ______________ 100%
 ########################################
Error: Unknown error while running /tmp/Y/php/bin/php -q 
/tmp/Y/php/bin/fixreg.php /tmp/Y/php/lib/php/.registry @@BITROCK_PHP_ROOT@@ 
/tmp/Y/php
Press [Enter] to continue: 

After Installation finished, Message was Your Stack may have not been correctly installed

Can anyone help??

Fixed: This was due to extreme low memory. I upgraded to an Instance with higher memory and it did the trick. When initially testing a proof of concept, I went for the lowest (750 hrs free) instance and sure enough it only comes with 512MB. Not enough.

Glad to see you were able to solve your issue! We are marking the previous answer as “Solution” and this topic as “Closed”.

If you have any other questions, please do not hesitate to let us know. Feel free to create a new topic referencing this one if necessary.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.