Running ghost version 4.10.2, cannot edit posts in blog because it is missing versions of things inside node.js

Keywords: Ghost - AWS - Technical issue - Application configuration

bnsupport ID: a47f3955-1fe8-95f1-5868-b04ccdfe6d55

bndiagnostic output:

? Apache: Found possible issues
? Mariadb: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/
https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-mariadb/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
Installed new server. Configured my website address. Using cloudflare for SSL (just cloudflare, not SSL on apache but I will add that later)

Ghost seems to be fine then go to edit a post and received an error about missing packages.

updated ghost cli
Force reinstall ghost with ghost update 4.10.2 --force to reinstall all dependencies

:heavy_multiplication_x: Stopping Ghost
An error occurred.
Message: 'Cannot find module ‘fkill’
Require stack:

  • /opt/bitnami/ghost/versions/4.10.2/node_modules/ghost-cli/lib/utils/local-process.js
  • /opt/bitnami/ghost/versions/4.10.2/node_modules/ghost-cli/lib/system.js
  • /opt/bitnami/ghost/versions/4.10.2/node_modules/ghost-cli/lib/command.js
  • /opt/bitnami/ghost/versions/4.10.2/node_modules/ghost-cli/lib/bootstrap.js
  • /opt/bitnami/ghost/versions/4.10.2/node_modules/ghost-cli/bin/ghost’

This error showed up.

Hi @jhoke6,

I couldn’t reproduce the issue. Did you change any configuration files or install any plugins? Did you configure the domain as well?

https://docs.bitnami.com/aws/apps/ghost/administration/configure-domain/

Regards,
Michiel

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.