RS Post Installation Error - ver 7.7-2 x64 - bad MySQL config

OS: RHEL6
Receiving following error when first trying to launch ResourceSpace following ‘successful’ install and seemingly successful startup of my apache and mysql servers startup:
/apps/resourcespace/htdocs/include/db.php line 122: mysqli_connect(): (HY000/1045): Access denied for user ‘root’@‘localhost’ (using password: NO)

NOTE: I experience the same error/problem whether or not I run the installler as linux root user or non-root.
Does the Installer itself generate a Run LOG file which I could analyze to find out where it may have encountered errors and possibly failed to complete the overall installation as intended by Bitnami? The installer reports that it was successful when run and shows no evidence of any problems or errors.

I researched the overall config setup of RS Stack installation, seems that the main config file (?) :
/apps/resourcespace/htdocs/include/config.php
has very few directives/lines in it (as compared to the config.default.php file template);
including absolutely no information regarding the proper user/password combo to use when connecting
to MySQL. (please see the ‘sparse’ contents of my config.php file just below)
I’m having a lot of trouble determining what the default MySQL passwords are for both ‘root’
and the seemingly-desired ‘bn_resourcespace’ mysql users which seem to have been set up as part of the install.
MySQL even fails when I try to supply the password I entered during the installer’s prompting.
I have been able to ‘break into’ MySQL and login in order to discern that the ‘bn_resourcespace’ user has indeed been created in MySQL.
I was tempted to try to continue to hack more and more information into the config.php file to see if I could get RS up and connected to MySQL correctly, but I wanted to create this Topic in order to report that something seems to be broken with the current linux installer (named: bitnami-resourcespace-7.7-2-linux-x64-installer.run ). I’m really not sure what else may need to be manually configured into this Stack at this point…

[ my config.php looks like the following … ]

$mysql_bin_path = ‘/home/greg/rspace/mysql/bin’;
$imagemagick_path = ‘/home/greg/rspace/common/bin’;
$ghostscript_path = ‘/home/greg/rspace/common/bin’;

#Paths
$ftp_server = ‘my.ftp.server’;
$ftp_username = ‘my_username’;
$ftp_password = ‘my_password’;
$ftp_defaultfolder = ‘temp/’;
$thumbs_display_fields = array(8,3);
$list_display_fields = array(8,3,12);
$sort_fields = array(12);

$storagedir = ‘/home/greg/rspace/apps/resourcespace/htdocs/filestore/’;
$imagemagick_colorspace= ‘sRGB’;
$mysql_charset = ‘utf8’;

Hi @anyburl

Yes, the installer generates a log file. Could you please send this log file to fortiz [at] bitnami [dot] com in order to check the issue? You can find it at /tmp/bitrock_installer.log

Regards,
Fran