Review Board version mismatch

Keywords: ReviewBoard - Amazon Web Services - Technical issue - Upgrade
Description:
The version of Review Board running does not match the version the site was last upgraded to. You are running 3.0 and the site was last upgraded to 3.0.6.

Please upgrade your site to fix this by running:

$ rb-site upgrade /opt/bitnami/apps/reviewboardpowerpack/htdocs/rb-sites/reviewboard

Then restart the web server.

I did this and still no joy. I backed up the /opt/bitnami/apps/reviewboardpowerpack/htdocs folder before I started and putting it back makes no difference as I see my previous version of rb under python has been deleted. What can I do to get back to a working version of RB or better still get 3.0.6 working. Any help is greatly appreciated.

Many Thanks,
JB

Got it sorted

from the upgrade instructions here:
https://docs.bitnami.com/installer/apps/reviewboard/

cd installdir/apps/reviewboard/htdocs/
sudo venv/bin/easy_install -U ReviewBoard
sudo venv/bin/rb-site upgrade installdir/apps/reviewboard/rb-sites/reviewboard/

on running upgrade command
I was getting a message “Cannot locate wrapped file”

so I did “sudo su” and did the following:

cd installdir/apps/reviewboard/htdocs/
venv/bin/easy_install -U ReviewBoard
venv/bin/rb-site upgrade installdir/apps/reviewboard/rb-sites/reviewboard/

and everything works again, yah!

Thanks,
JB

Hi @john.brady,

Great to hear you’ve solved the issue :smile: Thanks for sharing the solution.

Regards,
Michiel

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.