Redmine - Force SSL / HTTPS in Windows

Hi again!

I am now able to load my login page via https.
But when I try to login I get redirected to http://mydomain/redmine/my/page , without httpS!
When I type in https://mydomain/redmine/my/page erveything works fine.
Also inside of Redmine (after login) everything is forwarded with httpS.
When I logout I get redirected to http://mydomain/redmine/, also without httpS!

My redmine.conf looks like:

ProxyPass /redmine balancer://redminecluster
ProxyPassReverse /redmine balancer://redminecluster

Proxy balancer://redminecluster
RequestHeader set X_FORWARDED_PROTO ‘https’
BalancerMember http://127.0.0.1:3001/redmine
BalancerMember http://127.0.0.1:3002/redmine
/Proxy


So the RequestHeader is set...
Does anybody know how to fix this? Thanks in advance!

Try to restart the servers and clean your browser cache. Do you continue having this issue?

Thanks for the input. But I still get redirected to the http site.

Any suggestions how to configure the forwarding?? Thanks!

Does anybody have a solution for this problem? Thanks in advance!

Have you changed anything else in route.rb or any configuration apache file?

Maybe there is some route hardcoded. Please double check your configurations file because this is very strange.

Any advice what I have to look for? Just for hardcoded URLs?

I installed a completely new Redmine Stack and changed some files today:
- Apache, httd.conf (activate ssl)
- Apache, httd-ssl.conf
- Redmine, redmine.conf (requestHeader)
- Redmine, plugins
- Redmine, views, settings, _authentication.html.erb (auto-logout)
- Redmine, models, mailer.rb (Mail subject)
- Redmine, public, favicon & logo

That is all I canged in the files... Also I imported my last SQL database... Would be great if you could help me!

Did you configure Redmine app? Try to set Adminitration > Configuration > Protocol to https.

Yes I did this... was included in the SQL database I've imported. Is there anything I could tell you to figure out what's wrong?

Is there anything I have to pay attention to when I set the hostname in the Redmine Adminsitration?

And do I have to change the httpd.conf -> Listen port aswell or is thisnot used because off the activated ssl?

I think that this is the normal behavior of Redmine. A workaround is that you can remove the "Listen 80" line in the httpd.conf so only 443 will be available.

I get still redirected to http... I need to figure this out soon. Does anybody have an additional idea?

I have now tried to set up a complete new instance of Redmine. It was installed to port 88 and only httd.conf and httpd-ssl.conf in the apache-> config-folder and the redmine-config-file were changed like mentioned in the wiki. I didn't change any other file or the database.

But the behaviour is still the same:

I can load the httpS-login site. But when I press "Anmelden"/"Login" I get redirected to a http-site with port 80!
Teh I have to add the httpS and the port 443 by hand to get to this:

Inside of the logged-in-area I can move normally. Afterwards I want to logout and the same thing happens:

As you can see the login/logout-action tries to load port 80 instead of 88 (without SSL) or 443 (with SSL).

Does anybody have an advice how to solve this? THANKS!

For the solution look at:

http://community.bitnami.com/questions/7972/redmine-home-url

/7972

Thank you for summarizing this.