Redirect loop when logged in my wordpress site

Keywords: WordPress - AWS - Technical issue - Secure Connections (SSL/HTTPS)
bnsupport ID: 20210611-163137-22246
Description:
when i login as vendor in my worpress site, and clicked the home page i get a redirect loop, this only happends with this role.

Hi @applications,

Thanks for using Bitnami. Unfortunately, the bnsupport ID you provided is not valid. Can you run the tool again and share with us the generated code? If the tool has issues uploading the results to the Bitnami servers, please follow the next guide to manually update it

https://docs.bitnami.com/aws/how-to/understand-bnsupport/#manually-upload-the-bitnami-support-tool-bundle

The tool will also show you the issues detected and propose some solutions. Can you check them as well?

Hi @gongomgra,

I run the tool again.
this is the code: a557772b-d595-8ec0-99e4-99ad2f9fbbb1

Hi @applications,

Thanks for the bnsupport code. I see you configured the WordPress domain with HTTPS in wp-config.php, but I don’t see the HTTPS redirect configured in Apache. Can you set it, restart the services and try to log into WordPress admin panel again?

https://docs.bitnami.com/aws/apps/wordpress/administration/force-https-apache/

I added the apache HTTPS configuration, but the problem continue. This only happens when i login as a vendor role. The web site redirect me to the dashboard , but when i click the home page i get redirect loop error. If i am login as administrator or i am not login the web page work fine.

Hi @applications,

Can you check the database values as well?

sudo mysql -u bn_wordpress -p -e "USE bitnami_wordpress; SELECT option_name,option_value FROM wp_options WHERE option_name='siteurl' OR option_name='home';"

If needed, you can update it with the next commands. Remember to replace YOUR_DOMAIN with your actual value

sudo mysql -u bn_wordpress -p -e "USE bitnami_wordpress; UPDATE wp_options SET option_value='https://YOUR_DOMAIN/' WHERE option_name='siteurl' OR option_name='home';"

Hi @gongomgra,

I checked the database to get the URL and both are in HTTPS.

Hi @applications,

Thanks for the info. If both the wp-config.php file and the database information is showing the https://YOUR_DOMAIN values correctly, I’m afraid I don’t know what else you can check to try to fix it. Can you run the bnsupport tool again so we can check the updated config?

Additionally, we recommend you to ask for help in the official WordPress forums, where someone with more experience using the application may be able to help you

https://wordpress.org/support/forums/

I ran the code: a557772b-d595-8yc0-99e4-994d2f9fcbb16

Hi @gongomgra.

Thnaks for your help. I resolved the problem, the error was caused by the plugin Ultimate Member, i deactivated the plugin and all work fine.

Hi @applications,

Thanks for the info. I’m glad you fixed your issue! We will close this thread as solved. Please do not hesitate to open a new one with any other questions you may have.