Recovering filestore database using Resourcespace

Using Resourcespace version 6.1.5219 in a Bitnami Vmware Appliance I tried to use the recover.php script.

I´m getting the error: /opt/bitnami/apps/resourcespace/htdocs/pages/tools/recover.php line 238: SimpleXMLElement::__construct(): namespace error : Namespace prefix resourcespace for resourceid on record is not defined

Is there someone to give a little help in this subject?

Thanks in advance,
Claudio Bastos

Hello @claudio_bitnami.

Could you please give us more information about how you are running the script or how to reproduce this issue?

Best regards.

David.

Edited the recover script with the Filestore source path.
Go to the path /opt/bitnami/apps/resourcespace/htdocs/include/
Running using command ./recover.php

Hi,

I tried to reproduce the issue but I did not get that error. Did you remove the columns in the database that they recommend to remove it? It seems you also posted in the ResourceSpace google group so maybe the ResoureceSpace developer could give you more info.

   Note that after using this script you will need to:
	1) Drop columns such as field8, field12, etc. from the 
	   resource table. The system will then recreate them 
	   with the proper data.

	2) Reindex the database using the pages/tools/reindex.php script.

The action of dropping the columns is after running the script.
This error is happening at the 4th reource being recovered.

Unfortunately there was no answer at the Google group.

Did you manage to run the script in a filestore and it re-created the database?

Hi @claudio_bitnami,

I’m sorry but we are not able to reproduce it. I’m sure that the ResourceSpace developers are going to help you better than us in this case.