RDP is not Working on AWS Market AMI by Bitnami

Type: Bitnami Support Tool

Description:
We can able to launch the guacamole console successfully after launching an Amazon EC2 Linux instance. The RDP is not working to one of the Windows server which is sitting same network.

Windows Response :

  1. Please wait for Local session Manager
  2. Waiting for Group Policy Client.

Catalina and Guacd.log are below:

guacd.log:

==========================================
guacd[2092]: INFO:      Creating new client for protocol "rdp"
guacd[2092]: INFO:      Connection ID is "$e57b80a7-6c63-40db-ba54-df3f29dee092"
guacd[10317]: INFO:     Security mode: Negotiate (ANY)
guacd[10317]: INFO:     Resize method: none
guacd[10317]: INFO:     User "@e5a80713-3c6d-4dbb-a3fc-92c24e5c2896" joined connection "$e57b80a7-6c63-40db-ba54-df3f29dee092" (1 users now present)
guacd[10317]: INFO:     Loading keymap "base"
guacd[10317]: INFO:     Loading keymap "en-us-qwerty"
guacd[10317]: INFO:     Connected to RDPDR 1.13 as client 0x0003
free(): double free detected in tcache 2
guacd[2092]: INFO:      Connection "$e57b80a7-6c63-40db-ba54-df3f29dee092" removed.
guacd[2092]: INFO:      Creating new client for protocol "rdp"
guacd[2092]: INFO:      Connection ID is "$7dd39a14-8ad1-49f7-9570-9fe1655e8caa"
guacd[10332]: INFO:     Security mode: Negotiate (ANY)
guacd[10332]: INFO:     Resize method: none
guacd[10332]: INFO:     User "@6f616878-0409-4e58-8a20-9dc7809133f8" joined connection "$7dd39a14-8ad1-49f7-9570-9fe1655e8caa" (1 users now present)
guacd[10332]: INFO:     Loading keymap "base"
guacd[10332]: INFO:     Loading keymap "en-us-qwerty"
guacd[10332]: INFO:     Connected to RDPDR 1.13 as client 0x0003
free(): double free detected in tcache 2
guacd[2092]: INFO:      Connection "$7dd39a14-8ad1-49f7-9570-9fe1655e8caa" removed.
===============================================

catalina.out:
================================================
14:03:15.356 [http-nio-8080-exec-6] INFO  o.a.g.tunnel.TunnelRequestService - User "guacadmin" connected to connection "5".
14:03:16.041 [Thread-172] INFO  o.a.g.tunnel.TunnelRequestService - User "guacadmin" disconnected from connection "5". Duration: 684 milliseconds
14:03:19.821 [http-nio-8080-exec-10] INFO  o.a.g.tunnel.TunnelRequestService - User "guacadmin" connected to connection "4".
14:03:20.171 [Thread-174] INFO  o.a.g.tunnel.TunnelRequestService - User "guacadmin" disconnected from connection "4". Duration: 349 milliseconds
14:03:24.033 [http-nio-8080-exec-9] INFO  o.a.g.tunnel.TunnelRequestService - User "guacadmin" connected to connection "5".
===========================================

Thanks,
Sanjeevi

Hi @smahalingam,

Could you ask in the official Guacamole community forum to debug this issue? They have more knowledge of how the application works.

http://guacamole.apache.org/support/