Promoted an ephemeral external IP address, Google Cloud not working

Keywords: CouchDB - Google Cloud Platform - Technical issue - Connectivity (SSH/FTP)
Description:
Very simple, see under “Promoting an ephemeral external IP address”: https://cloud.google.com/compute/docs/ip-addresses/reserve-static-external-ip-address
Now I can’t connect to my pouchdb at http://104.154.38.45:5984/_utils
I also can’t even ping it. I tried restarting the server. What else do I do? Thanks.

Maybe I now need to add a firewall rule? Not sure about the other options listed like Routes.

Hi @jhchadwick63,

To connect to CouchDB remotely, we suggest you use a SSH tunnel to connect to it instead of opening the port in the firewall. However, our documentation explains how to open the port and configure CouchDB to accept remote connections

https://docs.bitnami.com/google/infrastructure/couchdb/administration/connect-remotely/

Happy to help!


Was my answer helpful? Click on :heart:

I wasn’t connecting so I was about to reboot but I hit shutdown by mistake. I clicked reboot after. However now I can’t connect. I tried “LAUNCH SSH CONSOLE” but I get “You cannot connect to the VM instance because of an unexpected error. Wait a few moments and then try again. (#13)” How do I start the server? I would guess ther is no “STARTUP” option since “REBOOT” should work.

Also, in regards to remotely connecting to pouchdb, when I had the External IP Ephemeral (not static) I was connecting from Cloudways server fine by using the pem key (which I uploaded to that server). One thing I think I was confused about was the pinging of the IP. I thought if you can’t ping you can’t connect. I’m learning this network stuff. Thanks for your help.

Sorry I didn’t really respond to your point. Indeed I was using an SSH tunnel from the other server (my Cloudways server), so I don’t need to open a port in the firewall.

Anyway, I also tried Putty, WinSCP and they time out. I think it is just down. There should be some response, no? Searching how to start it or troubleshoot. I used to be able to connect to the bitnami server, but not since I changed it to static.

On the VM instance page I can stop or reset my instance with the external IP address, “which can lead to filesystem corruption”. Reset deletes all data on server? Should I try this next?

Hi @jhchadwick63,

To sum up, you did shutdown the instance using the Google Console and then restarted it. From that time on, you can access the instance, right?

Please note that the IP of you instance changes when rebooting the instance, did you obtain the new IP from the Google console? Please ensure that it’s the correct one when using the ssh commands to create the tunnel. [quote=“jhchadwick63, post:4, topic:62465”]
I tried “LAUNCH SSH CONSOLE” but I get “You cannot connect to the VM instance because of an unexpected error. Wait a few moments and then try again. (#13)”
[/quote]

Does that error appear in the Google console? Can you share a screenshot with us?

Thanks

Confirmed: you did shutdown the instance using the Google Console and then restarted it. From that time on, you can access the instance, right?

IP address updated.

I never touched any settings, like the FIrewall rules. It shows tcp:22 is open. It seems like my server is down.

So shouldn’t using the option “Lauch SSH Console” always work?

Link in message “We are unable to connect to the VM on port 22. Learn more about possible causes of this issue.”:
Learn more

At that link I see: The instance is shut down. Verify that the instance is up and running. See this guide for information on how you can troubleshoot an unhealthy instance.

Now looking at:
https://cloud.google.com/compute/docs/troubleshooting/general-tips

That page is useless.

I tried stopping and start my VM Instance “bitnami-couchdb-dm-7dc9” but it did nothing. Should I try “Reset”.

I am looking at:
https://cloud.google.com/compute/docs/troubleshooting/troubleshooting-ssh
This command: gcloud compute instances describe bitnami-couchdb-dm-7dc9 --format=‘get(networkInterfaces[0].accessConfigs[0].natIP)’
returns “No zone specified”. Any help is appreciated.

On that page at “Test the network”
This worked:
gcloud compute instances describe bitnami-couchdb-dm-7dc9 --zone=us-central1-c --format=‘text’
Of course returned 104.154.38.45 22 as external natIP

Any idea how to get to the next step in:

Check for SSH banner

user@loal:$ nc [EXTERNAL_IP] 22

Don’t know what to do here.

In windows I try ping 104.154.38.45:22
In nmap I try it as well. If the server is up like the interface shows, I should be able to communicate. Maybe I just create another instance and start off with it as static? I don’t recall it being that complicated. I only have test data anyway.

Too much time on this. I am now looking at CouchDB - JSON based Web database powered by TurnKey GNU/Linux (HVM) at AWS.

Actually bitnami is also on aws, I tried it before without success. I will try again. If you can solve the Google Cloud issue, great.

I created a Bitnami instance at AWS and so far I have connected with Putty and from my Cloudways server. I just have to find out where to specify a static IP and now modify the couchdb to allow access from the Fauxton interface.

Hi @jhchadwick63,

I just tried accessing the instance using the nc command line tool and it returned a timed out error

$ nc -zv -w2 104.154.38.45 22
45.38.154.104.bc.googleusercontent.com [104.154.38.45] 22 (ssh) : Connection timed out

If the SSH service is not working or the SSH port is not open in the firewall, you can obtain this error message. Can you check if the SSH port (22) is opened in the firewall?

https://docs.bitnami.com/google/faq/administration/use-firewall/

If the port is opened, can you try restarting the instance so it restarts the SSH service?

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.