Process Maker Installation Error!

Hi Guys

Hope you are doing well.

Actually it’s the first time Here, We install the latest Process Maker software version

on Windows Server 2008 R2 and we receive error message related to SQL as per attached print screen, so kindly advice to fix this issue.

Waiting for your reply
Best Regards

Hello @mbd149

I was unable to reproduce the issue on a Window Server 2016: the installation finishes and ProcessMaker worked as expected.

Let’s take a look to the Installation Log so we can debug the reason for this issue. You can find it under the Temporary Directory. More information about the temporary directory at:

https://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/where-is-the-temporary-folder/44a039a5-45ba-48dd-84db-fd700e54fd56?auth=1

The file would have a name very similar to bitrock_installer.log. Once you obtained it please upload to any Cloud Storage site and share with us the link or you can also send it to me to juan@bitnami.com.

Best Regards,

Juan Ariza

1 Like

Dear Mr. Juan

I would like to thank you first for your fast response to fix the installation error issue; I attach the bitrock log file as per your request as below:

Note: OS: Windows Server 2008 R2 64bit
Software version: processmaker-3.2.1-0

Waiting for your reply

Best Regards

bitrock_installer_928

Hello @mbd149

I can see in your Installation Log file the error below:

Unknown error while running C:/Bitnami\PROCES~1.1-0\mysql\bin\mysqld.exe "--defaults-file=C:\Bitnami\processmaker-3.2.1-0\mysql\my.ini" &
Error running C:\Bitnami\processmaker-3.2.1-0\mysql\scripts\myscript.bat ****: The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail.

Could you please share with us the Configuration file and the MySQL log file? I wonder if the configuration is wrong for some reason or the log file gives us more info about the issue. You can those files at:

C:\Bitnami\processmaker-3.2.1-0\mysql\my.ini
C:\Bitnami\processmaker-3.2.1-0\mysql\data\mysqld.log

Best Regards,

Juan Ariza

https://1drv.ms/f/s!As7VT7PacJce1GNahQwnJMwXj8WI

I am waiting for your reply Mr. Juan Ariza

Hello @mbd149,

The MySQL configuration file seems to be fine. I would like to know the output of the following command:

C:\Bitnami\PROCES~1.1-0\mysql\bin\mysqld.exe "--defaults-file=C:\Bitnami\processmaker-3.2.1-0\mysql\my.ini"

Please run the command above in the Windows Command Prompt.

Also, it seems the C:/Bitnami/processmaker-3.2.1-0/mysql/data/mysqld.log log file is missing in the folder you uploaded. Could you upload it too?

That file could reveal important information about the first database startup.

https://1drv.ms/f/s!As7VT7PacJce1GQLWb3tKxNEi9iM

Hi @mbd149.

I cannot find the mysqld.log file in the folder you shared. Could you double check it is properly uploaded?

Hi jdrios,

I also has same issue when I was installed application in my Win server 2008 R2.

But unfortunately, in my server haven’t mysqld.log under path C:\Bitnami\processmaker-3.2.1-0\mysql\data after

Please let me know if necessary additional information required.

Hi @mantimothy,

We tried to reproduce the issue but we couldn’t do it. We launched a fresh Windows Server 2008 R2 instance and installed the latest version of ProcessMaker in that machine. The installation process finished fine and we could access the site properly.

Could you please let us know the specifications of your Windows Server? It will be also useful if you share with us the content of the installer log that you will find at the %TEMP% directory of that machine. Please note that it’s a temporary directory and it’s removed every time you stop or restart the machine.

Regards,
Jota

Hello,

mysqld couldn’t start because its side-by-side configuration is incorrect. This sounds to me that there are one or more missing redistributables you should install.

When installing MySQL (for another application) I had to install MS Visual C++ Redistributables for both x86 and x64.
Maybe this can solve your problem.

Kind regards

Hi Sperling,

I agree with you, my final workaround is separate install MySQL in my machine and under installation, it has notification server machine required to install your mentioned application.

After all modules completely installed, MySQL and ProcessMaker was running fine without issue.

Cheer!!

Hi Jota,

The point of this issue, may due to my machine doesn’t has some prerequisite module for MySQL. I got notice when I separate install MySQL.

And it was work fine on my machine with ProcessMaker right now.

Thanks you :slight_smile:

Hi @mantimothy,

Please note that we install the different services along with the dependencies that those services need when installing the application, for example, we install the Visual C++ Redistributable libraries for the services that require them. Could you please let us know which package did you install to solve the installation issue?

Regards,
Jota

Hi jota,

As I mention the installation method I was standalone to install MySQL instead of using ProcessMaker installer.

But under my standard MySQL installation, I need to download & install following:
image

Hope this information can help you.

Best Regard and Thanks!!