Problems with 3.0.1 installation (see report inside)

We have tried migrating from 2.4.1-0 to 3.0.0-0

We are running Redmine instance at Server2008R2

1 Wiki page with specific word at page name causes “Internal server error”

bugreport: http://www.redmine.org/issues/19321 - on redmine.org Im able to create such wiki page, so most likely installer is broken.
Confirmed for 3.0.0 and 3.0.1 versions resolved see solution below. change required for static.rb file.

2 Incorrect hyperlink to task generated at email, if host setup uses other port (":" symbol)

bugreport: http://www.redmine.org/issues/19323 - havent tested on other PC so far, dont have SMTP installed there, could be a Update: tested on other PC, problem exists. Redmine itself problem.
Confirmed for 3.0.0 fixed at 3.0.1 version
Its a Redmine problem, probably will be fixed at 3.0.1 version. A possible workaround for the moment - do not use other port except 80. So this will require no port setup within settings and everything will be OK.

Hi @EugeneB,

About the first issue, I have installed it and created a project with a wiki, with a page with that text (in Windows Server 2012 R2 and Linux), and I have not been able to reproduce it.
Could you check if you find something strange in your Apache error log? It will be located at:

C:\Redmine\3.0.0\apache2\logs

You can also take a look at Thin’s error logs, which will be located at:

C:\Redmine\3.0.0\apps\redmine\htdocs\logs

The second issue is a Redmine bug so it will probably be fixed in the next release.

Best regards.

Please find link to my log files: https://cloud.mail.ru/public/7261d0e62c8e/logs.zip
I have cleaned them before redmine restart, so its not much to see there. I see nothing special there. Probably I need to set more thorough log mode? If possible, please tell me how to do it.

Also please find link to youtube with video recording for this problem. http://youtu.be/r3TITwOP_Fk

I have tried to use InternetExplorer too - same result, page is not opening.

Regarding problem with: 1 Wiki page with specific word at page name causes “Internal server error”

Redmine team said its a webserver (apache?) error. At 2.4.1 Bitnami installation there was no such error, so its something with new version. I dont know hot to turn on debug level logs there, if anyone knows please tell me.

Is there a way to debug this error? If there are some problems to reproduce or confirm bug, I can give teamviewer access to affected PC (virtual PC) if its needed. So it will be easier to get required information. Contact me with e-mail at my profile if interested.

Hi @EugeneB,

I was finally able to reproduce your issue. It happened when creating a project and/or Wiki with Информация_по_поездке_в_Китай_(контакты_заметки) as title, and then trying to access it.

This issue is not happening on Redmine 2.6.x, but it is in 3.0.0, so it may be a Redmine error (we didn’t change the Thin server configurations), however, we will try and take a deeper look at this error (which is not getting reported on the error logs, just in the access log).

Let us know if you have any update. We’ll get back to you soon.

Thanks for confirming. On http://demo.redmine.org/projects/test19321/wiki/Wiki
the affected word is working on 3.0.0 version, so its possible that Redmine 3.0.0 is not affected by the bug. I hope there is a way to debug this error for Thin or Apache service, because its strange that there is no recordings at all at the log file. If I can help some way, just let me know. We are using Redmine for long time, currently we have switched back to 2.4.1 from 3.0.0. because of this 2 bugs. Incorrect hyperlink is already fixed by Redmine Team, i hope to find solution for 2nd problem too, and after that we can try to move to 3.0.1 again.

1 Wiki page with specific word at page name causes “Internal server error”

same issue for 3.0.1 too.
Looking for help how to resolve it.

Some good news, I have found how to turn on debug mode for Apache, and now it writes error to logs!

Please below find 22:02:48 time, at error.log and access.log

https://cloud.mail.ru/public/5fb423d7bb7e/updatedlogs.zip

Any ideas what to do?

Rised thread on Apache bugtracker, maybe they will say something:
https://bz.apache.org/bugzilla/show_bug.cgi?id=57726

Still no response here or on Apache tracker, any ideas what to do?

Hi @EugeneB,

Sorry for the late response, another user has reported us a very similar issue, could you please check it?

Do you have any other page that doesn’t have that type of characters? Does that page work fine?

Jota

I have tested mentioned above wiki page with name “Отвал хоста от vSphere” on my installation. It works normally for me:

http://s8.postimg.org/604mvx1ud/otval_hvosta_test.jpg

More information, any word (or even just any letters) that contains capital “И” letter leads to problem
“История” (history) “Интервал” (interval) “авеИавы” (just random letters with big “И”)

Ill try to install Redmine w/o Bitnami bundle tomorrow. Bundle installer is really a sweet thing for not experienced users, I doubt that most of the other users will be able to deploy and configure correctly 4-5 services such as: ruby thin mysl apache redmine. Actually bitnami installer was the key for me that allowed to start using Redmine, because its regular installation is too hardcore. After reading installation way like this: https://www.redmine.org/boards/1/topics/32693 I would not even try, though I can consider myself as advanced user.

Thanks to Toshi MARUYAMA from Redmine Team, this problem is resolved!

https://github.com/macournoyer/thin/issues/268
https://github.com/marutosi/rails/commit/c53a49e0bbe615d5ff51620a993c4d3d79c73370

I have updated line 32 at my file\apps\redmine\htdocs\vendor\bundle\ruby\2.0.0\gems\actionpack-4.2.0\lib\action_dispatch\middleware\static.rb
from “path = File.join(@root, p)”
to “path = File.join(@root, p.force_encoding(‘UTF-8’))”

And now links with capital “И” opens correctly! Thanks to everyone who take part in resolving this problem.

1 Like

Hi @EugeneB,

Thank you for taking your time to let us know the solution. I think that this will help the users that have the same issue.

Jota

While browsing the forum I have noticed many other people have faced a problem with “Internal server error” and some of them already found that they need to fix static.rb file. I suggest you to update your bundle installer with fixed static.rb file, this will help others to avoid this problem.