Problems updating ResourceSpace to the latest version

Hello,

I’ve used the bitnami one click install on Google Cloud to get ResourceSpace up and running, however it is an out-of date version.

I’m trying to update ResourceSpace following your instructions here:
https://wiki.bitnami.com/Applications/Bitnami_ResourceSpace#How_to_upgrade_ResourceSpace.3f

Whenever I try to unzip the file from the actual location, I get the error message as follows:

/opt/bitnami/apps/resourcespace/htdocs$ sudo unzip /home/bitnami/ResourceSpaceVERSION.zip
Archive: /home/bitnami/ResourceSpaceVERSION.zip
End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.
unzip: cannot find zipfile directory in one of /home/bitnami/ResourceSpaceVERSION.zip or
/home/bitnami/ResourceSpaceVERSION.zip.zip, and cannot find /home/bitnami/ResourceSpaceVERSION.zip.ZIP, period.

I definitely have the .zip file in the /home/bitnami directory

:/home/bitnami$ dir
apps htdocs ResourceSpaceVERSION.zip stack

I have tried deleting the zip archive and downloading again, but still get the same problem.

Adding to my question, is there a way to have my Bitnami installed ResourceSpace install update automatically via subversion as documented on the ResourceSpace wiki here:
http://wiki.resourcespace.org/index.php/Upgrading

Hi @michael_howarth,

The word VERSION in the instructions you followed is meant to be replaced with the version number of ResourceSpace you wish to download. For example, the download link could be: http://www.resourcespace.org/downloads/ResourceSpace_6_1_5219.zip.

I hope it helps.

Best regards,
Alvaro

1 Like

Thank you @arecio so obvious… I couldn’t see the wood for the trees. :smile:
All done now.

Hi @michael_howarth,

I’m glad to hear that you managed to solve your problem. Please note that we also updated the stack of ResourceSpace to its latest version some days ago.

https://bitnami.com/stack/resourcespace/changelog.txt

Don’t hesitate to write us back if you have any more questions.

Regards,
Jota