Problems migrating wordpress site to a new updated instance

Keywords: WordPress - Linux - Technical issue - Upgrade
Description:
Hi,

I’m trying to update the server to the new Bitnami Wordpress AMI in AWS. I’ve launched an instance with the new AMI, but I’m having troubles migrating the site with All-in-One plugins as indicated in the documentation.

My site weight is about 1 GB, so Ai1 doesn’t allow the import the file showing this message:

Your file exceeds the maximum upload size for this site: 80 MB
How-to: Increase maximum upload file size or Get unlimited

As per indicated in the message I have two options: 1- Upgrade to paid version. 2- Increase the maximum upload file size modifying configuration files.

Have you been through this already? What would be your recomendation. If I can avoid the paid version at this moment would be better. So I’d apreciate is you have some instructions to go for the 2nd option.

Thanks in advance,
Pablo.-

Hi @pcorrenti,

Thanks for using Bitnami. We solved a similar case recently about increasing the WordPress max upload size. Can you check the thread below?

Apart from that, we recommend you to ask for help in the official WordPress forums, where other users with more knowledge can help you on migrating a big site like yours in a different way in case it is possible

https://wordpress.org/support/forums/

1 Like

Hi @gongomgra,

Thank you very much for your help. I’ve followed the instructions indicated by @itjunior in his thread and worked perfectly. Thanks to both.

Best regards,
Pablo.-

Hi @gongomgra,

I’ve just launched a new wordpress image, and I can’t find neither the the directory nor the configuration file below anymore.

/opt/bitnami/apps/wordpress/conf/php-fpm/php-settings.conf

Actually there isn’t any apps directory in /opt/bitnami…

Has anything changed? Where should I change the php configuration now to increase the upload size.

Hi @pcorrenti,

We are updating the technology behind our solutions and WordPress was updated recently. The WordPress files are now inside the /opt/bitnami/wordpress directory and you can take a look at these guides to know more about how to edit the PHP-FPM configuration

https://docs.bitnami.com/google/apps/wordpress/administration/increase-upload-limit-php/
https://docs.bitnami.com/google/apps/wordpress/configuration/configure-phpfpm-options/
https://docs.bitnami.com/google/apps/wordpress-multisite/configuration/configure-phpfpm-processes/

Happy to help!


Was my answer helpful? Click on :heart:

1 Like

Hi @pcorrenti,

In the new AMI you launched, the Bitnami installation is slightly different than in previous versions. We are in the process of releasing our assets using this new configuration, and WordPress was one of our recent updates. You can read more information on this in the next link

https://docs.bitnami.com/aws/faq/get-started/understand-upcoming-changes/

For the PHP settings, you should be able to update them following the steps in the guide below

https://docs.bitnami.com/aws/apps/wordpress/administration/increase-upload-limit-php/

1 Like

I’ve Got it! Thanks for the information.
Regards,
Pablo.-

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.