Problem with some links in wiki

Hello!

After updating Bitnami from 2.6.0-1 to 3.0.1-0 all looks fine but some links in Wiki stops working. I check in database, looks like articles exists and it is ok, but when i try to open it i get:

https://yadi.sk/i/pg9i4fXPfTNrs

Only some articles don`t open, other is ok.

In Apache log i found this:

213.14.152.159 - - [23/Mar/2015:15:11:11 +0200] “GET /projects/redmine00012/wiki/%D0%A2%D0%B5%D1%85%D0%BD%D0%BE%D0%BB%D0%BE%D0%B3%D0%B8%D1%8F_%D0%BF%D0%BE_%D0%B8%D1%81%D0%BF%D0%BE%D0%BB%D1%8C%D0%B7%D0%BE%D0%B2%D0%B0%D0%BD%D0%B8%D1%8E_%D0%A0%D0%B5%D0%B4%D0%BC%D0%B0%D0%B9%D0%BD%D0%B0 HTTP/1.1” 404 294

Looks like it can`t find correct address for a link?

It you have any ideas what it can be, let me know.
Thank you!

Hi @alterspirt,

Did you follow our wiki about how to upgrade Redmine?

https://wiki.bitnami.com/Applications/BitNami_Redmine#How_to_upgrade_Redmine.3f

Are all the pages with those type of characters failing?

Jota

Hello!

Yes, i follow your wiki, the most interesting thing that only some pages not opens, all other is ok. I decide to remove Cyrillic symbols from links, i update them in MySql, after, fix link in redmine wiki page to this:

[[link example| Cyrillic explanation]]

After this step page opens normal. If you have any ideas how to figure out the reason, why some pages broken - let me know.

Thank you.

btw, I have tested mentioned above wiki page with name “Отвал хоста от vSphere” on my installation. It works normally for me:

http://s8.postimg.org/604mvx1ud/otval_hvosta_test.jpg

My issue: Problems with 3.0.1 installation (see report inside)

Please try to create any wiki page with capital “И” letter at the page name. Is it working for you? I get “Internal server error” try this one: myredmine:7788/projects/it00024/wiki/История1

Hi @alterspirt,

Can you check this post?

@EugeneB posted a solution to this problem.

I hope this helps!

Jota

I confirm, after creating link with capital ‘И’ I`m also getting this error:

https://yadi.sk/i/C0X4uVg2fZSZW

So, as i understand, we have some problem with Cyrillic letters?

I try to edit this file: \apps\redmine\htdocs\vendor\bundle\ruby\2.0.0\gems\actionpack-4.2.0\lib\action_dispatch\middleware\static.rb

32 line update from path = File.join(@root, p) to path = File.join(@root, p.force_encoding(‘UTF-8’))

Restart everything several times, but still getting same error.

I was able to create your page “Отвал хоста от vSphere” even before static.rb file fix, so it seems problem is different. However you can check, can you use “И” letter at the wiki pages after line 32 change? If you can, then my suggestion probably helps only in this case.

Unfortunately - no, i edit file and still can`t open ‘История1’ wiki link.