Problem when starting bitnami Wordpress application

Hi, when I download and paste it in the content package, and then open the terminal and I write the command sudo /opt/bitnami/bnsupport-tool, I have this response:

Last login: Mon Jun 29 08:21:24 on console
mac@MacBook-Pro-de-mac ~ % sudo /opt/bitnami/bnsupport-tool
Password:
sudo: /opt/bitnami/bnsupport-tool: command not found
mac@MacBook-Pro-de-mac ~ %

Thank you.

Hi @nezzal.abdelmalek,

You need to run the command on the Bitnami WordPress VM terminal. So on the Bitnami window manager click “Open Terminal” and then a terminal window should open.

Regards,
Michiel

Hi
I realize that I don’t know where I can find the “Bitnami WordPress VM terminal.” I have only a stack of moodle or Wordpress and when I display it I find a folder “Content” … :slight_smile:
Regards
Abdelmalek

Hi @nezzal.abdelmalek,

Can you run the following command and tell me the output:

ls -la /Applications/Wordpress*

Regards,
Michiel

Hi Michel before your post I’ve deleted wordpress to try download it again, but for Moodle I’ve this information:
Last login: Mon Jun 29 09:06:20 on ttys000
mac@MacBook-Pro-de-mac ~ % ls -la /Applications/Moodle*
total 0
drwxrwxrwx@ 3 mac admin 96 16 jui 20:16 .
drwxrwxr-x+ 67 root admin 2144 24 jui 12:09 …
drwxrwxrwx@ 9 mac admin 288 29 jui 09:06 Contents
mac@MacBook-Pro-de-mac ~ % ls -la /Applications/Wordpress*
zsh: no matches found: /Applications/Wordpress*
mac@MacBook-Pro-de-mac ~ %
Best regards

Hi @michiel

I’m facing a similar problem. The Bitnami WordPress VM Terminal button is deactivated.

Using iTerm to get to the WordPress Volume and using the commands: cd /Volumes/WordPress and then ls -la, I got the following outcome:

total 44
lr-xr-xr-x 1 anylytical staff 13 Jun 15 12:50 -> /Applications
drwxrwxrwx 4 anylytical staff 2048 Jun 15 12:50 .
drwxr-xr-x 7 root wheel 224 Jun 29 23:11 …
-rwxrwxrwx 1 anylytical staff 15364 Jun 15 12:50 .DS_Store
drwxrwxrwx 2 anylytical staff 2048 Jun 15 12:50 .background
drwxrwxrwx 3 anylytical staff 2048 Jun 15 12:50 WordPress.app

Regards,
Confidence

Hi @mukwindidzacp,

You need to mount the volume first:

  • On the General tab click “Start”
  • On the Volumes tab cick “Mount”
  • On The General tab click “Open terminal”

Regards,
Michiel

Hi @nezzal.abdelmalek,

The issue you were reporting was for the WordPress application. Are you experiencing the same issue with the Moodle application? Could you reinstall the WordPress application and send me a screenshot of the error you are getting?

Regards,
Michiel

Hi Michiel
This is the link of Wordpress installation after download: Link

And tis is the message of failing:
"failed to start machine: hyperkit: [INFO] Resized file to 24567 clusters (3144576 sectors)
hyperkit: [INFO] image has 0 free sectors and 24564 used sectors
hyperkit: [INFO] Resized file to 8 clusters (1024 sectors)
hyperkit: [INFO] image has 0 free sectors and 4 used sectors
vm exit[0]
reason VMX
rip 0x000000000009e019
inst_length 3
status 0
exit_reason 33
qualification 0x0000000000000000
inst_type 0
inst_error 0
"
Regards

Hi @nezzal.abdelmalek,

I’ve requested your permission to view the file. In any case. does the shared file contain a screenshot? If not, could you paste a screenshot here?

Regards,
Michiel

Hi Michiel
Yes the link to google drive contains screenshots, I didn’t know that I can paste it here :smile:
Regards

Hi @nezzal.abdelmalek,

Sorry, I’ve been reviewing the information here and the error you are getting is from the OS X VM itself, not from the app.

https://docs.bitnami.com/installer/get-started-osx-vm

In this case, we will need all the information under the ~/.bitnami folder of your computer in order to debug the issue and help you recover all the data from the VM.

Could you please let us know the current size of that folder

du -sh ~/.bitnami

and if there is any other VM there?

ls -la ~/.bitnami/stackman/machines

In order to give you access to a platform to upload the information, can we use the same email address you have configured in this forum?

Thank you

Hi,
Thank you for your post this is below the information needed:


Regards

Hi,
of course you. can use my mail.
Regards

Hi @nezzal.abdelmalek,

Thank you for sharing the information. Instead of giving you access to our systems to upload the machine, we will let you know how to fix the VM in your own machine so you don’t need to upload/download the VM. Please follow these steps to fix the qcow file

  • Close the Bitnami OS X VM solution
  • Install QEMU in your Mac OS X machine

https://www.qemu.org/download/#macos

  • Move to the machines folder
cd ~/.bitnami/stackman/machines
  • Create a copy of your application folder (in your case WordPress)
cp -RP wordpress wordpress.back
  • Once you finished copying the image, run the QEMU tool to check the qcow file. It should return a list of errors
qemu-img check ./wordpress/vm/machine.qcow2
  • Fix the errors in the qcow with this command
qemu-img check -r all ./wordpress/vm/machine.qcow2
  • Open the Bitnami Mac OS X VM again and start the application. It should start without problems.

  • If everything goes well, remove the folder you copied before

cd ~/.bitnami/stackman/machines
rm -rf wordpress.back

Happy to help!


Was my answer helpful? Click on :heart:

Hi,
I’ve done all the steps and this is the result:
Report install QEMU in your Mac OS X machine.rtf.zip (206.7 KB)

Regards

Hi @nezzal.abdelmalek,

Can you try to resize the disk of the VM?

https://docs.bitnami.com/installer/faq/osx-vm-faq/administration/resize-disk-osx-vm/

The guide uses owncloud as an example, you will need to run these commands

qemu-img info $HOME/.bitnami/stackman/machines/wordpress/vm/machine.qcow2

Remember to stop the VM now

qemu-img resize $HOME/.bitnami/stackman/machines/wordpress/vm/machine.qcow2 100G
qemu-img info $HOME/.bitnami/stackman/machines/wordpress/vm/machine.qcow2

Hi ,
I’ve resized the disk :

Then started the vm and I’ve this message:
failed to start machine: hyperkit: [INFO] Resized file to 24569 clusters (3144832 sectors)
hyperkit: [INFO] image has 0 free sectors and 24564 used sectors
hyperkit: [INFO] Resized file to 8 clusters (1024 sectors)
hyperkit: [INFO] image has 0 free sectors and 4 used sectors
vm exit[0]
reason VMX
rip 0x000000000009e019
inst_length 3
status 0
exit_reason 33
qualification 0x0000000000000000
inst_type 0
inst_error 0

I’ve the same problem with moodle.

I’ve another VM for moodle 3.9 MAMP: it works with moodle but some problem on the dashboard.
Regards

Hi @nezzal.abdelmalek,

I’m sorry to hear that. I just sent you a private message with the instructions to share the OS X VM information.

Please ping us here once you upload the files to our system.

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.