Problem Starting the Bitnami Stack

Keywords: Moodle - Google Cloud Platform - Technical issue - Other
bnsupport ID: 98a6325a-3582-4969-790e-0d3d79fe43c4
Description:
Support Tool Code 98a6325a-3582-4969-790e-0d3d79fe43c4

Problem:
Followed the guide “Enable HTTPS Support With Apache”. Tried to restart apache service. But will not start. Ends with an error.

My Workaround
Tried to run the service again using sudo /opt/bitnami/ctlscript.sh restart apache. Same result, ends with an error. Tried to restart all services. Same result, ends with an error. Last resort, rebooted the system (using sudo reboot). Bitnami stack wont start.

Hi, @henry.haranay.

There’s this error in your Apache log:

[Wed Oct 14 02:49:50.520058 2020] [ssl:emerg] [pid 1470:tid 140308775385984] AH02565: Certificate and private key www.example.com:443:0 from /opt/bitnami/apache/conf/bitnami/certs/server.crt and /opt/bitnami/apache/conf/bitnami/certs/server.key do not match

As it states, your certificate and the private key used to sign the certificate don’t match. You can double check it as shown in this guide: https://docs.bitnami.com/general/apps/moodle/administration/check-ssl-certificate/

If your certificate and key don’t match, you will need to generate a new certificate and configure it, or find the private key that was used to sign your original certificate and configure it in Apache.

Regards,
Alejandro

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.