Prestashop breaks when changing cache settings

Keywords: PrestaShop - Google Cloud Platform - Technical issue - Other
bnsupport ID: 3e144cce-d7cd-065e-5f11-bff616cf6a6b
Description:
I need to change the cache setting to no and Force recompile the templates, but when i change the Force recompile, prestashop stop working and i cannot acces either the front or back office.
If i reset the services, i can access for a short time to the backoffice, but when i click on any link, prestashop stop responding.

The support file code is : 3e144cce-d7cd-065e-5f11-bff616cf6a6b

Hi @i.amorrortu,

Could you try to add /opt/bitnami/apache2/conf/httpd.conf the next lines?

Timeout 600
ProxyTimeout 600

I hope that helps.

No luck with that
Now on the frontoffice i get a too many redirections errors, but i can see the login page on the backoffice, but when i try to log in it get stuck.

Thanks for the reply!

Hi @i.amorrortu

do you restart Apache?

sudo /opt/bitnami/ctlscript.sh  restart apache

Check this link, maybe helps you https://support.plesk.com/hc/en-us/articles/115000064929-Website-on-Plesk-server-is-not-accessible-504-Gateway-Time-out-The-timeout-specified-has-expired-client-203-0-113-2-54693-AH01075-Error-dispatching-request-to

Yeah, i have restarted the full stack.
It’s weird error, it only appears when i change cache settings.

I have checked the link, but it does not apply to my case, i am not having a 504, it seems like its working, but is unresponsive.
Maybe is a bug? I has some previous problems with prestashop and friendly url before, but after a update of the deployment it comes with it enabled and working perfectly.

Hi @i.amorrortu,

In you logs appears an error about cache:

[Wed May 27 12:13:53.385453 2020] [proxy_fcgi:error] [pid 3968:tid 140216320915200] [client 35.240.65.174:48284] AH01071: Got error 'PHP message: PHP Notice:  Undefined index: hookName in /opt/bitnami/apps/prestashop/htdocs/var/cache/prod/smarty/compile/30/7d/c6/307dc6bd4724d29d1572cc301dd7148e962604ef_2.module.psemailsubscriptionviewst.php on line 26\nPHP message: PHP Notice:  Trying to get property 'value' of non-object in /opt/bitnami/apps/prestashop/htdocs/var/cache/prod/smarty/compile/30/7d/c6/307dc6bd4724d29d1572cc301dd7148e962604ef_2.module.psemailsubscriptionviewst.php on line 26\nPHP message: PHP Notice:  Undefined index: hookName in /opt/bitnami/apps/prestashop/htdocs/var/cache/prod/smarty/compile/30/7d/c6/307dc6bd4724d29d1572cc301dd7148e962604ef_2.module.psemailsubscriptionviewst.php on line 33\nPHP message: PHP Notice:  Trying to get property 'value' of non-object in /opt/bitnami/apps/prestashop/htdocs/var/cache/prod/smarty/compile/30/7d/c6/307dc6bd4724d29d1572cc301dd7148e962604ef_2.module.psemailsubscriptionviewst.php on line 33\nPHP message: PHP Notice:  Undefined index: hookName in /opt/bitnami/apps/prestashop/htdocs/var/cache/prod/smarty/compile/30/7d/c6/307dc6bd4724d29d1572cc301dd7148e962604ef_2.module.psemailsubscriptionviewst.php on line 37\nPHP message: PHP Notice:  Trying to get property 'value' of non-object in /opt/bitnami/apps/prestashop/htdocs/var/cache/prod/smarty/compile/30/7d/c6/307dc6bd4724d29d1572cc301dd7148e962604ef_2.module.psemailsubscriptionviewst.php on line 37\n'

Could you please check this file?

i have checked the file but looks good to me. Want me to put here the content?
Its weird because it happens when i activate the option to recompile template, in a fresh install too

Hi @i.amorrortu

Have you tried to reinstall the plugin?

Bets regards,
Ibone

There is no plugin installed, this happens on a fresh prestashop install

Hi @i.amorrortu,

could you tell us what are the steps are you follow after the installation?
I’m not able to reproduce your issue.

sorry for the inconvenience, after some investigation, we reached that the issue is with out theme, not with prestashop.
Is an incompatibility of the theme with email subscription module.

Thanks for the help!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.