Prestashop backoffice untimely disconnection

Keywords: PrestaShop - Google Cloud Platform - Technical issue - Other
bnsupport ID: 521cbe50-9c8e-dd84-8a9c-44cd1f73174e
Description:
Dear,

We can work each time we want save something we are disconnected from the backoffice, I try to delete cache, it is same,

how can solve ?
regards

Hi,

Thank you for using Bitnami. Could you specify a set of steps to reproduce the issue? Did you change anything in the configuration?

Best regards,

Javier J. Salmerón


Was my answer helpful? Click on :heart:

Just I fallow the wiki

Hi @nicoR,

What wiki? Could you please provide the exact steps you followed (or a link with the steps) so we can take a look at them?

Thanks

HI,

I just launched a fresh new Prestashop instance:

  1. change language in French with use the wiki:
    sudo chown -R daemon:daemon /opt/bitnami/apps/prestashop/htdocs/
    Change in french fallow https://docs.bitnami.com/aws/apps/prestashop/configuration/change-language/
    sudo chown -R bitnami:daemon /opt/bitnami/apps/prestashop/htdocs/
    sudo chown -R daemon:daemon /opt/bitnami/apps/prestashop/htdocs//var/cache
    After that front and backoffice work

  2. Change URL: https://docs.bitnami.com/aws/faq/configuration/configure-custom-domain/
    cd /opt/bitnami/apps/prestashop
    sudo ./bnconfig --machine_hostname my-shop.com (my-shop.com was change with my correct domain name and redirect to correct IP), back office work

After that impossible to use backoffice always disconnected

regards

Hi @nicoR,

Did you make any other change in the application before changing the language? I just followed the same steps to change the shop language to Spanish and everything went fine. As you can see here, I can access the site

and the dashboard

using the domain I configured with the bnconfig command. Can you try to use the Spanish language as an example? I don’t know if there is something wrong with the French language.

Note: I didn’t add any custom translation, did you?

From your bnsupport, I found this error

[Thu Jun 11 10:21:44.071800 2020] [core:error] [pid 8628:tid 139852439738112] (13)Permission denied: [client 108.162.229.243:39824] AH00035: access to /administration/index.php denied (filesystem path '/opt/bitnami/apps/prestashop/htdocs/administration') because search permissions are missing on a component of the path, referer: https://store.marcareeds.com/administration/index.php?controller=AdminDashboard&token=4eb35922cba2df29523d13c560883928                                                           
[Thu Jun 11 10:21:48.149594 2020] [core:error] [pid 8628:tid 139852397774592] (13)Permission denied: [client 108.162.229.243:48362] AH00035: access to /administration/ denied (filesystem path '/opt/bitnami/apps/prestashop/htdocs/administration') because search permissions are missing on a component of the path

and when I review the permissions configuration, the htdocs folder has a different permissions configuration than the one I had after following the guide. Did you change the permissions by your own? Can you try to launch a fresh instance and start the process from scratch?

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.