Port 80 in use by "Unable to open process" with PID 4!

Apache will not start because Port 80 is in use.

Could you please provide us a little more information?

  • What application and which exact version are you using?
  • Are you using this application in a Cloud Provider (AWS, Google, Azure, …), in the native installer (Windows, Linux, OS X) or in a VM?
  • Have you installed any plugin or modified any configuration file?
  • Which steps did you take in order to reproduce the error?

Best regards,
Carlos R. Hernández

Windows Version: Pro 64-bit
6:20:20 AM [main] XAMPP Version: 5.6.30
6:20:20 AM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]

I downloaded XAMPP to my Windows 10, and opened Control Panel v3.2.2. I get the above error message when trying to start Apache.

MySQL does start, but when I try to load Joomla using bitnami-joomla-3.7.1-0-module-windows-installer, I get as far as Configure SMTP settings in the Setup. It asks for SMTP Host.

I got the SMTP Host, and installed Joomla, but I am not able to open Joomla.

My Microsoft Edge Browser is trying to open (?).

Hello @danlee58

There must be another process that is using the port 80 so Apache is unable to start. You can find several alternatives to do that in the link below:

Once you identify what program/process is using that port, you can stop it if you’re not using it and try to start Apache again.

After you start Apache, you should be able to access your Joomla! server using that IP.

I hope this information is useful for you. If you have any other questions, please do not hesitate to let us know.

Best Regards,

Juan Ariza

How do I get to C:. My Command Prompt comes up with C:\users\Home7?

This is the Port Dump from C:\Users\Home7> netstat -a -o

Hi @danlee58,

There is a process running in the 80 port of your machine so you will need to stop it before starting the XAMPP’s Apache server if you want it to run in the 80 port. You can also check current used ports clicking on “Netstat” in the Control Panel of XAMPP.


Do you have any other Bitnami stack installed in your system or do you have IIS (Internet Information Services) enabled?



Netstat says that the System is using Port 80.
Task Manager says that NT Kernel & System is using PID 4…

I don’t have any other Bitnami stack installed, nor can I find any reference to IIS.

Hi @danlee58,

could you please check this post in order to know which service is using the 80 port?


I hope it helps,

When I use C:\User\Home7>tasklist /svc /FI “PID 4”

I get:

Image Name PID Services
System 4 N/A

Hi @danlee58,

Could you please check these cases?


You also have this section in the documentation to stop the IIS service in Windows

“How can I get XAMPP working on port 80 under Windows 10?”


In case you can’t stop that service, you can modify the Apache port to use a different one by modifying this files:


Listen 80 to Listen 8080

Apache will start using the 8080 port now and you can access it by using localhost:8080.

For questions related to XAMPP, we highly recommend you visit the Apache Friends Support Forum (https://community.apachefriends.org/f/).


I ran “net stop W3SVC” from an Administrative Command Prompt, and now Apache starts.

Hello @danlee58

That’s great! So, could you please confirm us that you were able to solved the issue? Could we consider this thread as solved?

Best Regards,

Juan Ariza

I have some other Joomla problems, but this one is solved. Thanks for the help.

This post was flagged by the community and is temporarily hidden.