Pods Moodle cannot connect to mariadb server on kubernetes

Type: Suggestion

Description:
I’ve tried deploying using a helm and using a chart from Bitnami. but the error keeps on not being able to connect to the database. I’ve tried to find a solution but still can’t, I remotely remote mariadb statefullsets from Moodle pods and can connect. but on the Moodle app it doesn’t connect, may anyone have a solution?

moodle 12:53:29.56
moodle 12:53:29.56 Welcome to the Bitnami moodle container
moodle 12:53:29.57 Subscribe to project updates by watching GitHub - bitnami/bitnami-docker-moodle: Bitnami Docker Image for Moodle
moodle 12:53:29.57 Submit issues and feature requests at Issues · bitnami/bitnami-docker-moodle · GitHub
moodle 12:53:29.57
moodle 12:53:29.57 INFO ==> ** Starting Moodle setup **
realpath: /bitnami/apache/conf: No such file or directory
moodle 12:53:29.62 INFO ==> Configuring the HTTP port
moodle 12:53:29.65 INFO ==> Configuring the HTTPS port
moodle 12:53:29.65 INFO ==> Configuring Apache ServerTokens directive
moodle 12:53:29.69 INFO ==> Configuring PHP options
moodle 12:53:29.70 INFO ==> Setting PHP expose_php option
moodle 12:53:29.74 INFO ==> Validating settings in MYSQL_CLIENT_* env vars
moodle 12:53:29.76 INFO ==> Validating settings in POSTGRESQL_CLIENT_* env vars
moodle 12:53:29.96 INFO ==> Ensuring Moodle directories exist
moodle 12:53:29.97 INFO ==> Trying to connect to the database server
moodle 12:58:30.40 ERROR ==> Could not connect to the database

Hi @taufikdiki11,

We handle all issues related to Bitnami charts on Github. Could you ask your question there?

https://github.com/bitnami/charts/issues

Regards,
Michiel

Facing the same problem. Cannot connect to database from the pod. I can access db from all other application. Only moodle cannot connect. I’m using bitnami/moodle image for building. can you help here please @michiel ?

Hi @pravin.banjade,

We handle all issues related to Bitnami charts on Github. Could you ask your question there?

https://github.com/bitnami/charts/issues

Regards,
Michiel