PHP.ini extension=imagick.so

Keywords: LAMP/MAMP/WAMP - Windows - Technical issue - Other
Description:
Hello,

I installed WordPress locally, on WAMP Stack 7.4.16
And it asks me for the imagick module.

I went to the file php.ini installdir/php/php.ini and it is not there.

In the php.ini file I can’t find the line “extension = imagick.so”.

Thanks,
Greetings.

Hi @AndresLG,

You will need to download the dll files from the official site

https://mlocati.github.io/articles/php-windows-imagick.html

Download the thread safe version of the dll package for your PHP version. You will need to include it inside the ext folder and then enable it in the php.ini file.

Happy to help!


Was my answer helpful? Click on :heart:

Hello,

I entered the official site to download the files.
I applied the filters to know which one is for me to download.

But it presents me with a different approach than what you tell me.
I have to download two zip files:

  • php_imagick-3.4.4-7.4-ts-vc15-x64.zip
  • ImageMagick-7.0.7-11-vc15-x64.zip

The first, OK, I copy the file “php_imagick.dll” to the php/ext folder.

But then it asks me from “ImageMagick … zip” to copy all the DLL files from the “bin” folder that start with “CORE_RL” or “IM_MOD_RL”, and save them to the root directory of PHP.

The latter generates confusion for me, if I have to do it or not?

And do I copy only the ones that start with CORE_RL or the IM_MOD_RL as well?

Thanks.
Greetings.

Hi @AndresLG,

You do not need to download the ImageMagick files, we are already including them in the installation. You simply need to download the PHP dll file, copy it to the php/ext folder and enable the dll in the php.ini file.

Happy to help!


Was my answer helpful? Click on :heart:

Hello,

WordPress in Site Health, I keep getting:
“The module, imagick, is not installed, or has been disabled.”

The integration in the php.ini, I tried it both ways and it still doesn’t work:

In the Bitnami manual:
https://docs.bitnami.com/installer/infrastructure/wamp/configuration/install-modules-php/#imagick
He says:
extension = imagick.so

But in:
https://mlocati.github.io/articles/php-windows-imagick.html
He says:
extension = php_imagick.dll

Tried it both ways and it still doesn’t work.

Thanks.
Greetings.

Hi @AndresLG,

The so extensions are for UNIX systems, you are using a Windows machine so you need to use extension = imagick.dll. In order to confirm that the dll was loaded properly, can you run this command in the command prompt and look for the imagick extension in the list you will get?

php -m

You will first need to load the Bitnami environment

https://docs.bitnami.com/installer/how-to/understand-bnconsole/

Hello,

I integrated in php.ini the line: extension=imagick.dll

And in the Bitnami Stack Environment console, I ran the command php -m:

C:\Bitnami\wamp-7.4.16>php -m

And output gives me the code:

PHP Warning: PHP Startup: Unable to load dynamic library 'imagick.dll' (tried: C:/Bitnami/wamp-7.4.16/php/ext\imagick.dll (No se puede encontrar el m├│dulo especificado.), C:/Bitnami/wamp-7.4.16/php/ext\php_imagick.dll.dll (No se puede encontrar el m├│dulo especificado.)) in Unknown on line 0

And it still doesn’t work.

Thanks.
Greetings.

Hi @AndresLG,

Sorry for the typo in my previous message. You just need to add the extension’s name, without the dll in the php.ini file

extension = imagick

Does the php -m command work now?

Hello,

I modified it, now I put: extension = imagick

But it still doesn’t work.

In WordPress can’t find the imagick module.
In phpinfo() the imagick module does not come out.

And when I run “php -m” in the console, in the list of modules that it returns, it is not imagick.

It strikes me, the path that returns me:
C:/Bitnami/wamp-7.4.16/php/ext\imagick
“ext”
Attached image:

Thanks.
Greetings.

Hi @AndresLG,

I reproduced the error and got it fixed by following the instructions of the ImageMagick website

Extract from ImageMagick-….zip the DLL files located in the bin folder that start with CORE_RL or IM_MOD_RL, and save them to the PHP root directory (where you have php.exe), or to a directory in your PATH variable

You will need to take those files and copy them inside the installdir/php directory

image

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.