PHP 7.3.16 error with Procesmaker 3.3.6 eith Bitmani Procesmaker 3.3.6-12

Keywords: ProcessMaker - Windows - Technical issue - Other
Description:
And I get system error in PHP recommended version 5.6 or higher, PHP 7.2 is not yet supported: 7.3.16

Mcrypt Support: Not Enabled

Hi @carlosandradesalas,

At which point do you get the error? Could you send a screenshot? We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

How to Run the Bitnami Support Tool

Please note that you need to paste the code ID that is shown at the end.

Regards,
Michiel

1-First, you should download the suitable version for your system from here:
https://pecl.php.net/package/mcrypt/1.0.3/windows
(i downloaded the ts version)

2- Then copy php_mcrypt.dll file into your /PATH/php/ext. where PATH is the exact location of the PHP folder

3- Now go to your /PATH/php/ folder and locate php.ini and search for ;extension=php_mcrypt.dll if you find it remove the ; in front
if it is not there just add the extension=php_mcrypt.dll at the bottom of the file

  1. Restart Apache

I have the same problem.
I will send you the screenshot.

Hi,

I was able to reproduce the issue. I will open a task for investigation. As soon as we have an update, we will update this ticket. Thanks for reporting.

Best regards,

Javier J. Salmerón


Was my answer helpful? Click on :heart:

2 Likes

i have the same problem either,
i’ll wait for further assistance at this thread.
Thank you in advance, #bookmarked hehe

Hi all,

We just detected that there was a regresion in the ProcessMaker version we include in the Bitnami solution. We updated PHP because ProcessMaker 3.4 supports that new version but then a ProcessMaker 3.x was released with that version too. We are working on releasing a new version of the Bitnami package with ProcessMaker 3.4 and PHP 7.3 and it should be available soon.

Sorry for the inconvenience.

Hi again,

The new version of the Bitnami solution is now available in bitnami.com. That new version includes ProcessMaker 3.4.9 that supports PHP 7.3.

Sorry again for the inconvenience.

1 Like

Thank you Jota i’ll give a try soon :grinning:

i’ve installed ProcessMaker 3.4.9 - CE. its run smooth without error,
just need a bit configuration for php_mcrypt.dll as kolawobee has explained before.
Thank you, Jota