Phabricator inbounding email not working with Sendgrid

Hi I seem to be having a lot of trouble with configuring Phabricator’s inbound email with bitnami and sendgrid.

  1. I have phabricator.crowdy.com MX 10 mx.sendgrid.net as my mx record (verified with nslookup -query=mx phabricator.crowdy.com)

  2. I have host=crowdy.com url=http://phabricator.crowdy.bitnamiapp.com/mail/sendgrid in my sendgrid preference (no complaints)

  3. I set metamta.reply-handler-domain to phabricator.crowdy.com.

When I send an email, t64@phabricator.crowdy.com, I am not getting anything from bin/mail list-inbound.

Any help?

Hi @vng;

Have you followed the every step in here? Just to make sure.

  1. https://secure.phabricator.com/book/phabricator/article/configuring_inbound_email/#configuring-phabricator
  2. https://secure.phabricator.com/book/phabricator/article/configuring_inbound_email/#mailgun-setup

I think you have configured it wrong.
For your first step, it should be phabricator.crowdy.bitnamiapp.com
For your second step, host should be crowdy.bitnamiapp.com. Url is fine.
For your third step, it should be phabricator.crowdy.bitnamiapp.com

Finally, it should be @phabricator.crowdy.bitnamiapp.com

Because you do not own crowdy.com, right?

Try with the new settings and tell me if they did the trick.

Regards;
Jorge

For my first step, how do I even add an MX for phabricator.crowdy.bitnamiapp.com? I wouldn’t be able to add the MX record for bitnamiapp.com

Hi @vng,

It is not possible to configure MX in BCH. You may want to change to Mailgun, as said in:

Please don’t hesitate to come back any issue you may find.

Edu.