Permissions denied after upgrading server to the latest version of Bitnami certified WordPress on AWS

Responding to your request for the support ID, I attach it, ID. 2a9fc857-d38d-a714-ceb4-bcbcd758d09e

It should be clarified that this time it came out a bunch of errors to be able to get that ID I attach screenshot.

Now to answer your question about how do I migrate my website.

I understand that Bitnami has a, guide with commands to do that, but I’m worried about making a mistake and damaging my website. So I better use the UpdraftPlus - Backup/Restore plug-in.

Then I delete the current instance on AWS and create another one that AWS already gives it to me updated, then I install on the new instance the UpdraftPlus - Backup/Restore plug-in and use the RARs. And I move everything to the new site.

Normally that makes me have to reinstall the SSL, but I’m already trying to see if there is a command that allows me to move the SSL. But there’s your question answered on how to move everything to the new Bitnami update.

I apologize if you do not understand my English I am using the translator of DeepL.

Hi!

I attach a video showing the moment I place the commands and also in the video you can see the old version of my bitnami which works fine my theme, and you can also see the updated version which disabled the settings of my theme and other things more.

I am afraid I can’t access the video:

It should be clarified that this time it came out a bunch of errors to be able to get that ID I attach screenshot.

Those errors you see are the possible errors our bnsupport-tool has identified in your instance or your configuration.

I understand that Bitnami has a, guide with commands to do that, but I’m worried about making a mistake and damaging my website. So I better use the UpdraftPlus - Backup/Restore plug-in.

We do not really have a preference for some plugins over others :slightly_smiling_face:. Nevertheless, if we make reference to a certain plugin in our guide that means that the team asserted the functionality worked as expected when elaborating the guide.

Having said that, I think that there is something wrong either with the way you are performing the migration or the plugin itself. All the errors you reported in the screenshots (and most likely the one of the permissions, as the DB is not correct) directly point to the UpdraftPlus plugin. In this case, it seems some tables/columns do not exist.

[Fri Jun 04 12:42:58.427832 2021] [proxy_fcgi:error] [pid 1636:tid 139931938629376] [client 190.110.220.130:51252] AH01071: Got error 'PHP message: Error Key 'PRIMARY' doesn't exist in table 'wp_fbv_attachment_folder' de la base de datos de WordPress para la consulta SELECT COUNT(*) FROM wp_fbv_attachment_folder USE INDEX (PRIMARY) realizada por do_action('wp_ajax_updraft_ajaxrestore'), WP_Hook->do_action, WP_Hook->apply_filters, UpdraftPlus_Admin->updraft_ajaxrestore, UpdraftPlus_Admin->prepare_restore, UpdraftPlus_Admin->restore_backup, Updraft_Restorer->perform_restore, Updraft_Restorer->restore_backup, Updraft_Restorer->restore_backup_db, Updraft_Restorer->prepare_create_table, Updraft_Restorer->restored_table, do_action('updraftplus_restored_db_table'), WP_Hook->do_action, WP_Hook->apply_filters, UpdraftPlus_Addons_Migrator->updraftplus_restored_db_table, UpdraftPlus_Addons_Migrator->_migrator_icit_srdb_replacerPHP message: Error Key 'attachment_id' doesn't exist in table 'wp_fbv_attachment_folder' de la base de datos de WordPress para la consulta SELECT COUNT(*) FROM wp_fbv_attachment_folder USE INDEX (attachment_id) realizada por do_action('wp_ajax_updraft_ajaxrestore'), WP_Hook->do_action, WP_Hook->apply_filters, UpdraftPlus_Admin->updraft_ajaxrestore, UpdraftPlus_Admin->prepare_restore, UpdraftPlus_Admin->restore_backup, Updraft_Restorer->perform_restore, Updraft_Restorer->restore_backup, Updraft_Restorer->restore_backup_db, Updraft_Restorer->prepare_create_table, Updraft_Restorer->restored_table, do_action('updraftplus_restored_db_table'), WP_Hook->do_action, WP_Hook->apply_filters, UpdraftPlus_Addons_Migrator->updraftplus_restored_db_table, UpdraftPlus_Addons_Migrator->_migrator_icit_srdb_replacer', referer: https://54.184.98.22/wp-admin/options-general.php?page=updraftplus
...
 FROM `wp_wfBlocks7` WHERE `type` IN (3) AND (`expiration` = 0 OR `expiration` > UNIX_TIMESTAMP()) ORDER BY `typeSort` ASC, `id` DESC realizada por wfWAFIPBlocksController::synchronizeConfigSettings, wfBlock::countryBlocks, wfBlock::allBlocksPHP message: Error Table 'bitnami_wordpress.wp_wfConfig' doesn't exist de la base de datos de WordPress para la consulta SELECT name, val, autoload FROM wp_wfConfig WHERE name = 'cbl_action' realizada por wfWAFIPBlocksController::synchronizeCon

Please make sure that you are also restoring the previous database in the process. Apart from that, I suggest that you reach out to the UpdraftPlus plugin developers for further assistance. I have launched a brand new instance and tried to install a plugin and a theme and they worked for me. Hence two options here come to my mind:

  • The migration process/plugin is not correct, and some vital data is missing. This may lead to unexpected errors.

  • The plugin/theme you use does not correctly work with the latest version of WordPress.

From the errors in your log, it’s clear that something is wrong with the actions UpdraftPlus is trying to perform to your DB.

But there’s your question answered on how to move everything to the new Bitnami update.
I apologize if you do not understand my English I am using the translator of DeepL.

Thanks a lot for the explanation and your time. No need to apologize, we’ll let you know if there is something we need further clarification on.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

The problem is not the UpdraftPlus plug-in as I indicated before I contacted you I ruled out any transfer error, so I installed only the theme from scratch without transferring it to the new bitnami update and there I got the error.

I know so you can replicate the problem and you can understand me better I will pass the theme install it on an instance of AWS option WordPress bitnami the free layer.

When you have the instance created access and delete all the plug-ins that appear by default in WordPress. and from there upload the rar with the theme. Then go to the left side option called buddyboss and a menu will expand.

In the menu that is deployed should appear theme options as I point out in the image, if it does not appear that means that the theme does not have sufficient permissions and that is my problem.

Below I attach the theme, it will be activated only for this test, it will not ask for a license.

** * * * REDACTED * * * * *

The problem is not the UpdraftPlus plug-in as I indicated before I contacted you I ruled out any transfer error, so I installed only the theme from scratch without transferring it to the new bitnami update and there I got the error.

In the menu that is deployed should appear theme options as I point out in the image, if it does not appear that means that the theme does not have sufficient permissions and that is my problem.

There is another thing that a fellow engineer suggested is worth trying. One of the differences the new instance has is that it uses some symlinks inside the /opt/bitnami/wordpress folders. Although WordPress itself supports storing wp-content outside the app directory, let’s try to undo the symlink and see if the plugin does not:

$ sudo /opt/bitnami/ctlscript.sh stop
$ sudo cp -R /opt/bitnami/wordpress /opt/bitnami/wordpress.back
$ sudo rm /opt/bitnami/wordpress/wp-content
$ sudo cp -R /bitnami/wordpress/wp-content /opt/bitnami/wordpress/wp-content
$ sudo /opt/bitnami/ctlscript.sh restart

After that, try to access the admin dashboard again and see if that solves the issue. That being said, you should contact the developer of the plugin for further assistance on this. WordPress itself supports setting wp-content outside the app directory!

Below I attach the theme, it will be activated only for this test, it will not ask for a license.

If the trick below does not tackle your issue, I am afraid we can’t provide assistance for specific issues on themes/plugins.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

After using the commands that you indicate me you can no longer upload plug-ins or theme to WordPress appears that error.

Try executing this to apply correct permissions:

$ sudo chown -R bitnami:daemon /opt/bitnami/wordpress/wp-content

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Woow perfect that solved my problem.

Excellent there if the problem was solved, but the bad thing is that the commands that I passed left another problem that does not allow me to upload theme and plug-in from WordPress only by SFTP.

And this command also helped a lot to solve the FTP permissions problem, and it will help me a lot, but now I just need to solve the other problem that caused the other command and be ready everything

223a1a66914e3ffd636f31e9dc0c01d2007e74a3_2_690x415

Oh and also I can’t seem to delete theme or plug-in now.

Hi @carbo17

Let me mention that the real issue here is with the theme itself. The commands I shared performed some modifications to the stack’s original file structure, which is not ideal.

Regarding the permissions, I think it is worth trying the following commands to restore the original ones:

sudo chown -R bitnami:daemon /opt/bitnami/wordpress
sudo find /opt/bitnami/wordpress -type d -exec chmod 775 {} \;
sudo find /opt/bitnami/wordpress -type f -exec chmod 664 {} \;
sudo chmod 640 /opt/bitnami/wordpress/wp-config.php

Once you have applied that, try deleting the theme or plug-in again. If you still experience permission issues, please share the last lines in your Apache error_log file to see if we can spot something:

$ sudo tail -n 40 /opt/bitnami/apache2/logs/error_log

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Thank you I think that would be all, my problem with the provided commands has been solved, thank you very much for the help.

Glad to see you were able to solve your issue! We are marking the previous answer as “Solution” and this topic as “Closed”.

If you have any other questions, please do not hesitate to let us know. Feel free to create a new topic referencing this one if necessary.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart: