Permission denied - Bitnami HTTPS Configuration tool -Let's Encrypt SSL Certificate for a Bitnami Application

:warning: IMPORTANT, please fill the questions

We assume you are using Bitnami to deploy your application.

  • Which version of the application are you using?:
    Ubuntu 16.04.6 LTS (GNU/Linux 4.4.0-1112-aws x86_64)

  • Please choose how you got the application: Installer (Windows, Linux, macOS), cloud image (AWS, GCE, Azure, …) or VM (VMDK, VBOX):

Installed WordPress from AWS Bitnami
*** Welcome to the Bitnami WordPress 5.4.1-0

  • Have you installed any plugin or modified any configuration file?:

  • Describe here your question/suggestion/issue (expected and actual results):

After succressully building a WordPress site on AWS I attempted to install SSL using LetsEncrypt, also through Bitnami.

I have run into permissions issues throughout the process. I have removed and attempted re-intallations three times.

Also my site, which was running smoothly is now unreachable. mktenterprises.com

I re-atttempted just now to get a clean statement of results, to keep it simple (because it has become incredibly complicated.

I am following these instructions
Generate and Install a Let’s Encrypt SSL Certificate for a Bitnami Application
https://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/#alternative-approach

Results from running first command
sudo /opt/bitnami/bncert-tool

Is this:
bitnami@ip-172-31-39-107:~$ sudo /opt/bitnami/bncert-tool

Welcome to the Bitnami HTTPS Configuration tool.


Bitnami installation directory

Please type a directory that contains a Bitnami installation. The default
installation directory for Linux installers is a directory inside /opt.

Bitnami installation directory [/opt/bitnami]: /opt/bitnami

Warning: The web server configuration check failed. Please fix the configuration
error:
/bin/sh: 1: /opt/bitnami/apache2/bin/apachectl: Permission denied
Press [Enter] to continue:

at this point, I cannot proceed with any resposne except to kill the process.

I did an ls to get details of the above file
-rw-r–r-- 1 bitnami daemon 3483 Apr 29 22:52 apachectl

Is there some secret instructions I need to chown files or directories so this will run?

Thanks in advance.

Hi @markkthomas,

It seems you modified the permissions of the whole installation folder. For example, the apachectl file should be configured like this

-rwxr-xr-x  1 root root   3483 Jun 15 05:22 apachectl

Let’s try to recover the permissions first but you will probably need to migrate the application data to a new instance later to ensure that all the permissions are correct. Could you please take a look at this other post in which I explain how to recover the permissions of the Apache’s, MySQL’s and WordPress’ folders

I get the default Apache’s page when accessing your domain. It seems you installed the Apache system’s package. Please follow this other guide to disable it

Happy to help!


Was my answer helpful? Click on :heart:

Thank you, Jota. I took the hint in your answer about having to move to a new server. Assuming I simply did something silly in the first attempt, I put up a new instances of my WordPress site. Running the configuration went in like butter!

Thanks again.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

We have added more information about resetting permissions in our guide at https://docs.bitnami.com/aws/how-to/troubleshoot-permission-issues/