Parse Dashboard shows blank white screen

Keywords: Parse - AWS - Technical issue - Other
bnsupport ID: 805f893f-0119-35e1-2433-6df56cd4fded
Description:
When I log into the Parse Dashboard, it shows the red, green, blue loading bubbles for about 2 seconds and then a blank white screen.

When I tried SSH into the server, it says:

mongodb not running
apache not running
parse-dashboard not running
parse not running

So I tried “sudo /opt/bitnami/ctlscript.sh start” and it says:
“Starting services…”

However, when I tried “sudo /opt/bitnami/ctlscript.sh status”, it still shows that mongodb, apache, parse-dashboard, and parse is not running.

This is my first time using a Bitnami Parse Server on AWS. Any help or suggestions would be greatly appreciated.

Hi @thedashboardcompany

Thanks for using Bitnami Parse!

I have checked your logs and indeed all the services are running, regardless of the output of ctlscript.sh. Furthermore, accessing your URL results in success:

$ curl -kLI XX.XXX.XXX.224
HTTP/1.1 302 Found
Date: Mon, 11 Jan 2021 11:29:21 GMT
Server: Apache/2.4.46 (Unix) OpenSSL/1.1.1d
X-Powered-By: Express
Location: /login
Vary: Accept
Content-Type: text/plain; charset=utf-8
Content-Length: 28

HTTP/1.1 200 OK
Date: Mon, 11 Jan 2021 11:29:21 GMT
Server: Apache/2.4.46 (Unix) OpenSSL/1.1.1d
X-Powered-By: Express
...

Unfortunately, the bnsupport-tool failed to retrieve some files. Could you please run the following commands?

$ tail -n 35 /opt/bitnami/apache2/logs/error_log
$ cat /opt/bitnami/parse-dashboard/server.js | grep serverURL

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hi @jcarmona

Thanks for your quick response. Here is is the response that was displayed after entering the 2 lines of code:

bitnami@ip-172-31-93-85:~$ tail -n 35 /opt/bitnami/apache2/logs/error_log
[Mon Jan 11 01:46:48.744522 2021] [mpm_prefork:notice] [pid 1479] AH00169: caught SIGTERM, shutting down
[Mon Jan 11 01:48:00.953747 2021] [ssl:warn] [pid 967] AH01909: 127.0.0.1:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jan 11 01:48:00.954539 2021] [ssl:warn] [pid 967] AH01909: 127.0.0.1:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jan 11 01:48:00.962000 2021] [ssl:warn] [pid 969] AH01909: 127.0.0.1:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jan 11 01:48:00.962331 2021] [ssl:warn] [pid 969] AH01909: 127.0.0.1:443:0 server certificate does NOT include an ID which matches the server name
[Mon Jan 11 01:48:00.964068 2021] [mpm_prefork:notice] [pid 969] AH00163: Apache/2.4.46 (Unix) OpenSSL/1.1.1d configured – resuming normal operations
[Mon Jan 11 01:48:00.964090 2021] [core:notice] [pid 969] AH00094: Command line: ‘/opt/bitnami/apache/bin/httpd -f /opt/bitnami/apache/conf/httpd.conf’
[Mon Jan 11 01:49:16.041995 2021] [mpm_prefork:error] [pid 969] AH00161: server reached MaxRequestWorkers setting, consider raising the MaxRequestWorkers setting
bitnami@ip-172-31-93-85:~$ cat /opt/bitnami/parse-dashboard/server.js | grep serverURL
serverURL: ‘http://localhost:1338/parse’,

Hi @thedashboardcompany

Thanks for sharing the commands’ output. I have launched a brand new instance (verion 4.9.3-2) and have not experienced any errors when accessing the dashboard. I see you are using an old version (4.3.0-2), is there any specific reason to?

Additionally, if you decide to remain using this version, could you please open the console panel in your browser to see if there are any errors there when accessing? If you are using chrome, this can be done as follows:

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hi @jcarmona

Thanks again for your quick response! Honestly, the real simple answer on why I’m using version 4.3.0-2 is because I don’t know how to upgrade my Parse Server (still very new to using the Parse server on Bitnami). I don’t know if you can see from your end, but thankfully, I have no data saved (or barely anything saved). So I have nothing to lose…just everything to gain from upgrading my Parse server.

Any guidance or assistance would be greatly appreciated. Thanks again for your help @jcarmona

If you don’t have any data to lose, the easiest way to upgrade is launch a brand new instance with the latest version.

Here you have a detailed guide that deals how to get started with Bitnami applications in AWS:
https://docs.bitnami.com/aws/get-started-marketplace/

Could that be an option for you?

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hi @jcarmona

Yes, that’s definitely an option for me (and probably best/easiest way like you said). I’ll launch a brand new instance of the Parse server (and delete this current instance since I’m not going to lose any data).

Thanks again for your help @jcarmona

My pleasure!

Please, update the thread with any new information :slightly_smiling_face:

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hi @jcarmona,

So I installed a new instance of the Parse Server (latest version 4.9.3-4-r05) on AWS (didn’t touch or add anything). However, when I signed in for the first time, I got the same red, green, blue loading bubbles for about 2 seconds and then a blank white screen. I decided to SSH and run “sudo /opt/bitnami/ctlscript.sh status” and it says:

mongodb already running
apache already running
parse-dashboard already running
parse already running

Any suggestions on what I can do? Thanks!

Hi @thedashboardcompany

Thanks for reaching out again! I have launched the same version on AWS and did not run into problems (version 4.9.3-4-r05 - ami-007456a9c0ce86d38). Could you please try accessing using another browser?

If you run into the same problem, could you please check your browser’s console?
https://community.bitnami.com/t/parse-dashboard-shows-blank-white-screen/90747/4?u=jcarmona

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Hi @jcarmona

Thanks for the suggestion. I tried it on Firefox and Safari and it works! The only browser it didn’t work on (which happens to be the browser I use often) is Chrome. This is what was displayed on the browser console for Chrome:

Hi @thedashboardcompany

I think this is due to accessing the site over HTTPS. You can configure the asset to work with HTTPS, but could you please try accessing the page over regular HTTP?

http://YOUR-INSTANCE-IP

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.