ownCloud on AWS LightSail Bitnami LAMP stack server - 500 error

Trying to use ownCloud on Lightsail Bitnami based LAMP stack server. Getting a 500 error trying to go beyond the ‘welcome’ page for ownCloud.

Server was deployed from AWS Lightsail server choice for Bitname LAMP stack.

Version: Owncloud 10.0.3-0

Installer: BItnami download for OwnCloud 10.0.3-0

Plugins / config changes: None outside whatever the ownCloud installer makes.

Issue:

Brand new AWS LIgthsail server based on the Bitnami LAMP stack. Nothing tweaked yet.
Ran the ownCloud install with SUDO
Faked my way through the config.
Opened 81 and 444 on my LightSail firewall.
I can get to the first page. But trying to go beyond that also gives me the 500 error.

Using Chrome dev console, you can see the 500 error come up instantly.

Repro: see Issue above

Looking a the Apache logs, I can see a permissions issue on the CONFIG.PHP file. (opt/owncloud-10.0.3-0/apps/owncloud/htdocs/config/config.php)

I gave it 744 for now, and get a lot further. Now the issue is getting to its database. So, the installed (run under SUDO) didn’t set permissions correctly for this.

Now to figure out the DB issue.

I am going to take a wild guess that installing this on a LAMP stack based server may not be the best idea. It would be a relatively advanced install, since you already have MYSQL installed, it you don’t get to tell the installer to use it.

That may or may not be the heart of my problem. Still investigating.

I gave up on that. After changing permissions on a couple of config files (as identified in the Apache logs), I was getting nowhere making it work.

Tossed the LAMP stack server. Built out a generic Ubuntu 16.04 server in LightSail and then ran the installer (as SUDO) on that. Came right up this time.

So… the takeaway here is do not try and install the Bitnami based ownCloud package onto the Bitnami based LAMP Stack (at least not in the AWS LghtSail environment). Each package tries to install everything for you, so you end up with multi Apache installs and MYSQL installs, etc. (Hopefully one day the installer will auto detect already installed versions and try to leverage those instead)

ownCloud’s own documentation talks about how to install it on an existing server by hand. Very logical. They even break out their offerings as ‘just the files for the app’ / ‘everything you could need including apache and mysql’ / ‘just the “everything else” without the app’.

Strange. I use Nextcloud instead of Owncloud. But beside that everything works great for me. I use the LAMP stack and install Nextcloud via the zip file from the website. It works great here. Not sure what is different with your setup or Owncloud

Hi,

We are sorry for your frustration. This is strange. Something tells me that you may have used the Owncloud Stack Installer instead of the Owncloud LAMP Module Installer: https://bitnami.com/redirect/to/161565/bitnami-owncloud-10.0.3-0-module-linux-x64-installer.run

Could you confirm if this is true?

Best regards,

Javier J. Salmerón


Was my answer helpful? Click on :heart:

First off:

Thank you (everyone) for responses for my frustration / issues. I appreciate it.

I built my machine using Amazon’s Lightsail service, and use the Bitnami based server (they present for creation) that has the LAMP stack pre-installed. After feeling that it looks good, and getting hooked on the Bitnami idea, I decided I would try the ‘ownCloud’ add on.

I pulled down the package and tried the installation on my brand new server, as sudo.
I would say the only config conundrum was the ‘base URL’ question. It prefills with ‘127.0.0.1’ which is local host only. So should I leave it like that, or give it the server’s actual external FQDN? At first I left it at default.

And then I hit all my problems. The biggest being config file access rights by the service as deployed out of the box. While I have the skills to change those by hand, the idea (as I understand it) is that you shouldn’t have to.

That all said, I (eventually) tossed all of that and built a new vanilla server based on Ubuntu 16.04, using the generic AWS Lightsail image. Then I added the Bitnami based ‘ownCloud’ image on top. Nothing more. This answer works ‘out of the box’.

Annoyance on this install method is that SMTP isn’t installed in the core Ubuntu image. So getting notifications working in the ‘ownCloud’ install has a lot more manual effort involved.

Overall I think the Bitnami idea is super great to get good software into more hands who would not use it because it is hard for the layman to install and configure on their own. Double plus super kudos for the whole Bitnami idea and project. Everyone who works on this deserves an extra pat on the back, no matter what level of the whole thing that work at.

** for testing, an Amazon Lightsail instance is only $5.00 a month for the smallest version, and can be tossed at any time.

Hi

First of all, thank you for your kind words.

I would say the only config conundrum was the ‘base URL’ question. It prefills with ‘127.0.0.1’ which is local host only. So should I leave it like that, or give it the server’s actual external FQDN? At first I left it at default.

As you want external access, then the FQDN would have been a better option. Otherwise you need to edit the configuration file to add the trusted domain.

And then I hit all my problems. The biggest being config file access rights by the service as deployed out of the box. While I have the skills to change those by hand, the idea (as I understand it) is that you shouldn’t have to.

We would appreciate if you could elaborate a bit more on the issues you found so we can improve the module.

Best regards,

Javier J. Salmerón


Was my answer helpful? Click on :heart: