Out of Memory issue in wp-db.php

Keywords: WordPress - AWS - Technical issue - Other
bnsupport ID: 09db221a-78fe-9b8f-9a54-67ca772bf2a6
Description:
Getting the following error, how to increase memory?

locate 2151072 bytes) in /opt/bitnami/apps/wordpress/htdocs/wp-includes/wp-db.php on line 2
056```

Hi @gg_0101,

Where are you seeing this error? Your instance seems to have enough memory.

Regards,
Michiel

Yes, I have seen this error.

I created a bigger instance using images of old instances … may be configuration is still based on old instances. can this be the case? how can I increase memory here and where I find this configuration?

Hi @gg_0101,

Could you try decreasing the max_children setting in the php/etc/bitnami/common.conf to a lower value. like 35, and then restart php-fpm?

 sudo /opt/bitnami/ctlscript.sh restart php-fpm

Regards,
Michiel

I increase this …will monitor it and come back if not solved

1 Like

I am still Getting out of memory error. Image attached

I am also getting this error.

No execution time limit. The max_execution_time PHP configuration directive is set to 0.

Hi @gg_0101,

Can you increase the memory_limit value in the /opt/bitnami/php/etc/php.ini file, and then restart php-fpm?

Regards,
Michiel