OpenProject switch to BIM edition seems impossible

:warning: IMPORTANT, please fill the questions

We assume you are using Bitnami to deploy your application.

  • Which version of the application are you using?:
    OpenProject 11.2.4

  • Please choose how you got the application: Installer (Windows, Linux, macOS), cloud image (AWS, GCE, Azure, …) or VM (VMDK, VBOX):
    VirtualBox

  • Have you installed any plugin or modified any configuration file?:
    No

  • Describe here your question/suggestion/issue (expected and actual results):
    I downloaded then launched Openproject via Virtualbox. I can reach the application via browser, but : every time i try to execute anything in the command line starting with opt/… or installdir/… a line says that the command do not exists or the directory could not be found. So i am unable to launch any gem for plugins or reach the configuration file. I’d like to switch from the “standard” edition to the BIM one. I saw on the official documentation that basically is necessary only a command line to activate that one, but still, any of my command is basically ignored because of what is written up there. I tried to access var/log/syslog but “permission denied” . I use “bitnami” and “bitnami” as credential for the terminal, as said when i launch the virtual machine.

thanks for your help

  • Steps to reproduce the issue (if relevant):

  • Copy the apache log (if relevant):

PASTE HERE

Hi @momyzilla88,

Thanks for using Bitnami. Can you give us any example of a command you are trying to run and the output you are getting? Can you also try to load the Bitnami console before running the command?

cd /opt/bitnami
sudo ./use_openproject

We also have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

Please note that you need to paste the code ID that is shown at the end.

hi, yes for example: https://drive.google.com/file/d/1uyjQHgWf5Q87kvT8d_uFqvnllmtR4Zke/view?usp=sharing

As you can see your commands work, but when i try anything else it doesn’t work. I am reading from the documentation at https://docs.bitnami.com/virtual-machine/faq/configuration/understand-bnconfig/ for example.

Thanks

About the bntool : https://drive.google.com/file/d/1omwFfSQsdY_z3AmXTmLrXSNI4YU1IFms/view?usp=sharing

Hi @momyzilla88m,

Thanks for the screenshot. Notice that when you run the cd command without any other argument, you are getting back to your home folder, which is /root according to your screenshot.

Also notice installdir is not a real directory name, but a placeholder for the installation directory of the Bitnami application. In the case of virtual-machines, it is /opt/bitnami. Can you follow the guide about the bnsupport-tool using /opt/bitnami as the base directory? Can you also run the commands you were trying to run previously having this into account?

ok thanks, i try right now and let you know

Ok it works : now i am seeing the bitnami dir and i am in bnconfig. But “reconfigure” is not a valid command.

From the official openproject documentation: sudo openproject reconfigure is enough to switch to BIM version.

What kind of command can i use to reconfigure using sudo /opt/bitnami/apps/openproject/bnconfig [if it is correct] ?

Hi @momyzilla88,

bnconfig is a generic tool to configure some settings of the application, but you can’t run the command you are trying to run, that is specific for OpenProject.

https://docs.bitnami.com/aws/faq/configuration/understand-bnconfig/

I also don’t know if the openproject binary is included or if it will work, because it seems to be specific for the Docker images (according to the official docs)

https://docs.openproject.org/installation-and-operations/operation/reconfiguring/

Can you check if any of the rake tasks available helps you? You can check them by running the next commands

cd /opt/bitnami/apps/openproject/htdocs
bundle exec rake -T

i just saw the list but i don’t think any of these can help. So… Now i have to ask, is really possible to switch to or do a fresh installation of openproject with BIM mode instead of deafult mode ?

Thanks

Hi @momyzilla88,

Thanks for your message. I checked our virtual machine and I didn’t find any openproject binary. I’m also not sure if it is possible to convert an installation that doesn’t include this binary into a BIM installation. Can you check it with the OpenProject developers? They know how the application works internally better than we do

https://community.openproject.org/projects/openproject/forums

What I see in the rake list is a method for running the BIM database migrations, but I don’t know if it is enough to set the BIM mode.

Thanks for your reply, i’ll ask them.

Have a nice day :smiley:

Hi @momyzilla88,

Thanks for your message. We really hope they can help you with this question. If you get your issue solved, please add a link here to be of help to other users in the future.

Regards,
Gonzalo

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.