OpenProject 10.3.1-3

A couple of days ago I installed the VMDK format file of OpenProject on my windows10 computer. Everything is working fine, the installation just misses the sample projects and all the settings (typ, status, priority, colors …) that come with it. Is the problem releted to the download file you provide under https://bitnami.com/stack/openproject/virtual-machine or is there anything wrong with my installation?

Thanks, Wolf

Hi @wolf,

Could you please elaborate? We would like to review the solution and see if there is something wrong with it. Let us know the steps you followed and what should appear and what you get.

Thanks

Hi @jota,

thanks for your fast reply :-)!

I downloaded the download.VMDK format from https://bitnami.com/stack/openproject/virtual-machine, unpacked the zip file into a folder on c:/openproject after that I installed WMware and opened the vmware virtuale machine file bitnami-openproject-10.3.1-3-linux-debian-9-x86_64. I log into bitnami without changing the password, and get the browser address for running openproject and loging in. When I log in everything workes fine except from the missing sample projects and all the missing categories (work package types, statuses, priorities, colors and so on). Since I haven’t found out where to define priorities in the administration section I was not even able to define a working package (priority is necessary to store work packages). Hope this short description is of any help. If you have any further questions, please let me know.

Hi @wolf,

Thanks for the info. I checked our OpenProject asset and I think I have discovered what’s happening. I tried to manually run the db:seed command to populate the database with the sample data, and it fails with the next error message

bundle exec rake db:seed
[DEPRECATED] Bundler.environment has been removed in favor of Bundler.load (called at /opt/bitnami/apps/openproject/htdocs/lib/open_project/plugins/acts_as_op_engine.rb:178)
*** Seeding for locale: 'en'
*** Seeding basic data for standard edition
 ↳ BuiltinRolesSeeder
 ↳ RoleSeeder
 ↳ ActivitySeeder
 ↳ ColorSeeder
 ↳ ColorSchemeSeeder
 ↳ WorkflowSeeder
   ↳ Types
   ↳ Statuses
 ↳ PrioritySeeder
 ↳ SettingSeeder
   Loading discovered seeders:
 ↳ SettingSeeder
 ↳ EnumerationsSeeder
*** Seeding admin user
   *** No need to seed an admin as there already is one.
*** Seeding demo data
 ↳ GroupSeeder
    ↳ Creating groups
 ↳ AttributeHelpTextSeeder
    ↳ Creating attribute help texts
 ↳ GlobalQuerySeeder
    ↳ Creating global queries
 ↳ ProjectSeeder
 ↳ Creating demo-project project...
   -Creating/Resetting project
   -Setting project status.
   -Setting members.
   -Creating news.
   -Assigning types.
   -Creating categories
   -Creating versions.
   -Creating queries.
   -WikiSeeder
    ↳ Creating wikis...
   -CustomFieldSeeder
    ↳ Creating custom fields...
   -WorkPackageSeeder
    ↳ Creating work_packages.rake aborted!
SocketError: getaddrinfo: Name or service not known
/opt/bitnami/apps/openproject/htdocs/vendor/bundle/ruby/2.6.0/gems/mail-2.7.1/lib/mail/network/delivery_methods/smtp.rb:109:in `start_smtp_session'
/opt/bitnami/apps/openproject/htdocs/vendor/bundle/ruby/2.6.0/gems/mail-2.7.1/lib/mail/network/delivery_methods/smtp.rb:100:in `deliver!'
/opt/bitnami/apps/openproject/htdocs/vendor/bundle/ruby/2.6.0/gems/mail-2.7.1/lib/mail/message.rb:2159:in `do_delivery'
/opt/bitnami/apps/openproject/htdocs/vendor/bundle/ruby/2.6.0/gems/mail-2.7.1/lib/mail/message.rb:260:in `block in deliver'
/opt/bitnami/apps/openproject/htdocs/vendor/bundle/ruby/2.6.0/gems/actionmailer-6.0.1/lib/action_mailer/base.rb:589:in `block in deliver_mail'
/opt/bitnami/apps/openproject/htdocs/vendor/bundle/ruby/2.6.0/gems/activesupport-6.0.1/lib/active_support/notifications.rb:180:in `block in instrument'
/opt/bitnami/apps/openproject/htdocs/vendor/bundle/ruby/2.6.0/gems/activesupport-6.0.1/lib/active_support/notifications/instrumenter.rb:24:in `instrument'
/opt/bitnami/apps/openproject/htdocs/vendor/bundle/ruby/2.6.0/gems/activesupport-6.0.1/lib/active_support/notifications.rb:180:in `instrument'
/opt/bitnami/apps/openproject/htdocs/vendor/bundle/ruby/2.6.0/gems/actionmailer-6.0.1/lib/action_mailer/base.rb:587:in `deliver_mail'
/opt/bitnami/apps/openproject/htdocs/vendor/bundle/ruby/2.6.0/gems/mail-2.7.1/lib/mail/message.rb:260:in `deliver'
/opt/bitnami/apps/openproject/htdocs/vendor/bundle/ruby/2.6.0/gems/actionmailer-6.0.1/lib/action_mailer/message_delivery.rb:114:in `block in deliver_now'

As you can see, it tries to do something related to SMTP and it fails because SMTP isn’t configured by default. If you configure it in the admin panel with valid credentials and then you run the rake db:seed command again, it will work fine. You only need to run the command below before configuring SMTP. There are some missing permissions we will fix on our side in a future release.

sudo chmod 664 /opt/bitnami/apps/openproject/htdocs/config/configuration.yml

I also recommend you to run the rake assets:precompile task after the db:seed success just in case. Apart from that, note you will need to restart Apache after running the rake command for changes to take effect.

sudo /opt/bitnami/ctlscript.sh restart apache

I can see now the work types populated on my side

Hi @gongomgra,

thanks for your effort and the information about how to solve the issue.

I proceded as described by you:
run the sudo chmod 664 /opt/…
changed to the admin panel in the browser (not sure what to change there, since I already put a valid email address and name - do I have to change the password and user name or anything SMTP related?)
Went back to the VMware console to run the rake command and got the following response (rake aborted, no rakefile found):

Do you have any ideas how to solve this?
Thanks!

Hi @wolf,

Please find below the detailed steps:

  • SSH connect and set write permissions
sudo chmod 664 /opt/bitnami/apps/openproject/htdocs/config/configuration.yml
  • Log into the OpenProject website and open the admin panel

  • Click the “System Settings” option in the left menu and the visit the “Email notification” tab

  • Configure you SMTP settings at the end of that page and click the “Save” button

  • Now, get back to the SSH console, and run the next commands
# Load the Bitnami console environment
sudo /opt/bitnami/use_openproject

# Move to the OpenProject installation directory
cd /opt/bitnami/apps/openproject/htdocs

# Run the rake commands
bundle exec ./bin/rake db:seed RAILS_ENV=production
bundle exec ./bin/rake assets:precompile RAILS_ENV=production

# Restart services
/opt/bitnami/ctlscript.sh restart
  • After that, you should see the work package types populated as shown in my latest post

Hope it helps,
Gonzalo

1 Like

Hi @gongomgra,

it is working! Thanks so much!!

Had a rought time though because in the email I received the commands were cut and it took me two tries before I discoverd the right commands here in the forum.

Thanks again,
Wolf

Hi @wolf,

Thanks for the info. I’m glad you fixed your issue! We will close this thread as solved. Please do not hesitate to open a new one with any other questions you may have.