OpenEdx on AWS - Unable to login into studio with user@example.com

Keywords: OpenEdX - AWS - Technical issue - Credentials
bnsupport ID: 8d43f90f-6c41-6d0a-0382-6211fc901ad3
Description:
Hello, I launched Bitnami Open Edx from AWS Marketplace and was able to SSH successfully, but using credentials (user@example.com with password from login screen) to login into Studio (http://IP/edx-studio) is unsuccessful. I retrieved credentials per instructions from /home/bitnami/bitnami_credentials and have confirmed that they are same. I was able to connect to mysql with the same credentials.

I also tried changing ‘user’ password by “sudo /opt/bitnami/apps/edx/bin/python.edxapp manage.py lms changepassword user --settings=bitnami” (per https://community.bitnami.com/t/login-error-on-bitnami-open-edx-vm-solved/65160/10), that did not work either.

What else can be done ? I need to get through this barrier (the very first step) to build some test courses. Please help.

Note: Earlier, I used Bitnami Open edX VM image and had the same issue, couldn’t get pass the login screen.
AWS AMI ID- ami-0f344c52d82e7e7bd
AWS AMI NAME- bitnami-edx-koa.1-0-r33-linux-debian-10-x86_64-hvm-ebs-98f7975e-2bf7-428b-8fd4-d9a91d062464

Hi @mr.sreek,

I just launched a fresh instance of Bitnami Open edX and everything worked as expected. I could access both portals without problems

Could you please try to access the application using a different browser or an incognito window to confirm that the browser is not the problem? If you don’t have any information in that instance, I suggest you delete this instance and use a new one to avoid more errors related to the password change you performed.

Happy to help!


Was my answer helpful? Click on :heart:

Hey @jota,

I redeployed Bitnami Open Edx on AWS, this time I deployed it in a private subnet. I got to the Studio login page and when click on Sign-in, it takes me to another strange IP address

I had the same issue when I installed the VM, it re-directed to 10.0.2.15, then I had to set port forwarding which worked for a few more clicks.

I tried changing the VM to a static IP (https://docs.bitnami.com/virtual-machine/faq/configuration/configure-static-address/), then I also tried configuring application IP / hostname (https://docs.bitnami.com/virtual-machine/faq/configuration/use-bnconfig/), but it wasn’t fully successful.

In this case, on AWS, do I have to have a public IP / EIP, is there a workaround to work with private IP ?

What is this IP (54.90.53.230), that Bitnami AWS Open EdX is pointing to ? Can I change it somewhere to point it to my IP (192.x.x.x) ?

Thanks
Sreek

Hi @mr.sreek,

54.90.53.230 is the public IP address of the instance. If you want the application to use a different IP you need to configure the domain for the application:

sudo /opt/bitnami/apps/edx/bnconfig --machine_hostname IP

Replacing IP with the private IP address.

Regards,
Michiel

Ok, Gentlemen,

I redeployed Bitnami Open Edx on AWS for the 5th time, and

changed IP per your guidance

changed hostname

disabled bnconfig

and rebooted.
I land on the homepage both by IP and DNS


I hit sign in on the studio page and got the login prompt

I retrieved the password and used username “user@example.com” and password as retrieved

and nothing happens, I am back at the welcome page (tried several times)

Then, I tried to run the demo (hitting sign in and providing credentials) and I get

I changed the browser settings to allow ‘pop-ups’ and 'insecure content’

and I am able to login into mysql, with the retrieved password

That’s it. I am unable to move forward. what am I missing ? what else needs to be done ?

Appreciate your help.

Thanks

1 Like

Hi @mr.sreek,

I’m not able to reproduce the issue you reported. I’ve started a new VM in the us-east-1 region and accessed the edx-studio site without problems again.

I took a look at the browser’s console and didn’t find anything wrong

I also confirmed that the security group of the instance I launched was properly configured

and that the machine had enough free resources

Could you please answer the following questions?

  • What instance type did you select when launching the Bitnami edX solution? What region?
  • Did you try to log in to the studio portal using a different browser or an incognito window?
  • Can you check the browser’s console to see if there is any redirection?
  • Do you have other ports opened in the firewall?
  • From your first screenshot, I can see that you accessed your site using a custom domain name (flbi-edx.org). Is that a domain you configured in the application?

I am having this exact same issue - downloaded directly to a local VM on three different computers and two different networks and every time with the same result: logging in “succeeds” in the sense that I don’t get an error message (like I do if I put in bogus credentials) but it just takes me back to the login screen.

I did many of the same steps as OP – used SSH to update the password successfully, can login to MySQL no problem with those credentials.

But always the same result when I try to login (on both the home page and the studio page). Just dumps me back to the generic home page.

So I don’t know what the solution is, but I’m stuck just like OP.

File details: bitnami-edx-koa.2-0-linux-debian-10-x86_64.ova running on VMware player.

Hi @digitalheritage,

Can you confirm the VM has the necessary resources for the application to work properly? Please note that edX needs at least 6GB of RAM to work, do the VM has enough free memory to work? Does the host system have enough memory to host the VM?

You can verify that the boot process finished correctly by running this command

sudo cat /opt/bitnami/var/log/*

if there is not any error there, I suggest you try to log in to the application using an incognito window or a different browser.

Thanks

Thank you for your response. Yes the VM has 6GB or RAM dedicated to it. Running the log script yields the following result:

Not sure what I’m looking for, but it does look suspicious that 80 and 43 are “blocked.” Not sure what that means or how to fix it. I’ll do some research but if you have a quick fix let me know!

Hi @digitalheritage,

I can’t see the whole output of the post-start scripts, can you run this command and share a screenshot here?

sudo cat /opt/bitnami/var/log/post-start.log

Apart from that, can you confirm that all the services are running?

sudo /opt/bitnami/ctlscript.sh status

@jota,

Thank you so much for your reply. It appears all the services are running:

And this is the output of the post-start scripts:

I have the same issue. All the services are running correctly and the logs do not have sql errors.

This is where I got the instance:
https://bitnami.com/stack/edx/cloud/aws/amis
ami-08046a2a5bf852a25

ran on t2-large

I am able to log in as user@example.com but not able to log in as administrator through the http://xxxx/edx-studio link.

@jota can you post the exact ami (and instance size) you used? I can give that a try. thanks!

Hi @markvitapoly,

I just launched a t2 large machine in AWS using the latest Bitnami image. I used the Bitnami Launchpad for AWS

https://docs.bitnami.com/aws/get-started-launchpad/

and could log in to the the main site

and the edx-studio site

I tested the same in a t3a large instance and everything worked fine too. Can you try using the t3a.large instance to see if the solution works for you? If you keep getting errors, can you try using a different browser or an incognito window?

Thanks

Hi @digitalheritage,

I do not see any error in the logs, can you check the browser’s console to see if there is any error or try to log in to the application using a different browser or an incognito window?

SOLVED: I was using Chrome and Edge browsers in normal mode and incognito mode. That was the problem – both of those browsers at this point refuse insecure connections. Since I have not yet set up the SSL certificates since I’m running on a virtual machine in a test environment that resulted in the failed login. Using Firefox, which allows the insecure connection, it logged in no problem and without any errors. I feel kind of dumb - but I’m surprised there was nothing posted on this since I assume it would be a fairly common scenario to encounter since Chrome and Edge have the lion’s share of the PC browser market.

Anyway - thanks for all the help. Hopefully this keeps someone else from pulling all their hair out in the future. Cheers.

Hi @digitalheritage,

I’m really glad to hear that and thank you for sharing the information here. :slight_smile: I was also using Firefox when testing the application and didn’t notice the issue with Chrome/Edge.

Enjoy :tada: