OpenClowd VM fails to detect network address under particular network settings in VirtualBox

Keywords: OwnCloud - Virtual Machines - Technical issue - Other
Description:
If you set VM to run inside VirtualBox Host-only Ethernet Adapter network with Host-only Adapter, scripts inside VM is unable to find IP-address, and subsequently fail to show any credentials for connection even if interface up and running and you’re able to reach site in web browser.
Also, after establishing a connection to the site under this circumstances, you will immediately receive “You are accessing the server from an untrusted domain.” error .

Hi @unhappy.troll,

Thank you for using Bitnami. I just downloaded the latest version of Bitnami ownCloud and created a new Host-only Adapter in VirtualBox

image

Then configured the application to use that adapter

image

Then I started the machine and configured the network interface settings

sudo ifconfig NAME_OF_THE_INTERFACE 192.168.56.2 netmask 255.255.255.0 broadcast 192.168.56.255
sudo ip route add default via 192.168.56.1
sudo /opt/bitnami/apps/owncloud/bnconfig --machine_hostname 192.168.56.2

Happy to help!


Was my answer helpful? Click on :heart:

1 Like

Thank you for info on workaround. Still, it does not give the user credentials for login.

Hi @unhappy.troll,

What do you mean with your last message?

  • Can you access the login page?
  • Can you use your credentials? Do you know the ones you need to use?
  • Do you receive any error message when running the commands or when accessing the login page?

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.