Old LAMP stack available ? (PHP 5.2, MySQL 5.0.45, Apache 2.2)

Keywords: LAMP/MAMP/WAMP - Linux - How to - Other
Description:
Hi!

I’m looking for a really old LAMP stack containing the following versions:

  • PHP 5.2.6
  • MySQL 5.0.45
  • Apache 2.2

I have a very old application (TestLink 1.9.3) running on an old CentOS machine using the mentioned versions.
Now I need to move away from this machine (as it’s obviously outdated OS), and need to install that on an Ubuntu 20.04 LTS.

I know, that basically, there is a TestLink stack from Bitnami as well - but unfortunately it starts with TestLink version 1.9.4 only - and I cannot risk doing an upgrade at this very moment (I have a few test installations with TestLink 1.9.4 and also with some recent versions of TestLink like 1.9.16, 1.9.18 up to 1.9.20, but I have problems in upgrading the database and I encountered a certain error while working with TestLink then - so I cannot do risk that right now.

That’s why I would like to install the very same versions of what I already had on my old machine.
So can someone please help?

Thx upfront,
Best regards, Chris

Hello @christian_presslmayr,

Unfortunately, the oldest version we still have in our archives is a LAMP stack using PHP 5.4.X, Apache 2.4.X, and MySQL 5.1.X, would that work for you?

Regards,
Francisco de Paz

Hi @fdepaz!

I don’t know - unfortunately.
But let’s give it a try :slight_smile:

So, would be great if you could provide this LAMP stack to me.
Thx in advance!
Best regards, Chris

Hi @christian_presslmayr,

The oldest installer that we have available uses PHP 5.3.29, Apache 2.4.9, and MySQL 5.5.29:

http://downloads.bitnami.com/files/stacks/lampstack/5.3.29-0/bitnami-lampstack-5.3.29-0-linux-x64-installer.run

The next oldest installer would be one using PHP 5.4.36:

http://downloads.bitnami.com/files/stacks/lampstack/5.4.36-0/bitnami-lampstack-5.4.36-0-linux-x64-installer.run

Regards,
Francisco de Paz