No diagnostic code produced by tool

Type: Bitnami Support Tool

Description:
As described - I don’t get any code when I run the tool within my AWS Lightsail instance.

I have an urgent problem with expired certificates and I believe the tool has some information but I am unable to produce the code required for a proper ticket.

Hi @lillian.wight,

Could you try to stop the services before executing them? You could do it with:

sudo /opt/bitnami/ctlscript.sh restart

Please let us know if it helps

Hi, @davidg!

I restarted the services as suggested and got the same Apache error as usual:

 bitnami@ip-172-26-8-2:~$ sudo /opt/bitnami/ctlscript.sh restart
AH00526: Syntax error on line 5 of /opt/bitnami/apps/wordpress/conf/httpd-app.conf:
Invalid command 'unix:/opt/bitnami/php/var/run/wordpress.sock|fcgi://wordpress-fpm', perha
ps misspelled or defined by a module not included in the server configuration
apache config test fails, aborting
/opt/bitnami/php/scripts/ctl.sh : php-fpm stopped
/opt/bitnami/mysql/scripts/ctl.sh : mysql stopped
/opt/bitnami/mysql/scripts/ctl.sh : mysql  started at port 3306
/opt/bitnami/php/scripts/ctl.sh : php-fpm started
AH00526: Syntax error on line 5 of /opt/bitnami/apps/wordpress/conf/httpd-app.conf:
Invalid command 'unix:/opt/bitnami/php/var/run/wordpress.sock|fcgi://wordpress-fpm', perha
ps misspelled or defined by a module not included in the server configuration
apache config test fails, aborting
bitnami@ip-172-26-8-2:~$ 

I’ve searched the error and had no luck figuring out the problem.

My investigations have continued.

For one thing, I’m not sure I have an Apache installation. Please see the results of the following commands:

bitnami@ip-172-26-8-2:~$ sudo systemctl status apache2
Unit apache2.service could not be found.
bitnami@ip-172-26-8-2:~$ sudo service apache2 restart
Failed to restart apache2.service: Unit apache2.service not found.
bitnami@ip-172-26-8-2:~$ sudo apachectl stop
AH00526: Syntax error on line 5 of /opt/bitnami/apps/wordpress/conf/httpd-app.conf:
Invalid command 'unix:/opt/bitnami/php/var/run/wordpress.sock|fcgi://wordpress-fpm', perhaps mis
spelled or defined by a module not included in the server configuration
bitnami@ip-172-26-8-2:~$ 

then,

bitnami@ip-172-26-8-2:~$ sudo ps aux | grep -E 'apache2|httpd'
root      1082  0.0  0.0 196288   128 ?        Ss   Jun13   4:30 /opt/bitnami/apache2/bin/httpd.
bin -f /opt/bitnami/apache2/conf/httpd.conf -DDISABLE_BANNER
daemon    3174  0.0 10.2 1306028 50576 ?       Sl   05:29   0:16 /opt/bitnami/apache2/bin/httpd.
bin -f /opt/bitnami/apache2/conf/httpd.conf -DDISABLE_BANNER
bitnami  12259  0.0  0.1   6208   868 pts/0    S+   23:19   0:00 grep -E apache2|httpd
daemon   25725  0.0  8.7 1307484 43200 ?       Sl   Sep22   0:15 /opt/bitnami/apache2/bin/httpd.
bin -f /opt/bitnami/apache2/conf/httpd.conf -DDISABLE_BANNER
daemon   30748  0.0  5.9 1309824 29216 ?       Sl   Sep07   0:53 /opt/bitnami/apache2/bin/httpd.
bin -f /opt/bitnami/apache2/conf/httpd.conf -DDISABLE_BANNER
bitnami@ip-172-26-8-2:~$

finally,

bitnami@ip-172-26-8-2:~$ sudo killall apache2
apache2: no process found
bitnami@ip-172-26-8-2:~$

Is it safe to just go ahead and install apache2? Or does this imply something else?

One other thing!

I compared the original httpd-app.conf file to the one on my sytem; mine is missing this entire bottom section:

RewriteEngine On
#RewriteBase /wordpress/
RewriteRule ^index\.php$ - [S=1]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . index.php [L]

Include "/opt/bitnami/apps/wordpress/conf/banner.conf"

Include "/opt/bitnami/apps/wordpress/conf/htaccess.conf"

The bit about banner.conf may refer to the Bitnami banner that appears for developers unless they turn it off, which I did. That may explain why that little portion isn’t in my .conf file anymore.

Hello @lillian.wight,

The correct way to restart Bitnami services is using sudo /opt/bitnami/ctlscript.sh restart command. As the output of the command suggests, there seems to be an error on line 5 of /opt/bitnami/apps/wordpress/conf/httpd-app.conf

The default content of that file is below, so you can compare and try to fix errors:

RewriteEngine On
RewriteRule /<none> / [L,R]

<IfDefine USE_PHP_FPM>
    <Proxy "unix:/opt/bitnami/php/var/run/www.sock|fcgi://wordpress-fpm" timeout=300>
    </Proxy>
</IfDefine>

<Directory "/opt/bitnami/apps/wordpress/htdocs">
    Options +MultiViews +FollowSymLinks
    AllowOverride None
    <IfVersion < 2.3 >
        Order allow,deny
        Allow from all
    </IfVersion>
    <IfVersion >= 2.3>
        Require all granted
    </IfVersion>


    <IfModule php7_module>
            php_value memory_limit 512M
    </IfModule>

    <IfDefine USE_PHP_FPM>
       <FilesMatch \.php$>
         SetHandler "proxy:fcgi://wordpress-fpm"
       </FilesMatch>
    </IfDefine>


    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ - [S=1]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]

    Include "/opt/bitnami/apps/wordpress/conf/banner.conf"
</Directory>

Include "/opt/bitnami/apps/wordpress/conf/htaccess.conf"

My suggestion was to execute sudo /opt/bitnami/ctlscript.sh stop (sorry for my typo), and then, execute the support tool.

Regards

Thank you, @davidg for the original version of httpd-app.conf; it resolved all the error messages and I was able to restart Apache successfully. I was also able to resolve my original certificate problem.

I am still unable to get a diagnostic code from the tool, however. The results I get from the tool are significant and I may need some help resolving the issues within, so I’d love to figure out how to get that code…

I followed your instructions: after making my repairs to Apache and ensuring I could start, stop, and restart the service, I stopped all services as you suggested.

bitnami@ip-172-26-8-2:~$ sudo /opt/bitnami/ctlscript.sh stop
Syntax OK
/opt/bitnami/apache2/scripts/ctl.sh : httpd stopped
/opt/bitnami/php/scripts/ctl.sh : php-fpm stopped
/opt/bitnami/mysql/scripts/ctl.sh : mysql stopped

The tool ran just fine, as far as I could tell. Still, no code. :slightly_frowning_face:

On second look, @davidg it seems the certificate issue is not completely resolved. The landing page of my site comes up, but none of the sub-domains. I think I know what I’ve done wrong…

Until next time… :wink:

1 Like

Hi @lillian.wight,

I’m glad you could advance solving some issues. Please don’t hesitate to contact us if you need more help.

Regards

Thank you, @davidg

Besides not getting a code from the Diagnostic Tool, my main issue is that I have a valid certificate for my Website but only the landing page will display. If I click a link I get the following error messages:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at you@example.com to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Two things to note:

  1. When I check the /opt/bitnami/apache2/logs/error_log, I get this:
    [Sun Sep 26 00:00:00.970010 2021] [mpm_event:notice] [pid 7002:tid 140555865040192] AH00493: SIGUSR1 received.  Doing graceful restart
    [Sun Sep 26 00:00:01.059729 2021] [mpm_event:notice] [pid 7002:tid 140555865040192] AH00489: Apache/2.4.46 (Unix) OpenSSL/1.1.1i configured -$
    [Sun Sep 26 00:00:01.059759 2021] [core:notice] [pid 7002:tid 140555865040192] AH00094: Command line: '/opt/bitnami/apache2/bin/httpd.bin -f $
    [Sun Sep 26 00:00:08.035659 2021] [mpm_event:notice] [pid 7002:tid 140555865040192] AH00493: SIGUSR1 received.  Doing graceful restart
    [Sun Sep 26 00:00:08.052654 2021] [mpm_event:notice] [pid 7002:tid 140555865040192] AH00489: Apache/2.4.46 (Unix) OpenSSL/1.1.1i configured -$
    [Sun Sep 26 00:00:08.052669 2021] [core:notice] [pid 7002:tid 140555865040192] AH00094: Command line: '/opt/bitnami/apache2/bin/httpd.bin -f $
    [Sun Sep 26 00:04:03.697089 2021] [core:error] [pid 9841:tid 140555732109056] [client 66.249.66.92:60376] AH00124: Request exceeded the limit$
    [Sun Sep 26 00:04:03.752483 2021] [core:error] [pid 9506:tid 140555623331584] [client 66.249.66.139:37001] AH00124: Request exceeded the limi$
    [Sun Sep 26 00:14:33.228809 2021] [core:error] [pid 9841:tid 140555740501760] [client 51.254.49.99:56291] AH00124: Request exceeded the limit$
    [Sun Sep 26 00:49:03.699783 2021] [core:error] [pid 9841:tid 140554792847104] [client 66.249.66.137:39811] AH00124: Request exceeded the limi$
    [Sun Sep 26 00:49:03.755872 2021] [core:error] [pid 9774:tid 140555706930944] [client 66.249.66.23:43213] AH00124: Request exceeded the limit$
    [Sun Sep 26 00:52:55.947199 2021] [core:error] [pid 9936:tid 140554516018944] [client 40.77.167.19:63808] AH00124: Request exceeded the limit$
    [Sun Sep 26 01:06:10.468752 2021] [core:error] [pid 9841:tid 140554776061696] [client 157.55.39.124:2496] AH00124: Request exceeded the limit$
    [Sun Sep 26 01:10:14.161318 2021] [core:error] [pid 9841:tid 140554650236672] [client 107.189.31.252:36500] AH00124: Request exceeded the lim$
    [Sun Sep 26 01:34:06.443495 2021] [core:error] [pid 9841:tid 140554524411648] [client 114.119.137.94:53794] AH00124: Request exceeded the lim$

…and it goes on like this, nothing but AH00124 codes, with a few different pids. When I check the pids, I’m pointed to the Bitnami banner display, which I did have trouble with when I disabled it.

bitnami@ip-172-26-15-49:~$ ps aux | grep 18797
root     18797  0.0  0.2 130096  8396 ?        Ss   20:16   0:00 /opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf -D
DISABLE_BANNER
bitnami  19345  0.0  0.0   6208   888 pts/0    R+   20:27   0:00 grep 18797
bitnami@ip-172-26-15-49:~$ 


bitnami@ip-172-26-15-49:~$ ps aux | grep 18797
root     18797  0.0  0.2 130096  8396 ?        Ss   20:16   0:00 /opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf -D
DISABLE_BANNER
bitnami  19345  0.0  0.0   6208   888 pts/0    R+   20:27   0:00 grep 18797
  1. The other thing to note is that when my antivirus program issues its own certificate for my website, all the links work fine. I can access any of the subdomains I choose.

Furthermore, @davidg, I’ve gotten the following error:

 bitnami@ip-172-26-15-49:~$ apachectl -t
AH00526: Syntax error on line 73 of /opt/bitnami/apache2/conf/bitnami/bitnami.conf:
SSLCertificateFile: file '/opt/bitnami/apache2/conf/server.crt' does not exist or is empty

Everything looks fine to me, however.

The bndiagnostic-tool results are now:

[Apache]

Found recent error or warning messages in the Apache error log.
```
[Mon Sep 27 20:38:20.365966 2021] [core:error] [pid 1105:tid 140489135036160] [client 209.
222.168.23:8064] AH00124: Request exceeded the limit of 10 internal redirects due to proba
ble configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. 
Use 'LogLevel debug' to get a backtrace., referer: https://mastcelladvanceddiagnostics.com
/
 [Mon Sep 27 20:38:20.796651 2021] [core:error] [pid 1106:tid 140489479137024] [client 209
.222.168.23:21608] AH00124: Request exceeded the limit of 10 internal redirects due to pro
bable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary
. Use 'LogLevel debug' to get a backtrace., referer: https://mastcelladvanceddiagnostics.c
om/about-us/
 [Mon Sep 27 20:38:44.575375 2021] [core:error] [pid 1515:tid 140489353246464] [client 209
.222.168.23:21586] AH00124: Request exceeded the limit of 10 internal redirects due to pro
bable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary
. Use 'LogLevel debug' to get a backtrace., referer: https://mastcelladvanceddiagnostics.c
om/sw.js

```
Please check the following guide to troubleshoot server issues:
 
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/

A high number of incoming requests originate from one or more unique IP addresses. This co
uld indicate a bot attack. The following guide shows how to check for and block suspicious
 IP addresses.
 
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/

I need to get it sorted right away. I profoundly hope you can help.

Hello @lillian.wight,

It seems you have a redirection loop. It is really difficult to debug without the logs provided by the support tool. Usually bnsupport errors are related to memory or storage, could you please share with us the output of the following commands?

sudo df -h
free -m

Note that WordPress need at least 700M of memory. You could try to increase your machine type if you face performance issues. This guide explains the process
https://docs.bitnami.com/aws/faq/administration/change-server-type/

The last message could make related to a bot attack, you can check the suggested link for more info.

Regards

Thanks so much, @davidg. I had seen that redirection was one of the possibilities; I appreciate very much having it confirmed.

Here are the results of the commands:

bitnami@ip-172-26-15-49:~$ sudo df -h
Filesystem      Size  Used Avail Use% Mounted on
udev            2.0G     0  2.0G   0% /dev
tmpfs           395M   11M  385M   3% /run
/dev/xvda1       79G  3.0G   73G   4% /
tmpfs           2.0G     0  2.0G   0% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           2.0G     0  2.0G   0% /sys/fs/cgroup
/dev/xvda15     124M  278K  124M   1% /boot/efi
tmpfs           395M     0  395M   0% /run/user/1000
bitnami@ip-172-26-15-49:~$ free -m
              total        used        free      shared  buff/cache   available
Mem:           3947         670        2664          59         612        3001
Swap:             0           0           0
bitnami@ip-172-26-15-49:~$ 

I was definitely having some memory shortages at the beginning, when I first posted. Since then I have enlarged my Lightsail instance dramatically; it really shouldn’t be a problem now.

Regarding the last message in the bndiagnostic tool, I’ve been chasing down the IP addresses one-by-one, and I’ve already blocked one from the list. :wink:

Thanks again for your help. I’ll be tackling the redirection while I wait for your response… It seems we are in different time zones. :slight_smile:

Hello @lillian.wight,

Thank you for your patience. We work from Spain.

Since you have a higher machine, the bnsupport should run properly. Could you please retry to use it in order to provide us with the necessary configuration and logs files? It would make it easier to check the current issue.

Regards

I have a code! It’s a48ae02b-ca89-bd33-bd02-601ded812e60

Here’s how I got it: first, I decided to follow the instructions here, hoping a new install might repair the tool. It did!

When I ran the tool I had an entirely new experience, including questions, advisories, etc. I knew this had fixed it, and sure enough, here are the full results:

===== Begin of bndiagnostic tool output =====

? Apache: Found possible issues
✓ Connectivity: No issues found
✓ Resources: No issues found
✓ Mysql: No issues found
✓ Processes: No issues found
✓ Php: No issues found

[Apache]

Found recent error or warning messages in the Apache error log.

[Mon Oct 04 20:08:34.535663 2021] [access_compat:error] [pid 2156:tid 
140127024129792] [client **ip_address**:48876] AH01797: client denied by server 
configuration: /opt/bitnami/apps/wordpress/htdocs/wp-cron.php, referer: 
https://mastcelladvanceddiagnostics.com/wp-cron.php?doing_wp_cron=1633378114.4335
041046142578125000
 [Mon Oct 04 20:08:34.582390 2021] [access_compat:error] [pid 2156:tid 
Press [Enter] to continue:
140127007344384] [client **ip_address**:48878] AH01797: client denied by server 
configuration: /opt/bitnami/apps/wordpress/htdocs/wp-admin/admin-ajax.php, 
referer: https://mastcelladvanceddiagnostics.com/wp-cron.php?doing_wp_cron=1633378114.4335
041046142578125000
 [Mon Oct 04 20:08:34.582390 2021] [access_compat:error] [pid 2156:tid 
Press [Enter] to continue:
140127007344384] [client **ip_address**:48878] AH01797: client denied by server 
configuration: /opt/bitnami/apps/wordpress/htdocs/wp-admin/admin-ajax.php, 
referer: 
https://mastcelladvanceddiagnostics.com/wp-admin/admin-ajax.php?action=as_async_r
equest_queue_runner&nonce=e95d8d168c
 [Mon Oct 04 20:09:06.034133 2021] [core:error] [pid 1818:tid 140126713599744] 
[client **ip_address**:5891] AH00124: Request exceeded the limit of 10 internal 
redirects due to probable configuration error. Use 'LimitInternalRecursion' to 
increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., 
referer: https://mastcelladvanceddiagnostics.com/sw.js

Please check the following guide to troubleshoot server issues:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-erro
rs-apache/

===== End of bndiagnostic tool output =====

Press [Enter] to continue:
The diagnostic bundle was uploaded successfully to the Bitnami servers. Please copy the fo
llowing code:

a48ae02b-ca89-bd33-bd02-601ded812e60

And paste it in your Bitnami Support ticket.
bitnami@ip-172-26-15-49:~$

I’m so excited - I know you’ll be able to help me now.

I can’t believe it - I had tagged you on my last reply but I see the tag is gone now. Oops!

Hello @lillian.wight,

I’m glad you finally could run the support tool.

First of all, I can access your site. Probably you would like to configure the domain properly. This documentation may help:
https://docs.bitnami.com/aws/apps/wordpress/administration/configure-domain/

Could you please follow it? If after that you still face errors, please let us know the exact issue (error message, steps to reproduce it…), and send a new support tool output with the latest changes.

Regards

Hello, @davidg I hope your day went well!

Here are the latest results from the tool, now that I’ve made the change to the wp-config.php file.

===== Begin of bndiagnostic tool output =====

? Apache: Found possible issues
✓ Connectivity: No issues found
✓ Resources: No issues found
✓ Mysql: No issues found
✓ Processes: No issues found
✓ Php: No issues found

[Apache]

Found recent error or warning messages in the Apache error log.

[Wed Oct 06 17:18:28.417089 2021] [core:error] [pid 1498:tid 139931737270016] 
[client **ip_address**:38303] AH00124: Request exceeded the limit of 10 internal 
redirects due to probable configuration error. Use 'LimitInternalRecursion' to 
increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., 
referer: https://mastcelladvanceddiagnostics.com/
 [Wed Oct 06 17:18:36.978346 2021] [core:error] [pid 1498:tid 139931720484608] 
Press [Enter] to continue:
[client **ip_address**:38630] AH00124: Request exceeded the limit of 10 internal 
redirects due to probable configuration error. Use 'LimitInternalRecursion' to 
increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., 
referer: https://mastcelladvanceddiagnostics.com/
 [Wed Oct 06 17:18:37.421126 2021] [core:error] [pid 1092:tid 139930697131776] 
[client **ip_address**:38655] AH00124: Request exceeded the limit of 10 internal 
redirects due to probable configuration error. Use 'LimitInternalRecursion' to 
increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., 
referer: https://mastcelladvanceddiagnostics.com/about-us/

Please check the following guide to troubleshoot server issues:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-erro
rs-apache/

===== End of bndiagnostic tool output =====

Press [Enter] to continue:
The diagnostic bundle was uploaded successfully to the Bitnami servers. Please copy the fo
llowing code:

70acc4f9-cb07-68a0-a10a-dc8c7e87a744

And paste it in your Bitnami Support ticket.
bitnami@ip-172-26-15-49:~$

It’s pretty much the same as before, except for the very last item which reflects what happens every time I try to switch away from my landing page to a secondary page. In this case, it reflects what happens when I tried to switch to the About Us section of the site.

I believe I’ve accidentally set up two redirections because I tried to use the Bitnami instructions for a Lets Encrypt certificate before finally getting the Amazon instructions to work. I hope for some direction that will guide me to the right file to make the right changes. I’ll keep working on it until we get this figured out.

Thanks, David!

Also, @davidg , I have the following code, generated after I did some troubleshooting, trying to reverse any changes made from using the bncert-tool, which I did before following the instructions here: https://lightsail.aws.amazon.com/ls/docs/en_us/articles/amazon-lightsail-using-lets-encrypt-certificates-with-wordpress#renew-a-lets-encrypt-certificate-wordpress

I deactivated and reactivated the Really Simple SSL plugin, then I ran the diagnostic tool to get this code:

b96e3b69-49dc-9d05-cf50-f21b9cf5af92

Hello @lillian.wight,

I can see the main issue is:

Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., refe\
rer: https://mastcelladvanceddiagnostics.com/about-us/

I would remove the really simple SSL related code and disable really-simple-ssl and really-simple-ssl-pro plugins since the Apache configuration and the plugins may have some conflicts. Remove the really simple SSL code from /opt/bitnami/apps/wordpress/conf/htaccess.conf and restart apache. Also please try setting the domain in wp-config.php:
https://docs.bitnami.com/aws/apps/wordpress/administration/configure-domain/

Please let us know the results after these changes.